Previous 1 4 5 6 7 8 Next 115 Replies Latest reply: Sep 21, 2012 1:07 PM by ie11 Go to original post
  • Stan52 Level 1 Level 1 (35 points)

    Folks,

     

    You can try deleting Aperture and then downloading the previous version here

    http://support.apple.com/downloads/#aperture

     

    Since I didn't purchase through the App Store, I can't download from there.

    I haven't tried this. since I can wait a day or two for Apple to fix it. That's what I plan to do.

    Good luck.

  • Goody64 Level 1 Level 1 (10 points)

    Where in the library folder?  Is it in a particular folder within Library?  What's the complete path so I can locate it.

  • léonie Level 9 Level 9 (63,925 points)

    Is it in a particular folder within Library?  What's the complete path so I can locate it.

    Are you asking about the Aperture preferences file? It is in your Home folder.

     

    The User library is hidden in MacOS Lion and later, so use the Finder's "Go" menu:

    Finder > GO    hold down the "Options" key, until the library appears in the menu, select it.

     

    The path to the preferences:

    ~/Library/Preferences/com.apple.Aperture.plist

  • Mtn Ed Level 1 Level 1 (0 points)

    UPDATE: Found the hidden library and moved com.apple.aperture.plist to my desktop. Aperture opened without error this time and I pointed it to the correct library. All is well for now. Cost me 3-4 hours to sort out and thanks to those who suggested this fix.

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Hi Mtn Ed, if you look through this thread, removing the plist may not be a permanent fix for the issue. If you re-enable FaceBook you may run into the issue again.

     

    The best solution would probably be to re-install Apetrure and then update to 3.4 if you bought a physical copy of Aperture, or just delete and re-install 3.4 from the Mac App Store if you bought the app there.

  • Trevor Harley Level 2 Level 2 (365 points)

    Aperture 3.4 crashed repeatedly on start up and deleting the plist file worked for me.

     

    Shoddy upgrade though. My mother would have been terrified.

  • jhave Level 1 Level 1 (0 points)

    Same story here. Didn't buy from App store but have been around since early versions on DVD.

     

    Same library opens fine in iPhoto, but Aperture is crashing no matter what I do. Not very Mac like... :-/

     

    Looking forward to the 3.4.1. patch.......

  • Clem Level 3 Level 3 (550 points)

    @jhave  Why wait? Just reinstall/reupdate and you are good to go?

  • Goody64 Level 1 Level 1 (10 points)

    I may have already asked, but where in the Library folder can I find com.apple.Aperture.plist ?  What's the path to get to it?

  • dosers Level 2 Level 2 (390 points)

    Worked great - thanks.

    And it lasted. While deleting the plist would make the issue re-appear, uninstalling completely and re-installing from DVD, then updating fixes it, and even makes FB integration work.

     

    Hard to believe Apple is still pushing the update as is and hasn't removed it yet for a fix....

     

    Thanks all.

    Dan

  • jhave Level 1 Level 1 (0 points)

    Well, reinstall what? I don't have the DVD, password and all that crap anymore. Could just buy a new version from the App store (paying only 63 EUR) and I would be OK... I suppose.

  • Aye Es Oh Level 2 Level 2 (330 points)

    Goody – The answer is, don't delete your plist. Delete Aperture from your /Applications folder and reinstall it.

  • léonie Level 9 Level 9 (63,925 points)

    I don't have the DVD, password and all that crap anymore

    If you can get Aperture to run for a moment - from a different user account, or on a new empty library, you can see your Aperture serial number in the about panel in the main menu bar:

    Aperture > About Aperture

     

    If you do no longer have the install DVDs, use the Trial Download:

    Try if this download link for the trial version still works: if yes, you can unlock it with your serial number:

     

    http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Aperture/061-8328 .20101020.AprE3/ApertureTrial3.1.dmg

    Regards

    Léonie

  • Trevor Harley Level 2 Level 2 (365 points)

    JUST deleting the plist seems to have worked fine for me, over several hours and restarts. So far. What causes the issue to reappear?

  • Trevor Harley Level 2 Level 2 (365 points)

    Goody64: The plist preferenes are hidden in User/Library/Preferences. You'll have to use something to show hidden files - I use Pathfinder. But note it is not working for everyone! It seems the easiest fix to try first though.

     

    I imagine the Aperture team are being flooded with crash reports at this very moment.

Previous 1 4 5 6 7 8 Next