Skip navigation

Aperture 3.4 will not open.

10612 Views 115 Replies Latest reply: Sep 21, 2012 1:07 PM by ie11 RSS
  • Tim Campbell1 Level 3 Level 3 (570 points)
    Currently Being Moderated
    Sep 20, 2012 12:58 PM (in response to asrermd)

    I just had the same problem on two different Macs.  I phoned AppleCare.

     

    They know about the bug.  They believe it impacts people who previously used MobileMe with Aperture (I did).  My other half didn't have the upgrade problem, but my other half also didn't use Aperture with MobileMe.

     

    I was fearful that, since it said a library upgrade was required, that it damaged my library.  Turns out the library upgrade was fine and all photos were fine.  The issue is a .plist file corruption, but that's very easy to fix.

     

    The fix is:

     

    Close all apps.

    Open Finder.

    Hold the "alt" key on the keyboard and click the "Go" pull-down menu (in finder) which causes the "Library" folder to appear (the "Library" folder wont be in the list if you aren't holding down "alt".)

    Pick the "Library" folder.

    Navigate to the "Preferences" sub-folder (under Library)

    Find the file named "com.apple.Aperture.plist" and drag it to the Desktop (you can drag it anywhere as loing as you get it out of the ~/Library/Preferences folder. 

    ALSO... if you have a "com.apple.Aperture.plist.lockfile" (and you probably will) then you need to drag that file out of the Preferences folder (e.g. drag it to the Desktop) as well.

     

    NOW start Aperture.

     

    You'll probably get a message that the last time you tried to run it, it kept crashing.  Just click continue.

     

    Since you've moved the preferences file, you will get a few prompts that you're not used to seeing (I think you get a screen offering to give you an overview/tutorial, you'll be asked if you want to use it when a camera is connected to the Mac, and you'll get a prompt asking if you want it to show you were photos were taken on a map (which requires an interaction with Apple which would send the GPS coordinates of all your photos to them.)  Aperture will create a fresh .plist file (non-corrupt.)

     

    After that, Aperture will work normally again.

     

    Once you've verified that Aperture is working, you can delete the copy of the old (corrupt) .plist files that you sent to your desktop.  Just drag them to the trash.

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Sep 20, 2012 12:57 PM (in response to Trevor Harley)

    JUST deleting the plist seems to have worked fine for me, over several hours and restarts. So far. What causes the issue to reappear?

    That will depend on the reason for the crash:

    For example, for some posters the reason for the crash is a missing or outdated framework in the library, that is needed, when uploading to Facebook. Removing the preferences removes the Facebook account from Aperture's web preferences and stops Aperture trying to connect to Facebook. As soon as you add the account again, Aperture will crash again.

  • jhave Calculating status...
    Currently Being Moderated
    Sep 20, 2012 1:11 PM (in response to jhave)

    My big library has showed up in Aperture 27,0000+ photos with Faces, Places intact. Phew...

  • johannes.bredner Calculating status...
    Currently Being Moderated
    Sep 20, 2012 1:14 PM (in response to léonie)

    I had the same problem and phoned apple care too. I also had to delete the Photomatix Plugin. To do that read here:

    http://www.hdrsoft.com/support/faq_applugin.html

    I deleted the plist plugin as described above and opened a small Aperture Library sucesscfully, then deleted the Photomatix plugin. Then reopend my big library an after that i could repair my old database and Aperture opened normally. Also look at these supprt messages:

     

    http://support.apple.com/kb/HT3805?viewlocale=de_DE

     

    http://support.apple.com/kb/TS4391?viewlocale=en_US

     

    Good luck.

  • Mtn Ed Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 1:17 PM (in response to Tim Campbell1)

    Tim,

    Thanks for your clear details. I was a MobileMe and Aperture user. I seem to be working with just removing the plist. Did not remove the lockfile and a bit scared of fooling around any more.

  • Ivor Janci1 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 20, 2012 1:46 PM (in response to asrermd)

    I was a MobileMe and Aperture user, too. I followed the suggestion to just trash Aperture 3.4, then reinstall an older version…working fine now. See <https://discussions.apple.com/message/19648600#19648600>.

     

    Ivor

  • faxao Calculating status...
    Currently Being Moderated
    Sep 20, 2012 2:54 PM (in response to Tim Campbell1)

    Thank you very much, you made my day ! Your fix worked flawlessly for me........

  • Ir. Bob Level 2 Level 2 (320 points)
    Currently Being Moderated
    Sep 20, 2012 3:02 PM (in response to asrermd)

    I never used MobileMe, but the bug still hit me. I firmly believe this is a Facebook issue. Since deleting the plist-file worked for me. Further tested this by editing the plist file as suggested by thom_ek Aperture will open fine with the edited plist.

     

    BTW you may need to convert your plist for editing by using a terminal command:

     

    plutil -convert xml1 [Drag in your plist here and hit enter]

     

    Although I did disable Facebook in system preferences before deleting the plist file, re-enabling it did not cause any problems. So my belief is that the issue is in the plist-file.

  • Stan52 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 20, 2012 3:33 PM (in response to Ir. Bob)

    Folks,

     

    Got a way to fix this from Apple Support. I had posted the problem to feedback. Received an e-mail from David.

     

    Here are the steps David recommended to me. They seem, to have worked.

     

    Delete Aperture App

    Download trial version from here Aperture 3.1 Trial

    Install

    Download 3.4 update from here http://support.apple.com/downloads/#aperture

    Install

     

    When I opened Aperture, it repaired the library. Seems to be okay now.

  • Proggie Level 4 Level 4 (1,300 points)
    Currently Being Moderated
    Sep 20, 2012 3:46 PM (in response to Stan52)

    Did you lose your preferences when you did this?

    Does the facebook integration still work?

     

    I'm hesitating doing any workarounds because I don't want to lose settings. I'm hoping Apple will release a fix soon since they know about this issue.

  • Stan52 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 20, 2012 3:49 PM (in response to Proggie)

    Proggie,

     

    No. Only issue so far, I tired to upload 20+ photos to Facebook and Aperture crashed. I then restart Aperture and the uploads have been fine. so there may still be a Facebook issue there.

  • Stan52 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 20, 2012 4:07 PM (in response to Stan52)

    Folks,

     

    Still having periodic crashes when uploading to Facebook. Out of about 12 tries, 2 crashes.

  • kaz78 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 4:57 PM (in response to Stan52)

    Aperture is working fine for me after removing the com.apple.Aperture.plist from my user/Library/Preferences/ I posted earlier, but when trying to use Facebook, it continues to crash.

     

    Now I am wondering, no matter what fix you used, for those who use Facebook via Aperture 3.4, is there anyone that is able to use it without crashing a single time? If yes, please explain, what you did to resolve the issue.

     

    I bought Aperture 3 on a DVD (not on the App Store), but don't have it with me right now, as I am on a business trip overseas. I do have my serial on file. (I will have access to my DVD in a week from now again, but am hoping to fix this problem quicker).

  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Sep 20, 2012 5:09 PM (in response to kaz78)

    I bought Aperture 3 on a DVD (not on the App Store), but don't have it with me right now,

    You do not need your DVD, to try the fix Stan described:

    Re: Aperture 3.4 will not open.

     

    Download the Aperture 3.1 Trial installer ( Aperture 3.1 Trial) and then upgrade again immediately, before launching Aperture.

    MacBook Pro, OS X Mountain Lion, 2.4 GHz I.Core i7, 16GB RAM, 500GB
  • kaz78 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 5:13 PM (in response to léonie)

    @leonieDF: And you are now able to use Facebook via Aperture without any problems?

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.