8 Replies Latest reply: Dec 6, 2012 10:59 PM by EMacApple1
trocotronic Level 1 Level 1 (0 points)

Dear forum,

 

I recently updated to OSX 10.8.2 and I want to link iMessage with my iPhone number but I can't. I add as an email my phone number with country prefix plus + sign but I do not receive any sms or code verification. I read that this process shall be done automatically but this is not my case. So, how can I add phone number to OSX 10.8.2 iMessage? Am I doing something wrong?

 

Thanks for your time.


iMac (27-inch Mid 2010), OS X Mountain Lion (10.8.2)
  • Parcileon Level 1 Level 1 (5 points)

    I am having this same problem.  I also went into apple ID settings and made sure my phone number was in the account.  Added it as my mobile number just to be succinct but no luck....

  • Anyonebutromney Level 1 Level 1 (10 points)

    This worked for me just now. Several steps, and maybe they're not all necessary. The goal is, when in Messages (not iMessage anymore!) preferences, to have the option to select your mobile phone number. Don't bother trying to put the mobile number in the email field:

     

    1. Add your mobile number to your AppleID (appleid.apple.com). Make sure it's in the Mobile field, not Phone or something else.

     

    2. On your iPhone go to Messages settings. Remove email addresses if there are any. Turn off messages entirely.

     

    3. Go to your 10.8.2 Mac. Try Messages preferences. Hopefully the number is there.

     

    And actually there was a lot of waiting, repeating, and restarting in and around each step here. Messing with the iPhone was the last thing I tried. When I went back to Messages on the Mac for the 23rd time the mobile number was there.

  • trocotronic Level 1 Level 1 (0 points)

    I would also add a four step:

    4.- When you turn on iMessage on your phone, it should appear in Messages a request to add your mobile number.

     

    Thank you so much Anyonebutromney.

  • dasocrplar Level 1 Level 1 (0 points)

    I tried  4 or 5 times to perform the aforementioned steps with no luck.  Would Apple really have made this so difficult when they were touting how easy it was for your number to be the single interface between io6 and 10.8.2?  I know we can't all be california girls, but this one should be easy for a person using OS X since '05 and original iOS.  Please help.

  • mw. Level 1 Level 1 (0 points)

    I was having trouble with this and got it to work just by trying to add a new (legitimate) email to my iCloud account in Messages.app settings on 10.8.2.  The act of trying to add a new email prompted me to reauthenticate my iCloud account; upon entering my password, the settings now had a checkbox to enable my phone number.

     

    I think that simply the reauthentication on the Mac may be the secret.

  • dasocrplar Level 1 Level 1 (0 points)

    mw.,

     

      Thanks.  Disabling the account in iMessage's preferences and signing out may have been what did it.  Appreciate it.

  • Cristian T Level 1 Level 1 (0 points)

    Adding a new address in iOS on the iphone is what made the phone re-register with imessages and my phone number also appeared on my macbook.

  • EMacApple1 Level 1 Level 1 (0 points)

    These steps work.  When I signed into manage my Apple ID, my cell phone number wasn't under mobile.  And after doing all those steps, the last step that resulted in the Mac iMessage recognizing my phone number was to sign out of iMessage on my mac and sign back in.

     

    Thanks.