Previous 1 2 3 4 5 Next 173 Replies Latest reply: Sep 25, 2013 10:35 AM by JoeNA612 Go to original post
  • WZZZ Level 6 Level 6 (12,650 points)

    I made  a copy of the "Mail (original)" file, renamed it, & ran the update again.

    No, doing that changed the Permissions on Mail.app. When you move a file or folder owned by the system using the Finder, the Permissions get changed.  Get BatChmod to do this.

     

    http://www.lagentesoft.com/

     

    Drag Mail.app into the upper field next to File and set it up like this. Then hit Apply. Do not check "Apply to enclosed..." Or any other boxes in the screenshot, except Change Ownership and Privileges.

     

    Or just do a Permissions repair from Disk Utility and see if that fixes it. Inspect the messages you get from Permissions repair and be certain there's one about Permissions for Mail.app being repaired. Disregard all the other messages you get. When finished, drag Mail into BatChmod and see if they match the screenshot below. If they do, just quit BatChmod.

     

    Screen shot 2012-09-21 at 7.49.56 AM.png

     

     

    You should trash the smaller Mail, the one with the generic icon (don't empty the Trash just yet.) Leave only the one with the proper icon in Applications.

     

    There is now no enclosing folder, so don't worry about that.

     

    See if Mail will open now. If not, then run the update once again.

  • 007Charlie Level 1 Level 1 (0 points)

    Senior tech at Apple suggested 2 things (didn't seem to know about Mail not in the App Folder or running the updater again). Anyway, one was reinstalling the OS altogether (which is a real pain !) the other one, which I have not tested is this:

    - Insert the installation disk in the toaster

    - Restart and press the letter C (to boot from the disk)

    - Choose your language

    - Open Mac Utilities

    - Open reset password

    - Bottom of the page Reset ACL

  • WZZZ Level 6 Level 6 (12,650 points)

    As far as I can tell, his suggestion doesn't make any sense at all. This issue has nothing to do with the login or admin password. And don't know why ACLs would be involved -- it is possible, though, if Mail was moved out using the Finder, that that would have changed the ownership and Permissions of Mail.app. Anytime you use the Finder to move a system owned file, which Mail is, the user replaces the owner in the Permissions, and, perhaps, but not certain of this, the ACls get modified as well.

     

    The problem is people have moved Mail out of the Applications folder where it belongs and needed to stay and the update couldn't find it.

  • 007Charlie Level 1 Level 1 (0 points)

    Tha'ts exactly what I thought. But then again, he was Senior Tech at Apple ! Go figure...

  • WZZZ Level 6 Level 6 (12,650 points)

    Techs, senior techs, whatever, they all want to sound as if they know what they're talking about. They can't just shut up and say I don't know, let me find out.

  • Smartio Level 1 Level 1 (0 points)

    As I had sucess with another workaround, let me repeat in other words.

     

    I think the initial cause is clear: Before starting Security Update 2012-004, Mail was located in a different folder than 'Applications' or was renamed.

     

    1. My workaround: Tinker your 4.6 version with the files that Security Update delivered (about 8,1MB). To do that, just right-click (ctrl-Click) on the Application to see the Package Content. Then just exchange all the files (not the complete folders!) of the new version to replace the Package Content-files of the old version.

    Now you have no mor error message and 4.6 running, despite clicking on the Application it says 4.5.

    Absolutely no re-installation of Security Update was necessary and it works fine.

     

    2. Suggestion to patriciados or if you want to re-install: If you can't rename the prior working version Mail(original), try it as root-User, then change the permissions as WZZZ said above.

  • WZZZ Level 6 Level 6 (12,650 points)

    Very interesting. Hope it works for everyone.

     

    Suggestion to patriciados or if you want to re-install: If you can't rename the prior working version Mail(original), try it as root-User, then change the permissions as WZZZ said above.

     

    But renaming it to "Original" won't bring back the correct Permissions. And another rename from the Finder will mess up the Permissions, if they were correct, which they are not right now. No need to enable the root user if using BatChmod. And without BatCmod, could do it with sudo chown from Terminal. BatChmod's UI makes it easy.

  • patriciados Level 1 Level 1 (0 points)

    I can't tell you how much I appreciate your aking the time to try and help me.  Thank you.

     

    WZZZ, after I've had enough coffee to feel brave, I'll follow your instructions on fixing the permissions.  Should I do this on the new renamed copy or the Mail(original)? I stil have the original one, it's just on my desktop.

     

    Smartio, here are the package contents of the existing mail app on the top & the new one on the bottom.  If I'm understanding you right, I replace all of the older files with the newer ones with the same name & leave the rest alone.

     

    I did notice something odd when I looked at these, the existing mail app has an extra CodeResources file. Do I leave it or delete it?

     

    pat

     

    Screen shot 2012-09-21 at 10.26.00 AM.png

     

     

     

    Screen shot 2012-09-21 at 10.23.08 AM.png

  • WZZZ Level 6 Level 6 (12,650 points)

    First, before trying the workaround, just run Permissions repair. If the smaller, newer one is in the Trash (don't empty it), Permissions repair won't see it and it will only repair the larger, renamed original. That's the one that needs repair. Then see if Mail will open. If it still doesn't, I'd take the more conservative route (after checking with BatChmod to see what the Permissions look like, as compared to the ones in my screenshot; but, note, if they look good, you are not using BatChmod to change anything -- you're just looking). Then run the Security Update from the standalone once again. Someone reported success by running the 10.6.8 Combo update first and then the Security Update.

     

    As for the workaround, which I'm still not sure of, for now I think I'd leave the second Code Resources. It's an alias; you can right click on it to show the original. It may need that.

     

    I'm also seeing MailTimeMachineHelper in the original and not in the new one. I'd leave that too. You also haven't clicked the disclosure triangle for Resources in the original.

  • WZZZ Level 6 Level 6 (12,650 points)

    Before recommending you proceed with the workaround, I want to compare the package contents of Mail from a clone/backup made before running the update and those from after running the update.

     

    I might also have misread what you wrote before about the enclosing folder for Mail. Mail.app should be sitting by itself in Applications. You shouldn't need to click on a disclosure triange to get to it. If you do, then it's sitting inside another folder, which you should trash. The one with the arrow should be trashed.

     

    Screen shot 2012-09-21 at 12.28.06 PM.png

  • Pops64 Level 1 Level 1 (0 points)

    thank you 1million times for this fix ... I was pullin my hair out after this latest download and my mail just quit . I was on the phone with Mac for an hour and 2 call backs with NO results. I'm glad someone around here knows what is goin on !!! Thankx again .

     

    Pops 64

  • WZZZ Level 6 Level 6 (12,650 points)

    The Security Update updated Mail 4.5 to 4.6 The first screenshot is the old 4.5 Mail. The second is the new 4.6 Mail.

     

    Screen shot 2012-09-21 at 12.52.08 PM.png

     

    Screen shot 2012-09-21 at 12.53.57 PM.png

     

    It looks like you don't need the CodeResources that isn't showing the alias. You can remove that one. I don't think you need to replace the Resources folder at all. Think they're the same. You need the TimeMachineHelper.app from the old one, since your new one appears to be missing it. I think Plugins stays the same. Don't replace that one. In fact, anything dated '09 appears to stay the same. Comparing my two, before and after, I'd only replace files  showing  a different modified date.

     

    If all the contents of a folder have the same modified date, you can just replace the entire folder.

     

    I would also run Permissions repair after doing this.

     

    Message was edited by: WZZZ

  • patriciados Level 1 Level 1 (0 points)

    I've re-installed the update 3 times since I last posted, I changed the permissions (thanks for leading me by the hand through this), deleted the Mail folder & as well as the small mail folder.  I just saw your two most recent posts... this is what I have now.

     

    The old mail folder, which still brings up the error message

    Reg Mail 2012-09-21 at 12.03.44 PM.png

    The new mail folder, which doesn't open

     

    New Mail 2012-09-21 at 12.04.49 PM.png

    By the way, I didn't expand the original  mail resources folder because it is very, very long.  So, if I am  understanding you correctly,  I should now copy all of the May 31 files from the new mail to replace  their counterparts in the old mail?    ...and then do a permissions repair exactly the same way I did before?

     

    pat

  • WZZZ Level 6 Level 6 (12,650 points)

    I think both of us are beginning to feel spun around and dizzy by now. I think if I were right there, I could probably find a way out of this morass, but doing this long distance doesn't seem to be working.  What I think might be best is for you to just reinstall Mail from the Snow Leopard install DVD. I think it's part of the Optional Installs, so you only have to reinstall that. If it's not in Optional Installs, you could use a program called Pacifist.

     

    Post back if you want instructions for using Pacifist and the link to get it.

     

    But, if it's not in Optional Installs, then rather than get into that, you might be better off just reinstalling Snow Leopard (that's not an erase and install, you just chose the install option and let it run) -- this should save all your third party programs and settings, by default. This will give you Snow as of the version on the DVD. Then update what's needed again using Software Update and get back to 10.6.8 from the Combo update.

     

    Having a backup before doing this is preferable. In fact, having a backup in the form of a bootable clone or Time Machine is absolutely necessary, since drives can fail at any moment without warning. If you had done a backup before running the Security Update, you could simply have restored that and saved yourself a lot of grief. I always make a new backup (clone) before running any serious updates like a  Security Update.

     

    Also, hard lesson learned: don't move folders out of where the system places them.

     

    Let me know how this works out for you.

  • patriciados Level 1 Level 1 (0 points)

    Spun around & dizzy is a beautiful way to describe it!

     

    The irony in all this is that I always keep  Time Machine on & have since I got the computer.  A few days ago the external HD dedicated to it failed.  My new drive was delivered this morning & a back up is running as I write. Since I'm a photographer, this is going to take a while, but once the backup is complete, I'll reinstall the Mail application.  The photos, by the way, are backed up 3 different ways.

     

    Thanks again for spending all this time with me. Someone really should nominate you for sainthood.

     

    pat

Previous 1 2 3 4 5 Next