13 Replies Latest reply: Feb 20, 2013 10:29 AM by Looli Lo
IainFC Level 1 Level 1 (0 points)

I don't seem to be able to turn on share photostream on my ipad after updating to ios6 - the option doesn't exist.  Any ideas?


iPad 2 Wi-Fi, iOS 6
  • Douglas McLaughlin Level 9 Level 9 (63,740 points)

    Have you enabled iCloud in the Settings first? The shared photostreams are shared through Apple's iCloud. Then in the sub-section for Photo Stream under iCloud there's an option to enable "My Photo Stream" as well as a second option to enable "Shared Photo Streams".

     

    -Doug

  • IainFC Level 1 Level 1 (0 points)

    Hi Doug

     

    Don't know why but the option wasn't there but oddly enough it appeared on my iPad once I had upgraded my iPhone to iOS 6 - very odd!

     

    Thanks for your help

     

    Iain

  • Duncan Hume Level 1 Level 1 (0 points)

    Same thin has happened to mine. Wasn't even sure if it was supposed to work on the iPad!

     

    I upgraded my phone first so can't try Iain's solution.

     

    I did a full restore and still no shared photostreams!

     

    How frustrating.

  • felixgroos Level 1 Level 1 (0 points)

    same with my 4s

  • Schmidti1981 Level 1 Level 1 (0 points)

    You actually need to enable shared ps in the 'Photos and Camera' settings.

  • Duncan Hume Level 1 Level 1 (0 points)

    That's the problem the option is not there.

     

    If I try subscribe to one shared by a friend (via email invite) it tells me to turn it on and takes me to the settings, but the option is still not there!

  • jostrasser Level 1 Level 1 (0 points)

    Hi, same here.

     

    The complete option is missing in the settings of "Photos and Camera", also in the "iCloud" settings!!

    That´s the problem on an 4S here.

     

    The second problem:

    If I want to share a shared photostream album with an iPhone 4, the iPhone 4 get´s only a mail to join, but cannot join it! It happens nothing if the other iPhone try to push the button to join in the email.

     

    I try it also with a different iPhone, all works fine! This iPhone doesn´t get a mail, only a push message to join.

    That´s perfect!

     

    I think, there are many bugs in this feature.

     

    Thanks, Jo!

  • Rob Futcher Level 1 Level 1 (0 points)

    I had the same problem where the option wasn't appearing on my iPad under 'photos and camera' settings.. However, the solution for me was to go to the 'iCloud' settings and turn it on there first. Then the option appears in 'photos and camera' settings. After turning those both on, I've had no problems. Hope that helps somebody.

     

    Rob

  • Duncan Hume Level 1 Level 1 (0 points)

    So I think I have the solution.

     

    I went to the iCloud prefs but all that was ok. The photostream was switched on but the setting for shared photostream in Photos & Camera did not exists. I tried switching off photo stream, then switching it back on, but that didn't work either.

     

    The solution was to delete the iCloud account from the iPad, using the big red Delete Account button in the iCloud prefs. Then sign back in to iCloud. The shared photostream settings now appear in Photos & Camera.

     

    Sorted!

     

    Duncan

  • jostrasser Level 1 Level 1 (0 points)

    Hi!

     

    The solution of Rob works for me...

     

    At first, disable the complete Photostream in "Photos and Camera", then re-enable it in the iCloud settings.

     

    Since that all works fine now!

     

    Thanks very much!

     

    Jo!

  • faizanzaveri Level 1 Level 1 (0 points)

    Had the same problem. The following helped me:

     

    First turn off Photo Stream in settings>photos and camera. (This will automatically turn off photo stream in iCloud settings). Turn on the photo stream in the iCloud settings, settings>iCloud>photo stream. The shared photo stream should appear then.

     

    Thanks,

    Faizan.

  • Aasim Level 1 Level 1 (0 points)

    Thanks a lot Duncan Hume.Solution provided by you worked for me!

     

    I was having the same problem. On my iPhone 4S, the shared photo stream option was not showing up under iCloud --> Photo Stream and Photos & Camera settings. When I restored the phone and set it up as a new phone, the option would appear. But when I restored it with my recent backup, the option ould diappear. Setting it up as a new phone wasn't an possible for me as I had some messages and other data that was important to me. I also checked by disabling the complete photo stream and re-enabling it but that didn't work either.

     

    After reading your post, I deleted my iCloud account (Settings -> iCloud -> (scroll down to the bottom) -> Delete Account).

     

    After this shared photo stream option appeared in my iCloud & Photos and Camera settings. Logged in again to iCloud and now it works!

     

    I guess someone can also try by logging out of the iCloud account instead of deleting the account itself.

  • Looli Lo Level 1 Level 1 (0 points)

    Tried every suggested solutions on the thread, still didn't help on iPhone, iOS 6.1.2

     

    When I deleted my iCloud account from iPhone, the Shared Photostream option appeared in the Photos and Camera settings, but when I logged in again, it dissappeared...