9 Replies Latest reply: Feb 14, 2014 9:21 AM by Quziesue
rsemerau Level 1 Level 1 (0 points)

I have an iPhone 3GS, and I downloaded and installed iOS 6 today when I came home.  It has been fine, except for the whole Passbook issue which most people seem to be having, but I fixed that.  I cannot figure out why my picture texts don't send though. My iMessage pictures send. MMS is on, data is on. Any suggestions? Thanks(:


iPhone 3GS
  • CASSIEwithPPOBCC Level 1 Level 1 (0 points)

    I want help with this too.  iMessage works fine, regular SMS works but when I try to send a MMS to a non-iPhone it won't work.

     

    I'm also running iOS 6 on my 3GS, which I like so far except this problem!

  • shady13 Level 1 Level 1 (10 points)

    Because apple doesnt care about you for the next 2-3 months since you are not payign them $700 for the new phone you get to use one that doesn't work. Welcome to the next generation.

  • rsemerau Level 1 Level 1 (0 points)

    Yeah, I know apple doesn't care, and it really ****** me off.  The only reason I'm keeping ios 6 is for the do not disturb feature. That's the only thing the 3gs got out of this, we don't get any of the features on the new map app, for some reason. It's not really like our phone's not capable of it, but whatever. Sometimes I think apple purposely adds these bugs in to try and get people to buy a new phone.  They're terrible.

     

    Anyway, if somebody has to know how to fix this, since clearly more people than just me have this problem.

  • ckuan Level 7 Level 7 (24,800 points)

    Talk to your carrier, SMS and MMS are managed by the carrier.

  • rsemerau Level 1 Level 1 (0 points)

    Yeah, but it worked until ios 6. I didn't get a new phone, new number, or anything. This is apple's fault, not att.

  • ckuan Level 7 Level 7 (24,800 points)

    Did you switch in Settings > Messages > Show Subject Field : OFF?

    If it's ON switch it OFF.

  • Shooshoo Level 1 Level 1 (0 points)

    I have an iPhone 5 through sprint and I'm having the same issue, through anything but wifi I can't send pictures? *** gives here? I want my iPhone 4 back! Just kiddin

  • tiggerx Level 1 Level 1 (0 points)

    That happened to me. I fixed it by going to Settings > Messages > MMS Messaging: ON

  • Quziesue Level 1 Level 1 (5 points)

    not sure what carrier you are using but i use straighttalk and had same issue, mms was on! tried everything and this finally worked....here is how i resolved it

     

    1. delete any profiles you have saved settings>general>profile  delete if you see profile there if not go to step 2

    2. turn on wifi (my internet was also not working)

    3. open safari

    4. type iapnupdatetfdata.straighttalk.com

    5. download profile

    6. turn off wifi

    7. turn off phone

    8. turn on phone

     

    my internet and pictures worked after this, any user, any carrier, no issues....hope this is helpful!