10 Replies Latest reply: Jan 29, 2013 9:00 PM by wv
chriskidd Level 1 Level 1 (0 points)

My iphone 4s won't connect to my home wifi after ios 6 update. 


iPhone 4S, iOS 6
  • Just30Ltd Level 1 Level 1 (0 points)

    Same here - after updating to IOS 6 on my iphone 4s 16gb it refuses to connect to my home wifi and tries to log into apple.com but gets a failed to find page message - strangely, my partner has the same phone on the same network and updated just before I did mine and her phone works fine - am updating my ipad 2 and am wondering if I have the best part of a grand's worth of kit that won't connect to wifi thanks solely to IOS 6 update - I hope that apple provides a solution quickly as this is not putting apple in a good light at the moment with me...

  • PatrickHee Level 1 Level 1 (0 points)

    I had the same problem. I kept getting directed to a login for www.apple.com. It could not find it. I kept trying to log into my wifi and it kept turning off each time. Now, all of a sudden after forgetting the connection and relogging into it with my password, I can now connect to my wifi with no problems. My New iPad after the update, did not have any issues.

  • BlackNova22 Level 1 Level 1 (0 points)

    I had the same issue, apparently you have to go into Settings - Safari - then clear your history and cookies cache then turn your phone off and then on it seems to work had to do it for both the iPhone and iPad. hope this helps

  • Just30Ltd Level 1 Level 1 (0 points)

    Well that is just odd - tried the safari clearing down of cookies and history etc and no joy - so switched it off, left it for five minutes, booted up and sat right next to my router and it now works fine... bizzarre!

  • rcpulk Level 1 Level 1 (0 points)

    Nothing is working for me either

  • favelado79 Level 1 Level 1 (0 points)

    I had the problem that my iphone wouldn't connect to my wifi at home but would connect to wifi at work and other peoples routers.

     

    I tried everything right through to reseting router to factory default. reseting network settings on iphone I even restored iphone to factory settings as a new phone

     

    In the end I discovered that changing the wpa security settings on my router from TKIP encryption to AES encryption solved the problem.

  • fastdriver1236 Level 1 Level 1 (0 points)

    im in the same boat.installed io6 and now cant connect to any wifi and some of my apps fail to start.apples a bloody joke.the phones vitually usless now as connecting to internet without wifi is to costly and cant download any large amounts of data.and the maps a joke too.why they cant let us choose to revert to are old operating software that worked until they sort out the bugs in io6.thinking of ditching the iphone and going back to android phones.i cant see what they have to gain by ******* off so many people around world as now there iphones and ipads are made useless through there failures.why is it taking so long to fix this problem.a very unhappy apple customer

  • Shanss Level 1 Level 1 (0 points)

    If you go to General - Reset - Reset All Settings, it should work once you type the password back in. Although you have to fix your Wallpaper back, and all the Settings you changed around, it works. Nothing deletes (media, contacts, etc.), only the Settings are back to how they were when the phone first started.

  • wv Level 1 Level 1 (0 points)

    Our home wifi stopped syncing with my iphone and my husbands iphone after our i06 update back in the fall.  I have read every thread and every discussion!! Tried everything!! Finally talked to a genius at Apple and we reset my router --voila it worked ... for a a month or two !! Then went back to apple to talk to another genius and she at least pointed us in the right direction. It has been 4 days and the wifi on both my phone and my husbands work fine now!! We also have a mac book pro and 2 ipads and an Airport Extreme.  This is what I did... on my mac book pro you go to Airport Utility and double click the home fifi (as of course this is working) -  click on wireless options- the genius said to make sure that 2.4 GHZ (iphones) and 5GHZ (ipads and computers) had automatic selected --well they did .. so no great solution there... then haha-I remembered reading somewhere that someone and switched to a diferent channel -- I remembered the thread said channel 6 --so I picked 6 for the 2.4GHZ only which is used for iphones.  Worked like a charm!!! Hope that helps someone!