Previous 1 9 10 11 12 13 Next 280 Replies Latest reply: Sep 24, 2014 2:27 AM by Clearvisions Go to original post Branched to a new discussion.
  • Alexzafish Level 1 (0 points)

    Hello people, I'm back with some answers. I had the same problem with my home network, my iPhone4 couldn't connect to my wifi, wich was secured by WPA2-PSK. After 2 weeks of reading forums, email and pages, it seems that apple doesen't care about the iPhone4 problems, they are concentrated on iPhone5. Ok, so here is my answer to the issue. I turned off the security password from the wifi and did the next things (if you are not familiar with setting up a wifi router please find a specialized person who does):1. Turned on Firewall from router settings; 2. MAC Address Filtering ON; 3. registered every MAC that I wanna have acces to the internet, otherwise they will only have LAN connection but no WAN. This step takes about 10min for a profesional. For me it works. The problem comes from the new iOS6 release from apple that made an error on the code, for short word a BUG in the iOS6 that doesen't know how to decrypt the wifi password. I hope it helped a lot of you out there, it did for me. If i find something better I will reply. 

  • Jeckt Level 1 (0 points)

    It's so annoying. I got an iPhone 5 three weeks ago and have only had problems with it... Especially with the wifi. It connects but it is sooooo slow. Feels like back in the dial up days...


    Odd thing is though that it works fine on my iPad 2 and iPad 3 both on the new software i0S6 my old phone 3 on the older software works just fine too. It's just the iPhone 5 that has the problem. Watching youtube is almost impossible.

  • cramag Level 1 (0 points)

    I have just fixed my wifi.


    I use my internet connection on my Iphone4 via airport on my imac, to save on phone bills. since updating to ios6 that connection wouldnt work for Safari, after much searching and lots of fustration, what i did was turn wifi on, chose my network (my imac) clicked on the settings and then forget this network. I then went to my imac and turned off the sharing then changed the password (on imac) for sharing internet then turned it back on, turned on wifi chose my network and entered the new password and everything worked fine.


    hope this helps and fixes everybodys.

  • D.Mercado Level 1 (0 points)

    After updating to IOS 6 my iPhone 4 using Att network was not working at wifi spots like Panera, our local library, Chickfil.  I try several of the suggestions here with no luck.  I was only able to log-in at our home network.  Today at the library I decided to turn off the cellular data on the phone and that was my fix.  The access login page for the library finally open and we were able to input the log in info, and the wifi connected.  So in my opinion the new iOS 6 is not allowing both functions on (cellular data and wifi) Again that was our fix for our iPhone 4 using Att network.  We have not try at Panera, but will keep you posted.

  • Michael Seelye Level 1 (40 points)

    Alexzafish, if connection via mac address filtering works, you have elimintaed layer two as an issue and narrowed down the problem. I'm not sure behind the schenes how NAT addressing works when allocating the IP however this is where I would suspect the issue is. . .  Yes I know that Apple doesn't monitor these forums but one can hope. 

  • Wilso83 Level 1 (0 points)



    So I have tried everything:


    Reset the i pad (using the reset wi fi)


    Reset the router to factory settings


    Turned security to WAP/ WAP2 ... turned it off... turned it back on again


    Cleared all the caches.


    Turned Wi Fi off/on


    Turned Airplane Mode on /off


    Forget Network/Logg back in


    Set to Auto/Manual Etc


    Renew Network


    Turned data roaming on/off... tried with it on...with it off


    Tried a combination of them all!!


    Tried connecting to home network, company network, public access without security, even been to another Continent recently and still not working.......


    I do not have a Mac Laptop etc so do not understand the talk about reset the Mac Password Etc.


    The ipad may work on WI FI for 1% of the time for no logical reason.


    Once Apple launch update IOS 6.01... how do I download it without internet access.


    Having read the news re management changes at Apple due to Mapping Fiasco.


    How about the top man offering to sort the WI FI out or Step down????




    Any other possible solutions much appreciated!!

  • Al Johnson 2 Level 1 (0 points)

    I had all the same issues with both phone and pad. Rang apple support and was told that there is 30 days support available after every update however this had passed. But they guy understood that all my apple products where now useless so they extended support for 30 days got me appointment with apple store nearest me and replaced everything . Now all good.

  • Wilso83 Level 1 (0 points)



    Thanks for the tip.


    Unfortunately I live in the UAE and Apple have different ideas on support out here.


    There are no Apple Stores... just Apple Authorised Resellers... thery act like an Apple Store... until you have a problem!!

  • sbailey4 Level 1 (25 points)

    Wilso83, here is some info that may help. Disregard any info about IPv6 as that is NOT whats wrong. However some of the other options do work. If you do not know how to manage your Wireless router I would recommend you look online at your routers support site for info how to manage your router and change wireless security, SSID, etc. But typically you use an internet browser from your PC and access your routers management page. or are common. Once logged into the routers management page you can change settings such as the items mentioned.  Change wifi encryption WPA2/TKIP or WPA2/AES or turn it off altogether (just for testing). Change SSID to something simple no spaces. Of course forget network on your iDevice each time you try it if it doesnt work.



    [edit] I just saw your other post where you listed all those items.  Sounds like at this point you may have to send the device back for exchange or wait for iOS 6.0.1 which is rumored to be released soon and to address these wifi issues. If you cannot connect to ANY wifi router with or with out encryption in any country then not much else I can offer.  I dont remember if you said you did a full restore of the iDevice but if you didnt I would try that next. As to the other question on how to update with no wifi, you will update your iOS via your PC/Mac and iTunes.

  • coshalj Level 1 (0 points)

    seems like all this is not needed.Apple finally upgrades once again to iOS 6.0.1 which apparently will fix all bugs.:)

  • petermjames Level 1 (0 points)

    I've upgraded to IOS 6.0.1 and I'm still having the same problem.


    The problem is intermittent but mostly the connection to my Netgear router doesn't work.


    I've got similar problems with a new tablet from another manufacturer but not as bad (i.e. it connects more often).  If you go to the support forums for that other manufacturer you will find some similar problems.

  • Wilso83 Level 1 (0 points)

    Dear All,


    I was so excited... my Ipad 3 back working.


    Alas spoke too soon.


    Updated to IOS 6.0.1.


    No difference.


    I have tried all the options as before to get Wi Fi to connect and then onto the internet


    Only hope Apple are still watching these forums....



  • oNaJi Level 1 (0 points)

    My phone was connected to the network (with the tick) but was not showing the WiFi symbol (just the 3G).

    Solved by AJCL's method.

  • jghiller Level 1 (0 points)


    Saw your post - I too have the same Netgear router at V2.26 firmware and iPhone4s, now with IOS6.1. Worked fine with IOS5 and with IOS6 at our other home that just has Verizon wireless modem. Came back to home with Netgear and it keeps asking for password for previously defined NETGEAR SSID with WEP. Apple and I thought it needed admin password because it didnt ask for WEP KEY but I think it is at issue with WEP KEY. Dont know of any device you add to a wireless network that needs admin password. Keep getting incorrect password when trying to JOIN NETGEAR network. After 4 hours Apple specialist said I need to change to WPA2. Well that means changing a ton of home devices from thermostats, TVs, home theaters, network media players, not to mention 2 laptops. I have seen entries that others changed security and still had problems with devices connecting. I did download and unzip the V2.0.21 to wgt624v3_2_0_21_1_0_1_na.chk. Netgear says to use this file for the upload.

    Did you try that using your browser while logged into the router or connect you pc with ethernet cable to do it?

    Did you get the 'incorrect password' when entering WEP key(if you use WEP) when trying to JOIN?

    There is no way that I see to delete this defined network in my iphone so I could set it back up. I also dont see this 'renew lease' that Apple was looking for. Maybe thats an ipad thing.

    Can you get back to me so I can confirm we are having the same problem? Thanks. - My Apple ID and email password.

  • sbailey4 Level 1 (25 points)

    Jg, I would switch away from WEP anyway. That is WAY outdated and is not a secure protocol at all. About as well off having no encryption. So while it may be a bit of a hassle to shange everything I think it would be in your best interest  to go to WPA or WPA2 the later being the best anyway. IMO. Plus if it fixes your iDevice then all the better!

Previous 1 9 10 11 12 13 Next