Previous 1 3 4 5 6 7 Next 207 Replies Latest reply: Jan 10, 2015 3:39 PM by kavanagh.adam Go to original post
  • jbcortes Level 1 Level 1


    Brilliant, worked for me too. The files had to be found manually though as the search engine wasn't working for some reason.

    Thanks for sharing this brilliant tip!


  • willviles Level 1 Level 1

    You're a wonderful man KenV54. This has sorted out the problem.


    I don't really understand what preferences I just deleted and whether it could have any side effects for the functionality of anything else on the system, but I suggest if anyone finds any issues - post them here!

  • Juhaz Level 1 Level 1

    Hi KenV54

    I have MBP 17-inch mid 2010. I did what you told but with no luck. There are similar name of files which ends .lockfile ( should I delete also those?

  • willviles Level 1 Level 1

    I did - it's working on mine.

  • qazokm1 Level 1 Level 1

    Mine is working now...


    I just hope that deleting those files didn't create other issues!

  • KenV54 Level 1 Level 1

    This is a composite reply.


    Juhaz and qazokm1, a disclaimer: I don't know anything more than what I have posted, and all of that came from the Apple Support people. I am just an end user like you, with a few years experience with Macs.


    Juhaz--are you sure you got all the files out, including from the ByHost directory under /youruser/library/preferences/ByHost? You have to go to all these directories and can't just do a search in Finder or Spotlight. But maybe there's something else going on with your MBP 17-inch 2010. If you still have AppleCare, you might have to call them. They should have something about this issue in their database by now.


    Again, my understanding is that you can delete any plist file you want and nothing bad will happen. These files are created every time a new process is run, and changed as necessary, and don't even exist before that process is run for the first time. They are sort of like a cache memory for processes, and deleting them may mean, at most, that you will be asked to set up preferences in some processes the next time they are run. For example, if you deletd the plist files for your wi-fi, your wifi would still work, but you might not have a list of the various previously used wifi networks and would have to set them up again. It would cost you some time but nothing else. In any case, you can hold onto the plist files in Trash and put them back again if you want to do so.

  • Juhaz Level 1 Level 1


    I just deleted also those .lock files. With no luck. I might have some other problem.

  • Ba55Man Level 1 Level 1

    I deleted those files on my mid-2010 MBP and where before it would at least attempt to switch graphics modes (and fail), now the machine won't even attempt to switch graphics modes when I plug in the external monitor adapter. 




    C'mon, Apple, this is nuts.

  • KenV54 Level 1 Level 1

    Ba55Man, since you don't have a Retina MBP, things must be different. I'll pass your experience along to the tech guy who's been in contact ith the engineers.


    It /is/ nuts that Apple didn't pick up this bug beforehand.

  • Eddienet Level 1 Level 1

    ByHost directory, find,etcxxxxxxxxxxx.plist


    I have an differant number but it says windowserver... should I delete this Ken, I dont see that number u have posted, letter and number

  • KenV54 Level 1 Level 1

    Sorry--the windowserver plist file(s) in the ByHost directory have all sorts of different numbers--not important--just delete them all. That applies to these plist files wherever you find them.

  • Eddienet Level 1 Level 1

    Ty alot Ken for posting this, it works now, tumbs up for u and thumbs down for apple who havent noticed such a big issue

  • Lucas84 Level 1 Level 1

    I have a MBP 13', Mid 2009, 10.8.2, that I connect to a Samsung 27', S27B350 via a DVI-to-HDMI-adaptor. Same problem.


    My setup worked fine until last week, then the Samsung went black. The symptoms are exactly like described here. Neither PRAM-Reset nor deleting the plist-files worked.


    The monitor works if I connect it via VGA-Cable, so I can rule out a hardware issue with either my Mac or the Samsung.


    Strangely, the issue occured before I updated to 10.8.2 and persisted after I did the update (hoping that it woluld solve the problem).


    Any help would be much appreciated – hopefully Apple finds a fix for this quickly, also for the older models that are non-retina...

  • KenV54 Level 1 Level 1

    Lucas 84 and anyone else following this thread:


    I have no further suggestions to offer, and I don't think Apple is going to be looking for fixes to problems of which they are unaware.


    Even if Apple silently follows these threads, remember that the original Retina issue was solved only by my working with their higher level tech support, sending them several data capture files from my Retina MacBook Pro, and having Apple find in those files that the windowserver plist file was being called up when the HDMI cable was attached. That was the answer for my computer and my problem, and for a few other users, as well, but it isn't necessarily a universal solution.


    In other words, problems like these cannot be solved in a vacuum. You will have to call Apple support, perhaps pay for it if you don't have AppleCare, unfair as that may be considering that it's their problem, get the support escalated if necessary, and work with Apple until the problem is solved.

  • leo92 Level 1 Level 1

    Excuse me- I'm an absolute beginner on Mac.

    I have the MacBook with Retina Display and my HDMI doesn't work since the update.


    I put into the trash but I can't find the other file.

    Can you explain it to a real beginner?


    That would be really fine

Previous 1 3 4 5 6 7 Next