Previous 1 2 3 Next 40 Replies Latest reply: Jul 18, 2013 9:24 PM by cnlwoo Go to original post
  • qwist Level 1 Level 1 (5 points)

    Bloody **** - wasted 2 hours trying to fix this and thought I was going absolutely crazy...only to find out from this thread that Apple (again) fail in the quality control and testing.

     

    I will have to (as most, I guess) switch off parental control completely, until Apple - eventually - gets around to a fix. Probably not soon, doubt this is high on their list of priorities.

     

    If anyone finds a workaround, please post...

  • grantalewis Level 1 Level 1 (0 points)

    Folks, you can "fix" this by creating a new account with the appropriate parental controls in place. Granted, it's not elegant/ideal, but it's better than turning off parental controls altogether.

     

    To restate: if you had an account with parental controls in place when the upgrade to10.8.2 was made, that account is irrevocably broken. There's no fixing it. Create a new account, and set the appropriate parental controls  on that new account.

  • Tekneek Level 1 Level 1 (20 points)

    It is interesting that a workaround exists for dealing with what Apple broke. That's better than nothing.

     

    I'm not really inclined to have to create new accounts for all of my children and move all of their files to the new account. If I move everything in their user directory to the new user, overwriting any conflicts, will everything be as it was? Also, could I then delete the old user and rename the new one to the same as the old?

     

    Rather unfortunate that Apple outsourced their QA to the customers.

  • grantalewis Level 1 Level 1 (0 points)

    The first thing I'd try is the User Migration Assistant:

     

    http://support.apple.com/kb/HT4413

     

    I'm working in a lab situation where there were no user files/settings to bring over, so I didn't bother with the above -- just created a new account. I'm not certain that using the Migration Assistant will not also bring over the problems with Parental Controls. We can hope that it won't

     

    Unfortunately the only way to know for sure is to try it.

  • hokiefans Level 1 Level 1 (0 points)

    Got a call for tech support (about an other issue),  tech support said that the perental control issue has been pushed up to the engineers.  dont know what that means as far as resolution goes, but it least some one at apple is looking at something other then there maps and profit sheets.

  • grantalewis Level 1 Level 1 (0 points)

    Unbelievable. The problem returned on all six of the workstations that I had "fixed.

     

    This is sloppy work, Apple. I'm disappointed.

  • bluedakar Level 1 Level 1 (0 points)

    Temporary Workaround:

     

    Our two main concerns with parental controls is limiting access to websites we consider harmful to our kids and limiting the time our kids spend on the computer. We've found a workaround, that while not ideal, is getting us by until Apple gets this fixed.

     

    First off, you have to disable Parental Controls.

     

    Secondly, there is good news if you want to limit web access. We abandoned the Apple web controls a couple of years ago because we got tired of having to constantly "approve" websites that in our view should have been considered harmless. We've been using an app called K9 Protection. You won't find it inthe Mac App Store but you can Google it. It's free and it gets the job done. No hassles and no complaints. It's also available for iPod/iPhone/iPad if you want to disable Safari using parental controls on one of those iDevices.

     

    Next, we found a timer that will "switch user" after it counts down. There have got to be better options out there but it's on the Mac App Store and I didn't have a lot of time to search around for something better. It's called Kidz Timer and it's 5.99. A bit of a rip off IMO for what it does. To get it to work, I had to change my kid's password so he couldn't log back on and give himself more time. What's also frustrating about the app is there is no visible countdown timer. It will just switch the user to the login window without warning when the time is done. You need to use a separate countdown timer if you want to keep track. Furthermore, there is no way to "pause" the timer. So for example, if your kid is allowed 1 hour and uses 15 minutes then logs off, you have to log back in and set the timer for 45 minutes and start the timer again. This is not an ideal solution for time limits and I'm sure there are other (and free) apps that would do a better job but this has been our workaround for the time being.

     

    The good news is, you may find you like K9 Protection better anyway. I know we do. Good luck everyone. I hope Apple gets this resolved soon.

  • qwist Level 1 Level 1 (5 points)

    Did you try moving accounts/data, as some suggested? I am considering that now - but concerned that I will drown in "permission" issues instead. If anyone tried (moving parentally controlled account/data) I'd like to hear of experience with that (ie. will "parental control w OSX 10.8.2"-issue reappear).

  • bluedakar Level 1 Level 1 (0 points)

    qwist, I created a new account and set the parental controls and got the same "secure website" bug. That was with "allow unlimited web access" selected. When my kids tried to play Minecraft in multi user mode the same warning popped up. I added the website to the appoved website list but it still didn't help.

     

    After that I didn't bother transferring any data. I just deleted the account.

     

    It's looks like grant's fix in the post above quit working as well.

  • grantalewis Level 1 Level 1 (0 points)

    No, I'm sorry to say that it's not working. As I mentioned in my last post from this AM, the problem returned on all six of the workstations that I had "fixed."

  • elbenoit Level 1 Level 1 (5 points)

    I have found that I can click on a bookmarked link in my child's parental control account without any trouble (so far) but if I try to type in an address, any address, I get the secure website warning.

     

    I have also noticed that the problem has temporarily gone away after making a change in parental controls then logging in to my child's account, but if I log out of my child's account and log back in again, the secure website problem returns.

     

    I have also seen a reboot temporarily resolve this, but as soon as I log out the child account and log back in, the issue appears.

     

    So far it affects typing in the address bar. Bookmarked sites are opening (for now).

     

    I had parental controls with 'try to limit access' setting enabled for web pages.

  • Weborican Level 1 Level 1 (115 points)

    Problem solved for me!

     

    Since there doesn't seem to be any way to fix this on 10.8.2, I simply re-installed 10.8 on the affected Mac. I then applied the 10.8.1 updater, and ow I'm back to 10.8.1 and all is well with parental controls.

  • Steve.Muench Level 1 Level 1 (0 points)

    Also see posts in https://discussions.apple.com/thread/4322178

    But no definitive resolution over there.

  • teswongen Level 1 Level 1 (0 points)

    me too  .....10.8.2.......

  • neilmedia Level 1 Level 1 (0 points)

    I wish had read about this before Thursday morning! I work in a lab with 30 iMacs. 25 have been updated to 10.8.2. Since yesterday, I've been experiencing this on at least 10 computers, but many have yet to be tested. Each machine is set up with 5 users each with parental controls enabled. I'll keep looking and hoping for a fix. Preferably one thay doesn't require me to migrate or create 150 new users and set the parental controls again.