Skip navigation

Aperture 3.4 crashes on startup how do I downgrade?

9220 Views 93 Replies Latest reply: Sep 29, 2012 4:32 PM by lĂ©onie RSS
1 2 3 ... 7 Previous Next
Eric Harding Calculating status...
Currently Being Moderated
Sep 19, 2012 5:02 PM

after upgrading to 3.4 (from 3.3.x) Aperture crashes on startup.  the install was done from the manual download from the apple site, since the app store does not recognize my pre appstore install.

 

running 10.8.2 on a MacPro

  • Clem Level 3 Level 3 (550 points)

    Before bothering to try and downgrade, you should try and reisntall from your DVD and update directly to this latest version.  Do you still see the crash?

  • jrfelbab Calculating status...

    I have this same issue.  I restored v3.3.4 from TIme Machine along with my Aperture Library and all is well.  This only wasted around 4 hours of my life.

     

    Come on Apple, you must be better than this.

     

    I chose to do some testing and did all the rebuilds of the old image database and tried the install again.  This time I made copies of Aperture 3.3.4 and the old  Aperture Library.  Same results but the recovery was much quicker.

  • Deepu Nair Calculating status...

    I too have the same issue.

     

    10.8.2 on MacBook Pro Retina Display

  • Ugh...iPhone3G Calculating status...

    It seems that the Facebook connect is causing the crash. I deleted the com.apple.aperture.plist file in the ~user/Library/Preferences/ and Aperture 3.4 started again and is working fine without enabling FB. When I re-enable FB, the crash happens again.

     

    Easier than re-install, although have you tried re-enabling FB after the re-install and does it work?

     

    I'm running 10.8.2 on rMBP.

  • Kaxeh Calculating status...

    Just delete the Preferences (.plist), this worked for me.

  • indagarden Calculating status...

    Thank you!  I tried repairing permissions, re-installing and upgrading again and nothing helped!  I deleted the plist files and now Aperture is working. 

  • ender78 Level 1 Level 1 (5 points)

    This worked for me as well, thanks for the find. 

     

    Apple is really slipping today, first WIFI broken on IOS 6 for few hours then this. Does Apple still have a Quality Control group ?

  • DRoush Calculating status...

    Same issue - deleting plist worked.  As soon as I tried to re-associate with Facebook, it crashed.  Serious flaw, and seriously disappointing.

  • Clem Level 3 Level 3 (550 points)
    Currently Being Moderated
    Sep 19, 2012 9:41 PM (in response to DRoush)

    DRoush, don't bother with the plist, just do a fresh install, from your orig DVD, then upgrade direct to 3.4. Then try Facebook again. Report back on the success of that or not.

  • sorinfromtoronto Level 1 Level 1 (10 points)

    Whoever is in charge at Apple of software development and QAT for Aperture MUST be fired. If not, Apple will loose any credibility they still have with professional photographers. As far as I can tell, they are not doing too well with videographers either, but the photo/Aperture side is a disaster.

     

    Software quality control for Aperture has been a nightmare (remember the massive performance problems we had after the last OS upgrade??!!). Apple, you need to get your act together and rid yourself of the problem before it is too late.

     

    PS: If it is not obvious by now, I am experiencing the same startup crashes everyone else is struggling with. The funny thing is that iPhoto works fine with the SAME libraries that Aperture is copiously crashing on. I guess the iPhoto SW development manager and team are separate from the Aperture one ..... Hey, here is an idea. Fire the Aperture team altogether and give the iPhoto team Aperture. Maybe they can salvage it.

     

    I am trying to put a workaround together .... (hint: it involves iPhoto and removing the .plist that contains the stupid facebook link that never worked properly)

  • Clem Level 3 Level 3 (550 points)

    Doesnt look like any workaround needed other that to reinstall app from orig media and update directly to latest version (skipping interim updates).

  • William Lloyd Level 6 Level 6 (19,220 points)

    The workaround is to delete Aperture and re-install as Clem suggested.  No need to develop your own.

     

    Note that software development and software QA is a non-trivial endeavor these days; there are lots of combinations of OS versions, install paths, etc., not all of which can be trivially created in a test environent.

     

    Clem suggested something that seems to have worked for everyone in these forums to date, so I guess the question is really whether you want to editorialize or whether you want to solve the problem.  Your call ;-)

     

    A second thing is whether the issue should be reported to Apple so they can fix it.  I submitted feedback based on all these reports so I figure that's taken care of.

  • sorinfromtoronto Level 1 Level 1 (10 points)

    It appears that the link to Facebook is indeed causing issues (why on earth did I re-enable it after it caused so much grief last time ...it is clear the Apple Aperture team does not know how to interface with Facebook ...).

     

    Open terminal from a privileged account. Type in the following commands:

     

    cd

    cd Library/Preferences

    mv com.apple.aperture.plist com.apple.aperture.plist.bad

     

    Restart Aperture 3.4. Is should work now, but you just lost some of your customizations, mainly screen and menus. You also lost your Facebook link. Yeppeee... Luckily, presets and adjustments are not impacted.

     

    After Apple wakes up and provides a fix, we can try to recover our old settings by using the .bad file again.

1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.