Previous 1 2 3 Next 93 Replies Latest reply: Sep 29, 2012 4:32 PM by léonie
Eric Harding Level 1 (0 points)

after upgrading to 3.4 (from 3.3.x) Aperture crashes on startup.  the install was done from the manual download from the apple site, since the app store does not recognize my pre appstore install.


running 10.8.2 on a MacPro

  • Clem Level 3 (670 points)

    Before bothering to try and downgrade, you should try and reisntall from your DVD and update directly to this latest version.  Do you still see the crash?

  • jrfelbab Level 1 (5 points)

    I have this same issue.  I restored v3.3.4 from TIme Machine along with my Aperture Library and all is well.  This only wasted around 4 hours of my life.


    Come on Apple, you must be better than this.


    I chose to do some testing and did all the rebuilds of the old image database and tried the install again.  This time I made copies of Aperture 3.3.4 and the old  Aperture Library.  Same results but the recovery was much quicker.

  • Deepu Nair Level 1 (0 points)

    I too have the same issue.


    10.8.2 on MacBook Pro Retina Display

  • Eric Harding Level 1 (0 points)

    Fixed it with Clem's suggeston


    DVD install of 3.0

    Then upgraded to 3.3.2 (going right to 3.4 did not work)

    Then upgraded to 3.4


    repaired my library.


    may need to rethink storing photos in libraries, or rethink Aperture.


    thanks for your help

  • Ugh...iPhone3G Level 1 (25 points)

    It seems that the Facebook connect is causing the crash. I deleted the file in the ~user/Library/Preferences/ and Aperture 3.4 started again and is working fine without enabling FB. When I re-enable FB, the crash happens again.


    Easier than re-install, although have you tried re-enabling FB after the re-install and does it work?


    I'm running 10.8.2 on rMBP.

  • Kaxeh Level 1 (0 points)

    Just delete the Preferences (.plist), this worked for me.

  • indagarden Level 1 (5 points)

    Thank you!  I tried repairing permissions, re-installing and upgrading again and nothing helped!  I deleted the plist files and now Aperture is working. 

  • ender78 Level 1 (5 points)

    This worked for me as well, thanks for the find. 


    Apple is really slipping today, first WIFI broken on IOS 6 for few hours then this. Does Apple still have a Quality Control group ?

  • DRoush Level 1 (0 points)

    Same issue - deleting plist worked.  As soon as I tried to re-associate with Facebook, it crashed.  Serious flaw, and seriously disappointing.

  • Clem Level 3 (670 points)

    DRoush, don't bother with the plist, just do a fresh install, from your orig DVD, then upgrade direct to 3.4. Then try Facebook again. Report back on the success of that or not.

  • sorinfromtoronto Level 1 (10 points)

    Whoever is in charge at Apple of software development and QAT for Aperture MUST be fired. If not, Apple will loose any credibility they still have with professional photographers. As far as I can tell, they are not doing too well with videographers either, but the photo/Aperture side is a disaster.


    Software quality control for Aperture has been a nightmare (remember the massive performance problems we had after the last OS upgrade??!!). Apple, you need to get your act together and rid yourself of the problem before it is too late.


    PS: If it is not obvious by now, I am experiencing the same startup crashes everyone else is struggling with. The funny thing is that iPhoto works fine with the SAME libraries that Aperture is copiously crashing on. I guess the iPhoto SW development manager and team are separate from the Aperture one ..... Hey, here is an idea. Fire the Aperture team altogether and give the iPhoto team Aperture. Maybe they can salvage it.


    I am trying to put a workaround together .... (hint: it involves iPhoto and removing the .plist that contains the stupid facebook link that never worked properly)

  • Clem Level 3 (670 points)

    Doesnt look like any workaround needed other that to reinstall app from orig media and update directly to latest version (skipping interim updates).

  • William Lloyd Level 7 (21,040 points)

    The workaround is to delete Aperture and re-install as Clem suggested.  No need to develop your own.


    Note that software development and software QA is a non-trivial endeavor these days; there are lots of combinations of OS versions, install paths, etc., not all of which can be trivially created in a test environent.


    Clem suggested something that seems to have worked for everyone in these forums to date, so I guess the question is really whether you want to editorialize or whether you want to solve the problem.  Your call ;-)


    A second thing is whether the issue should be reported to Apple so they can fix it.  I submitted feedback based on all these reports so I figure that's taken care of.

  • sorinfromtoronto Level 1 (10 points)

    It appears that the link to Facebook is indeed causing issues (why on earth did I re-enable it after it caused so much grief last time is clear the Apple Aperture team does not know how to interface with Facebook ...).


    Open terminal from a privileged account. Type in the following commands:



    cd Library/Preferences



    Restart Aperture 3.4. Is should work now, but you just lost some of your customizations, mainly screen and menus. You also lost your Facebook link. Yeppeee... Luckily, presets and adjustments are not impacted.


    After Apple wakes up and provides a fix, we can try to recover our old settings by using the .bad file again.

Previous 1 2 3 Next