Previous 1 2 3 4 Next 49 Replies Latest reply: Feb 25, 2015 4:03 PM by ecopenhaver
Darren Greenspoon Level 1 Level 1

This evening I updated iPhoto to v11.4 and after the update it required my iPhoto library to be updated to work with the updated version of the software.  After that was complete, iTunes could no longer see my iPhoto library, albums etc.  It looks like I have an empty iPhoto in iTunes.  All my other iLife and iWork software can see my iPhoto library, albums etc.  Any help would be greatly appreciated.

iMac, OS X Mountain Lion (10.8.2)
  • riderworks Level 1 Level 1

    I'm having the same problem here, can't select Albums, Events, etc. from within Photos device settings in iTunes. I have two computers running 10.8.2, iTunes 10.7, iPhoto 9.4 and Aperture 3.4 and four iOS devices, one with iOS 6 and the other three running iOS 5.1.1. Always get an iTunes Error 1140 when trying to sync with either computer. I've tried trashing prefs for iTunes, iPod and iPhoto. Also tried removing the "iPod Photo Cache" folder from the iPhoto Library package and completely rebuilding the iPhoto database. Very frustrating.

  • Sininakl Level 1 Level 1

    Same here. It's frustrating that the iPhoto and iOS updates don't seem to be playing well together.

  • Foxbat46614 Level 1 Level 1

    I am seeing the unknown error 1140 trying to synchronize my iPhone 4 with the latest iTunes 10.7 (21) 64-bit and iPhoto 9.4 (iLife '11) on my Mac Pro 1.1 running Lion 10.7.5 (busy night updating everything!)  It isn't an iOS 6 thing because I saw the error on my iPhone before upgrading from 5.1.1 to 6.0.


    I can make the error go away by clearing the Photo Synch option on my iPhone.  When I go to select my iPhoto library, the option to select Albums, Events, etc. from the last n months is greyed-out.  Because I've got years and years of photos (my iPhoto Library is over 115 GB) I can't synch everything.


    Upgrading to Mountain Lion isn't an option unless Apple wants to come out with the Thunderbolt Mac Pro...

  • Darren Greenspoon Level 1 Level 1

    Sorry I meant iPhoto 9.4

    I have solved the problem - I downloaded a Free program called iPhoto Library Manager and it told me the issue was with my AlbumData.xml file.  I found the error and fixed it using the help provided in the iPhoto Library Manager.  Everything seems to be working except there are now some events that don't really exist and some of the albums have less pictures then I'm showing, but at least it is working!

  • rjans Level 1 Level 1

    Same ove here, although it only appeared after installing iPhoto 9.4 this morning. Yesyterday evening everything worked fine with the previous iPhoto version.

    Always get unknowm error 1104 with my iPad and also with my old iPod video.

    I hope Apple comes with a fix.

  • riderworks Level 1 Level 1

    Darren found it. I also downloaded iPhoto Library Manager and found problems with the AlbumData.xml file. I was able to edit some of the problems in Text Wrangler directly and other problems were fixed by changing the music for some older iPhoto slide shows within iPhoto. Updating my iPhone as I write this.

  • cdmilton Level 1 Level 1

    Unfortunately, iPhoto Library Manager isn't offering me any options for fixing it. It says my library is "malformed" and that it "encountered unknown ampersand-escape sequence at line 126732.:


    Ugh. Anyone have any ideas on how to deal with this? I've emailed feedback at Apple with all my details as well.



  • Doc11355 Level 1 Level 1

    Thanks for the suggestion.  iPhoto Library Manager is reimporting all the photos in my library as we speak.  Hopefully, the new, reconstituted library will ba able to be recognized by the new iTunes


    Looks like this iPhoto library access by iTunes glitch got past their bug detection staff this time... I hope they get it fixed with the next update!

  • Foxbat46614 Level 1 Level 1

    After reading the Apple Support pages, I came across the Option-Command key pair when starting iPhoto to bring up the Database Repair Tools.  Unfortunately, I went through all four levels of analysis and repair and I was still unable to see Events and Albums in my iPhoto Library from iTunes.


    Reading the above responses talking about "AlbumData" being the problem, I viewed the Content of the iPhoto Library (Ctrl-click on your iPhoto Library and select "Show Package Contents" to view your Library.  Inside the iLifeShared folder you'll find the AlbumData2.xml file that iPhoto Library Manager analyses.  You can use Quick View to look at the file, but opening it in XCode shows it in a color-coded format.  That's where I saw that the top of the file was fine, but at some point the XML parsing broke down because it no longer color-coded.


    Scrolling down from the top, I saw that one of my slide shows referenced an iTunes album that had an ampersand in the name.  Everything was blue after the "&".  Hmmm, I thought.


    Long story short: I spend an hour going through my iPhoto Albums, Events, and slideshows to change "&" to "and" or eliminate it if it made sense.  After all that, I am now able to sync my photos to my iPhone again!

  • cdmilton Level 1 Level 1

    You're a genius! This fixed my problem and I am now able to sync. Yay!


    iPhoto Library Manager had identified an error involving an ampersand in my iPhoto library but I didn't know what it meant. You supplied the missing piece of information. I searched my iPhoto library for &, found and eliminated several and -- voila! -- all is now well.


    Thank you so much!

  • Free-Dawg Level 1 Level 1

    Same problem, and I have 3 iPhoto Libraries to contend with. Each are reporting an error with this "&" symbol at different locations in the Album File.I think it is unreasonable to assume will eliminate (or not use) this charater in Album names.



  • Andres Eloy Level 1 Level 1

    El mismo problema Error 1140, no sicroniza Foto con Apeel Tv.

  • anitpatel Level 1 Level 1

    Great find! It gets worse though. I went through my iPhoto library and changed all albums and events to remove ampersands from names, but the error still continued.


    Downloaded iPhoto library manager which reported an ampersand error. Opened the XML file, and went to the line in question. The problem: many years ago I played around with iPhoto slide shows, and set the music to a track that contained an ampersand in the title. I nolonger have the track, and from iPhoto could not find a way to remove the track info from the slide. The work around was to select a new track not containing ampersand.


    I can now synch from iTunes without the 1140 error.

  • Free-Dawg Level 1 Level 1

    How did you edit the XML file? What App/Tool did you use?


    Did you simply remove the line or just deleted the "&" symbol on that line?

Previous 1 2 3 4 Next