Previous 1 2 3 4 Next 49 Replies Latest reply: Feb 25, 2015 4:03 PM by ecopenhaver Go to original post
  • riderworks Level 1 (0 points)

    I think all the problems that are showing up here are similar in nature, but specifically a bit different. I'll outline as best I can how I fixed my specific issues with getting the iPhoto Library to sync properly with my iPhone within iTunes. Again thanks to Darren (the original poster) for leading me down the path to solving this.


    Quit iTunes and iPhoto. I used the iPhoto Library Manager application (download from web) to reveal any corruption of the iPhoto metadata. It will show you what line of the AlbumData.xml file is having problems. I then used the Text Wrangler application (download from web) to open the AlbumData.xml file (shown by opening Package contents of your iPhoto Library file). Since Text Wrangler can show you the lines numbers, it's easy to locate the problem music (my specific issue). The best way to fix the problem is to look a few lines above and note the Album Slideshow that uses the music. Do a find in Text Wangler for the problem music file to see if that music is used in other Album Slideshows and note those Albums as well. I found that editing the data directly in the AlbumData.xml didn't work. It would just get reverted to the same problem after opening iPhoto again.


    Close the AlbumData.xml file without saving, then open iPhoto. Locate the Album's slideshows and change the default music to a different piece of music. Quit iPhoto and open iPhoto Library Manager to test for any other problems. Lather, rinse and repeat until there are no more issues. Also, you may have to remove the "iPod Photo Cache" folder from the iPhoto Library Package contents as well.


    Hope that helps. I know how frustrating it is dealing with this.

  • FanManDan Level 1 (0 points)

    Big time kudos for identifying the root cause and recommending a solution... super creative digging!


    If I understand the issue correctly, we should still hear from Apple Support regarding the issue, as it hadn't persisted in previous release versions until the latest refresh 9.4 (701.64). Not sure how practical it will be to manage files/song names to preclude ampersand usage (450 alone in my iTunes library; who knows how many 1,000s more in the iTunes store as it seems to be a routine naming convention).  Hoping to hear it's being addressed in the next point releases of iPhoto and iTunes.


    That said, if I misunderstood please let me know  :-)

  • ribbo39 Level 1 (20 points)


    I have had the similar problem in not being able to sync my iPad 3 to iTunes.   Each time I try my iPad appears in the devices list and click on sync I get a window with the error code 1140 and then  my iPad disappears from the devices.

    This happens whether I try to sync via Wi-Fi  or using a USB cable.


    As a result I spent anbout an hour on the phone to Applecare trying to resolve the problem - eventually

    I was asked to turn off "Sync iPhotos" to my iPad  and all is now OK.


    Just thought I would pass this on in case anyone else is having the same problem.


    Applecare are phoning me later this week with a work around - assuming they find one.



  • Free-Dawg Level 1 (15 points)

    I have the same problem and a scheduled AppleCare callback tomorrow. With my issue, the Album.xml file is choking on an "&" symbol from a photo slideshows song that I no longer even have in my iPhoto Library. I know some people have gone through their libraries and removed these references and it's worked for them. However, this error occurs in 3 libraries I've upgraded to iPhoto 9.4, and none of them have slideshows anymore. However, the same sync error occurs on each.


    I cannot sync  photos via iTunes to any of my mobile device (iPhone 5 or iPad 3) AND even my Apple TVs can't get to photos on my computer. Effectively, I have lost 100% ability to sync photos  via iTunes from iPhoto 9.4 libraries. In addition to this total failure, the 9.4 upgraded wiped out all of my FACES photo groups.


    Given this, plus the accuracy/functionality  issues of the iOS 6 Maps and Passbook Apps, the quality of Apple releases has REALLY diminished this time...

  • pastorcard Level 1 (0 points)

    This actually worked!


    Using both the iphoto library manager and the text wrangler. Opened the library manger, it showed what lines had the "&" and I found the lines in the albumdata.xml file. I found the slideshows a few lines above and went to those shows in my iPhoto.


    I went to my iTunes library and found the folder that held the mp3 and changed the title of the folder, using the word and. I also removed the song from the list in the slide show music. For one slideshow where the song didn't appear, I removed the slideshow. I quit and reopened iphoto libary manger, there was no errors. So I went back to iTunes, quit, reopened, when to photos for my iphone and selected sync, then clicked "selected albums" and they all came up.


    So it is the "&" and this solution does work!

    Thanks so much!

  • nlgould Level 1 (0 points)

    I tried everything that pastorcard suggested with iphoto library manager and text wrangler. However, I have no slide shows AND I had no ampersands in the albumdata.xml file. The only places I have ampersands are in the titles of individual photos, which didn't appear in that file. So I am back at square one, frustrated with a new iPhone and no photos on it. Has anyone without slideshows found a working solution?

  • pastorcard Level 1 (0 points)

    Hey nlgould,

    When I used the iphoto library manager, after getting the line error containing the &, and going to my iTunes libary folder, I would make sure the folder containing the mp3's w/ the "&"s also had no &'s. In other words, the folders AND the files must have the "&" removed.


    THEN, I would go back to iPhoto librarymanager and quit the program, restart it, and it would find the next "&". I did it about 3 times until the library manager didn't return any errors but would display the items and files I could manage (if that makes any sense).


    The point was, I removed the music from the slide shows, in one case I removed the slide show altogether, I then cleaned any "&"s from the folders and files in my iTunes library.


    Hope that helps. Oh, and I rebooted my mac, and iphone.

  • Doc11355 Level 1 (0 points)

    Thanks for the detailed description of your process, but I'm puzzeled about something:


    Why do we have to go through this tedious process, anyway?  Shouldn't we expect Apple to fix this ASAP?


    Has anyone heard that Apple Customer Support has acknowledged this problem and that a fix is on the wayt?

  • Free-Dawg Level 1 (15 points)

    I contacted AppleCare support on Saturday, talked with them extensively about the problem, sent them failure logs, as well as my Albums.xml files for 3 off my photo libraries. I also pointed them to this forum thread for additional data on customers affected by this bug.


    All of this I'm told went straight to their Engineering Team, and they are scheduled to call me back this evening with an update.


    If I learn something new, or if they give me a more reasonable workaround than searching the thousands of media files that I own to change names, I will post back to this forum topic...

  • M.A.Stough Level 1 (50 points)

    Same here...I'm very frustrated right now!

  • pastorcard Level 1 (0 points)

    There's another thread on this as well about Apple understanding this and working on a solution. My iphoto library must be smaller than most but the iphoto library manager did tell me what lines those "&" signs were on and then I could find what iphoto slide show they were in with text wrangler. It really did work with my iphone sync. Again I did reboot my iphone and computer after removing all the "&" signs I could find in my iTunes library.

    Apple really needs to fix this but until then, this worked for me.

  • dlewis379 Level 1 (0 points)

    Thanks a bunch. YOur solution worked  after a lot of searching but worth it,

    Thanks again

  • Mikey_Byte1 Level 1 (0 points)

    I have had two VERY long calls with AppleCare. They have a copy of my AlbumData.xml file. But they have also asked me to change every single entry of " & " in my iTunes library to " n ". They said the issue has to do with how iTunes talks to the new iPhoto. I started to make the changes but quickly realized I have well over 100 songs to go through. So I stopped. I seriously doubt they plan to rename every entry - track, artist, composer, etc. - in the iTunes store. Seems dumb. The next time I buy a song with " & " in it I would have to rename it?  So I am going to wait for them to release a fix. 


    I went through AlbumData.xml and I do find one entry with " & " in it. The odd thing is that if I follow that path on my computer that folder and file do not exist in my iTunes library. I changed the name of it last week but it is still there. Odd thing is it is in a folder that doesn't exist.  So my guess is the problem is not in my iPhoto library anymore, but somewhere in iTunes.

  • Mikey_Byte1 Level 1 (0 points)

    I solved the problem. For me. May be true for others. This past summer I got a new iMac and upgraded from iPhoto 4 to iPhoto 9. If you recall, iPhoto 4 let you assign default music to an Album. But if you look at an Album in iPhoto 9 you can't see the default song.  You can hit Slideshow and it will ask you if you would like to play a song with your slideshow. But that song will not be the default song left over from iPhoto 4. It's like it's meta data behind the scenes tied to that Album. The only way to see it is to do a search for " & " in AlbumData.xml. Be sure to include the spaces before and after. If you scroll back a a few lines you will notice the Album name that the song with the & is tied to. For me it was an old Album with stuff that I did not care about having organized, so I deleted the album. I also deleted my iPod Photo Cache folder, but that may not have been necessary. Then I relaunched iPhoto and then iTunes and all of my devices would allow me to sync selected photos again.


    I deleted the Album but another option might be to set some default music on Slideshow to see if that overrides it. It may or may not work. For me, deleting the Album did it.


    So, in summary, I think many of you may be struggling because you have default music assigned to an Album and it is leftover from an old version of iPhoto. But you can't see that song anywhere in the new iPhoto 9.4. If you are in the dark with the basic " & " clean up, chances are you have this hidden info behind the scenes.

  • iRobinator Level 1 (0 points)

    I'm getting the same "Error 1140" when syncing by iphone 4. Just updated to IOS 6, OS 10.8.2 so I don't know which caused the problem. Hard reset on iphone 4 did not help. Rebuilding the iphoto library database did not help. Removing "&"s from the event names did not help.

    So what next?