Previous 1 2 3 4 Next 49 Replies Latest reply: Feb 25, 2015 4:03 PM by ecopenhaver Go to original post
  • Mikey_Byte1 Level 1 (0 points)

    It's not just the &'s in the Event Names. It is anywhere in iPhoto. Even if it is hiddin in the meta data. You can determine if you have this in one of two ways:

    1) If you click on your iPhoto Library and select Show Package Contents you will see the details of what is in it. Open the AlbumData.xml file using a text editor. Do a search for &. If you find them then it means you still have them somewhere in the iPhoto library. Look for some key words before the & such as Album or something to help you figure out where they might be.  OR....

    2) In iPhoto click on Photos on the upper left to pull up all of your photos. Then do a Find for the &. What might happen is you get a list of photos that come up but when you look at them you may or may not see the &, such as in the name of the photo. Change any/all that you can see.  If you are still getting a list of photos and you can't see the & anywhere then chances are you have the problem that I had, which is there is old info tied to the photo that you cannot see. For example, the actual photo file name.  Try dragging those photos that look like they do not have an & associated with them onto your desktop. My guess is they will now have a file name with the & in them.  For all of them, drag them out. Change the file name on the desktop. Delete the originals in iPhoto and then drag them back in.  Also check your Album names. If you have Albums with the & rename them.


    Now, if you are still having problem it could be that the Album has meta data, such as a default song, tied to it that the latest iPhoto will not show you.  The only way I could find to fix this was to create a new album, copy the photos into it and then delete the old Album.  Close iPhoto and iTunes. Delete your iPod Photo Cache folder in your iPhoto Library package contents.You should be all set.


    Again, the problem is the & but it is in both visible names such as Albums, Events and Photos, as well as hidden meta data carried over from older versions of iPhoto.


    FYI - I am still having an odd error where iTunes lists a ton of bizarre events with Date Names as the Event that do not exist in iPhoto. But at this point I don't care since I can finally sync everything. I am going to call AppleCare to see if they have any ideas on how to get rid of these Events appearing in iTunes photo lists but not in iPhoto.

  • sarahfromranchos Level 1 (15 points)

    AMEN!  Why do we have to fix this ourselves?

  • gerrycgc24 Level 1 (0 points)

    iTunes 10.7, Iphoto 9.4. I could not sync to Apple TV, 1st generation from Itunes. I was getting error message, apple tv cannot sync photos to the apple tv unknown error 1140. I edited file, albumdata.xml in Iphoto, backed up original first. Used find and change under edit ,Changed & to n.


    Apple TV is, at this moment, is putting all my photos back on to my Apple TV. I had removed them from Apple TV to see if it would help. Removing the & symbol from that file worked for my problem. It is still syncing.




  • gerrycgc24 Level 1 (0 points)

    Did not work, same problem reoccurred.......

  • Qubic Level 1 (15 points)

    I found 2146 occurrences of "&" in AlbumData.xml.  Many appear to be escaping a possessive apostrophe, which I guess parses fine.  They are & and '  iPhoto Library Manager complained about the 'malformed' file, etc.  Will try to change a line and see if gets past.  I'd rather not edit these all, would prefer Apple address it with sanctified patch, but am getting sick of not having any pics on 3 ipads and two iphones other than photo stream.  :-P

  • Qubic Level 1 (15 points)

    This was also for me after iPhoto 11 had updated to version 9.4, although I hadn't exactly noticed when the sync problems started, but has been over past week.


    Made back up of the (on my system) /Volumes/Pictures/Pictures/iPhotoLibrary/AlbumData.xml first just in case so can put the offending version back for whatever reason.


    I just went specifically to the lines (only two it turned out) that iPhoto Library Manager was cribbing about.


    They were both:


    "<string>/Users/johnb/Music/iTunes/iTunes Music/London Mozart Players/Haydn-Symphonies Nos. 80, 87& 89 (Disc 1)/10 No. 89-Second Movement-Andante con moto.m4a</string>"


    where the 'naked' ampersand followed the number '87' in the string.  Clearing those in TextWrangler allowed iPhoto Library Manager to proceed with loading the file.  (woo! progress! ). I just hand edited it, replaced with comma, closed everything up.


    Bringing up iTunes (before iPhoto in case it does something) and see if am able to select the "Selected albums, etc" which has been greyed out for every iOS device....


    WOOO!!    YES!  Now everything is copasetic again, can select "Selected albums, Events, and Faces..etc" in the Photos tab in iTunes 10.7..


    Sigh... so relieved to at least get this far with it and get pics back on our stuff.  A bit of a PITA.  At least now have some idea of what was causing problem.

  • Qubic Level 1 (15 points)

    Waaaa.  iTunes put the ampersand back into AlbumData.xml

    Will have to try and change the actual underlying filename and see, but at least it made a difference for awile.


    "<string>/Users/johnb/Music/iTunes/iTunes Music/London Mozart Players/Haydn-Symphonies Nos. 80, 87& 89 (Disc 1)/10 No. 89-Second Movement-Andante con moto.m4a</string>"

  • Qubic Level 1 (15 points)

    Ok, is just songs associated with an Album for a slide show.  iPhoto changed it back. Not going to mess with the base music filenames, esp since are 12 of them and they are happily matched w iTunes Match.  Since issue is with the iPhoto Library, will just get rid of that song or replace it in iphoto for that album.


    Brought up iphoto again w/o apparent problem. Quit iphoto.  Wait about a year for it to quit (35k pics...).  Check w iPhoto Library Manager again to verify still clean.  Crap!!  iphoto put them back!    Ok, so I guess is pulling from itunes.....


    Going to punt and to the fix, bring up itunes and sync pics on devices, selected albums, then not worry about it for now until can do something else.  If is pulling from base music album and file name, I don't want to change those just for this.  Will either put up with work around for as long as casn stand it or wait until possible update.

  • Mikey_Byte1 Level 1 (0 points)

    You cannot edit AlbumData.xml. It will just get updated every time you open iPhoto. The only way to fix it is to change the "&" in the Events, Albums, and Photos inside iPhoto. Use the Find function. If the Find function takes you to a photo and you cannot see an "&" anywhere in the Info then it means it is hidden in the meta data. Drag the picture to your desktop and you might find that the actual name has an "&" in it. Delete the one in iPhoto, rename the one on your desktop, and drag it back in.  What the Find funtion won't show you is if an Album has a default music song attached to it. If it does and that song has an "&" in it then you need to either change the song or make a new Album without the music attachment, drag the pics from the old album to the new one, and delete the old Album.

  • nlgould Level 1 (0 points)

    It appears that all is now well. The promised update is out and my devices are syncing. I'm glad I waited for Apple rather than drag hundreds of files around to rename them. We can hope that future updates will be more carefully tested before they are released. Thanks for all the suggestions. I learned a lot.

  • gerrycgc24 Level 1 (0 points)

    9.4.1 works  thanks

  • FanManDan Level 1 (0 points)

    Confirmed here too. After the update installs, be sure to launch iPhoto and allow it update the iPhoto DB before attempting to sync via iTunes.


    Apple Tech Support: thank you for responding to the feedback with the interim release.

  • sarahfromranchos Level 1 (15 points)

    Here also.  Installed update, luckily launched iPhoto before trying to sync iPhone via iTunes, just completed sync (after changing which folders were checked).  Photos seem to have synced properly.  Yay!

  • andymate Level 1 (5 points)

    Fantstic stuff, riderworks!


    Same problem encountered, greyed out box for selectes albums, Events, and Faces, with All photos checked on the Sync Photos from pane in iTunes. Download iPhoto Library Manager and also TextWrangler from the internet.


    Quit both iTunes and iPhoto then run iPhoto Library Manager. This instantly threw up the ampersand (&) problem and gave me the line in the xml code that was causing the problem. Write this down and quit iPhoto Library Manager. Start up TextWrangler and open the AlbumData2.xml file inside iPhoto Library. Scroll down to the line that you found and you should see a soundtrack or album that had an ampersand in the title. A few lines above showed me the name of the slideshow inside iTunes that was using this track. Quit Text wrangler and open iPhoto. Open that slideshow and change the default music to some other tune (that doesn't have an ampersand in the title of either the song or the album name!). Close this slideshow and quit iPhoto.


    Then start the process all over again. If, like me, you open iPhoto Library Manager and you see all of your Albums appear instead of the error code - it has worked! If you get another ampersand problem follow the instructions above until you have cleared all of them and your photo albums list appears.


    Open iTunes and you should be able to sync again!


    Good luck and come on Apple!

  • ken_rulloda Level 1 (5 points)

    I believe there is an update to iPhoto that was just released yesterday. The update acknowledges synching issues between iTunes and iPhoto.