1 2 Previous Next 18 Replies Latest reply: Jul 6, 2014 11:30 AM by aydinfromtoronto
AEC22 Level 1 Level 1 (0 points)

My MacBook Pro is about 6.5 years old. I upgraded to Snow Leopard 2 years ago and added RAM at the same time. My first problem ever occurred three days ago when my computer got super sluggish, I restarted and got the gray screen with apple and spinning wheel...no boot up. I ran disk utility from the snow leopard install disk and found "invalid node structure" and "invalid record count". After reading on here what to do...try to repair the disk and so on with no success I went out and bought Disk Warrior. Got home expecting to fix everything and Disc Warrior won't boot...I just get a file with a question mark and the disc is ejected. I tried erasing the hard drive but was only able to use the "don't erase data" option. Then I tried to reinstall Snow Leopard with no luck. Now I am stuck. Any ideas? 

 

One thing to note is I am to the point of not caring about the files on the hard drive, I was a dummy and never backed them up...lesson learned!  I just want my computer back without having to spend $1000+ for a new one. Then again I am always willing to do that too as a last resort.

 

PLEASE HELP!


MacBook Pro, Mac OS X (10.6.8)
  • 1. Re: Please help! Invalid node structure and invalid record count
    sig Level 8 Level 8 (35,770 points)

    "I went out and bought Disk Warrior. Got home expecting to fix everything and Disc Warrior won't boot."

     

    You inserted the disk and rebooted while holding down the c key? Have you the latest version of DiskWarrior? If yoy still have issues with the disk then contact Alsoft. You other option is to reformat the hard drive which erases everything.

  • 2. Re: Please help! Invalid node structure and invalid record count
    AEC22 Level 1 Level 1 (0 points)

    Yes, I held down the c key while starting. I will try contacting alsoft tomorrow. How would I reformat the hard drive?

  • 3. Re: Please help! Invalid node structure and invalid record count
    CMCSK Level 6 Level 6 (10,425 points)

    When you contact Alsoft, make sure you let them know that you are using Snow Leopard (10.6.8).

     

    Try the following in the meantime -

    Disconnect all peripherals from your computer.

     

    Boot from your install disc & run Repair Disk from the utility menu. To use the Install Mac OS X disc, insert the disc, and restart your computer while holding down the C key as it starts up.

    Select your language.

    Once on the desktop, select Utility in the menu bar.

    Select Disk Utility.

     

    Select the disk or volume in the list of disks and volumes, and then click First Aid.

    Click Repair Disk.

    Restart your computer when done.

     

    Repair permissions after you reach the desktop-http://support.apple.com/kb/HT2963 and restart your computer.

     

    Try DiskWarrarior again if it's combatible with the os system.

     

     

    YOu cannot reformat until you get your issue corrected.

     

     

     

     

     

     

     

     

    Image Hosting by PicVault.info

  • 4. Re: Please help! Invalid node structure and invalid record count
    John Galt Level 8 Level 8 (36,380 points)

    Disk Warrior may be able to repair the invalid node structure, so that it might be possible to mount the disk and retrieve your data. However, it is very likely some has already been lost for good.

     

    It is also possible that the hard disk cannot be repaired at all, and even if you can repair it I would no longer rely upon it.

     

    You don't have to spend $1000 on a new MacBook. You can simply replace the hard disk. They are not expensive or difficult to replace.

     

    I realize it's too late for you, but an external backup device can be purchased for not much more than the cost of Disk Warrior.

  • 5. Re: Please help! Invalid node structure and invalid record count
    AEC22 Level 1 Level 1 (0 points)

    Thank you but I have tried this already. The disk utility cannot repair the disk hence going out and spending $115 on disk warrior. I am close to settling with the idea that my hard drive is just shot and I need a new one! Thank you for taking the time to respond.

  • 6. Re: Please help! Invalid node structure and invalid record count
    AEC22 Level 1 Level 1 (0 points)

    Thank you! I agree with possibly no longer wanting to rely on this hard drive. Purchasing a new drive would be possible but I use this as an excuse to do a full upgrade to a new MacBook Pro lol! Just thought i would give myself piece of mind by trying everything possible. Thanks again!

  • 7. Re: Please help! Invalid node structure and invalid record count
    Chris Watts1 Level 1 Level 1 (0 points)

    Invalid Node Structure is not a hardware failure, it never was (you may still have a hardware failure, but the Invalid Node error is not indicative of this problem. 

     

    Still, Disk utility will certainly fail to fix it, and DiskWarrior will probably fail too.  

     

    But don't despair.  Try this, and don't give up till you've tried it at least three times.

     

    First, get the name of the partition of the failing volume.   You can get it most easily by finding your disk in Disk Utility, selecting your partition (not the drive) and type cmd-i.    Look for "Disk Identifier" right at the top.

     

    Then,  open up Terminal, and type this:

     

    sudo /sbin/fsck_hfs -yprd /dev/disk5s2  

     

    substituting your disk identifier for the one already here.   Keep the "/dev/" part.   Enter your password, and wait.  It may take a while.  I have had this fail several times before finally working so its important to keep trying.   It's faster than a reformat!!!

     

    If the afflicted disk is your startup disk, you will need to do this in recovery mode: restart the computer, hold down option, and wait for the disk options to appear.   Select that, then proceed to Disk Utility and then Terminal as described above.  

     

    Good luck, and always keep a backup!

     

    chris watts

  • 8. Re: Please help! Invalid node structure and invalid record count
    Bowman4864 Level 1 Level 1 (0 points)

    Chris, I work IT for a digital agency and your reply to this proplem single handedly saved a Technical Director's main parittion! I cannot express how helpful your reply was and I thank you for your contribution to the community!

  • 9. Re: Please help! Invalid node structure and invalid record count
    clovist Level 1 Level 1 (0 points)

    Hi Chris,

    This command saved my day! Actually my weekend!! And of course all my files

     

    Thank you very much!!!

  • 10. Re: Please help! Invalid node structure and invalid record count
    holistichightech Level 1 Level 1 (0 points)

    Hi Chris.

     

    If I run "Disk Repair", all I get are red error messages saying "Invalid Node Structure" and "Invalid Record Count".  I can't run the sudo command within Terminal.  The command cannot be found or permissions don't exist to run.

     

    Also, as the "Repair Disk Permissions" runs, it's showing "Open error 5" messages.  I just want to be able to salvage and transfer all my data files to another computer, and reinstall the OS on my notebook.

     

    How can I solve this problem?

     

     

     

    Cheers

  • 11. Re: Please help! Invalid node structure and invalid record count
    Chris Watts1 Level 1 Level 1 (0 points)

    This may be a little late, but you should try starting from a bootable OS install CD. and then retry the above steps...

  • 12. Re: Please help! Invalid node structure and invalid record count
    holistichightech Level 1 Level 1 (0 points)

    I tried that approach before, but I got the same results.

     

    DiskWarrior recover the directory structure.  However, I can replace on the same internal HDD because it's damaged and failing.  I just bought a Toshiba Canvio Slim 2 external HDD so that I can transfer my files.  This HDD supports both Mac OS X and Windows.

     

    But, DiskWarrior sees it, but doesn't allow to transfer the files (i.e. the "Replace" button is still grayed out.).

     

    What is the workaround?

     

     

    Thanks.

  • 13. Re: Please help! Invalid node structure and invalid record count
    seacloudstudio Level 1 Level 1 (0 points)

    I have been having the same codes coming up in disk utility when  I've started up my computer with installation cd. I also saw a message that was

    ( node =81) unused node is not erased.

    I have tried going into terminal and typing the sudo command but it says no command found or file type not recognized I am sure I found the proper disk code but it doesn't work. Can anyone help me with this?

    I simply want to recover my personal stuff off my computer then redo the entire hard drive. I do not want to lose important photos and documents

  • 14. Re: Please help! Invalid node structure and invalid record count
    Emily1991 Level 1 Level 1 (0 points)

    Hello, I have the same problem!

    I've typed in exactly this (after -bash-3.2# appeared):

     

    sudo /sbin/fsck_hfs -yprd /dev/disk0s2

     

    and it quickly says 'command not found'...! Did I do something wrong?

     

    PS: I also have the 'invalid node structure' problem

1 2 Previous Next