Previous 1 2 3 4 Next 53 Replies Latest reply: Aug 25, 2014 1:57 PM by Jimmy Yu
jianglai Level 1 (0 points)

Since updating to 10.8.2 I noticed that spotlight will randomly start indexing for a while and then stop. Basically everything IS already indexed because when I search in spotlight I got what I need but from time to time there will be indexing progress bar in the bottum of the spotlight dropdown menu, which is full but keeps rolling. I checked and saw a lot of messages regarding mdworker, mdimporter and lsboxd like the following:


mdworker: Unable to talk to lsboxd

mdimporter: Unable to talk to lsboxd

sandboxd: mdworker(692) deny mach-lookup


I suspect that there might be some issue with spotlight and the sandbox mechanism? When I boot the computer I also notice that lsboxd keeps running in activity monitor, which wasn't the case prior to 10.8.2 update.


Has anyone seen the same symptom?


I'm on a mid-2010 MacBook Pro with Crucial M4 SSD.

OS X Mountain Lion
  • Adrian Robert Level 1 (10 points)

    Yeah, seeing same issue.  Unfortunately mds and mdworker get to consuiming a lot of CPU during these little games.  Somehow I doubt I'm going to be seeing the battery life improvements that are supposed to have come with 10.8.2.  I sure wish Apple actually *tested* this software before releasing it to the world...  I'm going to send in a bug report with log excerpts and maybe a partial dump of my spotlight indexes.

  • jonathan.muth Level 1 (0 points)

    I have got the same problem here. Mdworker and Mds take up between 40% and 60% of my CPU resources. Excluding all drives from Spotlight does not make a difference. Neither does reindexing.



    According to some other threads it has some thing to do with sandboxing:


    mdworker[299]: Unable to talk to lsboxd

    sandboxd[296] ([299]): mdworker(299) deny mach-lookup

    kernel[0]: Sandbox: sandboxd(314) deny mach-lookup


    Lets hope Apple releases a fix soon.

  • Bloedman Level 1 (0 points)

    I'm having the same issue since upgrading.  Having the spinning beach ball of death up no matter what activity I'm doing, my iMac is essentially unusable right now.


    2012-09-21 2:22:31.486 PM mdworker[4233]: Unable to talk to lsboxd

    2012-09-21 2:22:31.542 PM sandboxd[4239]: ([4233]) mdworker(4233) deny mach-lookup

    2012-09-21 2:22:31.000 PM kernel[0]: Sandbox: sandboxd(4239) deny mach-lookup

    2012-09-21 2:26:45.153 PM mdworker[4247]: Unable to talk to lsboxd

    2012-09-21 2:26:45.219 PM sandboxd[4252]: ([4247]) mdworker(4247) deny mach-lookup

    2012-09-21 2:26:45.000 PM kernel[0]: Sandbox: sandboxd(4252) deny mach-lookup

    2012-09-21 2:26:55.005 PM rpc.statd[25]: Failed to contact rpc.statd at host

    2012-09-21 2:28:51.869 PM mdworker[4256]: Unable to talk to lsboxd

    2012-09-21 2:28:51.948 PM sandboxd[4262]: ([4256]) mdworker(4256) deny mach-lookup

    2012-09-21 2:28:52.000 PM kernel[0]: Sandbox: sandboxd(4262) deny mach-lookup

    2012-09-21 2:30:53.667 PM mdworker[4270]: Unable to talk to lsboxd

    2012-09-21 2:30:53.000 PM kernel[0]: Sandbox: sandboxd(4275) deny mach-lookup

  • kpagchen Level 1 (0 points)

    I've forced reindex of spotlight using the terminal command

    sudo mdutil -E /

    Beware: start this at night as it takes a lot of ressources and run for many hours.


    Computer speed is normal again.

    But still get a lot of these messages in Console:


    2012-09-21 14:37:54,691 mdworker[5689]: Unable to talk to lsboxd

    2012-09-21 14:37:54,816 sandboxd[5691]: ([5690]) mdworker(5690) deny mach-lookup

    2012-09-21 14:37:55,000 kernel[0]: Sandbox: sandboxd(5691) deny mach-lookup

  • Bloedman Level 1 (0 points)

    Thank you for the suggestion but it had no effect.  Barely a third of my hd is used, cpu are a fraction of a percent, more than half my ram is free and yet the computer is not in a functional state.


    I'm at the end of my rope with this.  None of the suggestions that users are making are fixing my problem.


    Where the $%^^ is Apple?  It's not just me, a lot of other people are having the same problem.

  • Ted Savas Level 1 (10 points)

    Same thing here on a 2011 iMac and 10.8.2.


    Can't offer any advice yet.

  • kpagchen Level 1 (0 points)


    Check if you have this file in your system /System/Library/LaunchAgents/

    It was added in the original 10.8.0 but was causing problem. See this post for more information:


    When I installed ML, I had spinning ball and erasing it solved my problem on my MBP mid 2011.

    Different problem source, but same annoying effect.


  • Lanny Level 5 (6,445 points)

    This is from another forum, but it worked for me to stop the, "mdworker[299]: Unable to talk to lsboxd."


    Screen Shot 2012-09-25 at 4.15.47 PM.jpg

  • tfreyaus Level 1 (0 points)









    Seemed to have fixed it for me.

  • Lanny Level 5 (6,445 points)

    I had to also do a ML re-install though.

  • timyu Level 1 (10 points)

    Just to add another datapoint, I landed here after encountering the same problem.


    System: mid-2011 Macbook Air, 1.8GHz i7, running 10.8.2, with a 480 GB OWC SSD.

    Symptom: I noticed that Spotlight was frequently reindexing my SSD. I also experienced intermittent spikes in CPU usage and fan use, and, intermittent system freezes (no gray screen of death, but everything would just be frozen "in stasis" requiring a hard reset.


    Sample messages from Console:

    9/28/12 8:32:18.785 PM mds[74]: Unable to talk to lsboxd

    9/28/12 8:32:20.011 PM mdworker[464]: Unable to talk to lsboxd

    9/28/12 8:32:20.018 PM mdworker[462]: Unable to talk to lsboxd

    9/28/12 8:33:34.792 PM mdworker[536]: Unable to talk to lsboxd

    9/28/12 8:33:34.798 PM mdworker[537]: Unable to talk to lsboxd

    9/28/12 8:34:47.205 PM mdworker[551]: Unable to talk to lsboxd

    9/28/12 8:34:47.212 PM mdworker[552]: Unable to talk to lsboxd

    9/28/12 8:37:36.395 PM mdworker[592]: Unable to talk to lsboxd

    9/28/12 8:37:36.401 PM mdworker[591]: Unable to talk to lsboxd

    9/28/12 8:39:47.845 PM mdworker[607]: Unable to talk to lsboxd

    9/28/12 8:39:47.851 PM mdworker[606]: Unable to talk to lsboxd

  • skofgar Level 1 (0 points)

    Thanks! Removing the solved it for me - at least it looks like.

    I'm also observed the same problem on my MacBookPro6,2 using OS X 10.8.2


    UPDATE: Hmm... I'm still getting the error messages in the console and spotlight is indexing for a few seconds again and again...

  • Lanny Level 5 (6,445 points)

    Removing: "/System/Library/LaunchAgents/" and "/Library/Cache/" and re-installing ML did it for me.

  • skofgar Level 1 (0 points)

    Hey Lanny


    Thank you for the tip. I removed both Files, but I didn't had the chance to reinstall ML again... I'll do it asap.


    Isn't that weird that we've to reinstall ML? I actually erased my hardrive and made a clean install of ML when I installed version 10.8.0

Previous 1 2 3 4 Next