Previous 1 2 3 4 5 Next 94 Replies Latest reply: May 16, 2015 2:01 PM by mac427 Go to original post
  • sanderson.paul Level 1 Level 1 (0 points)

    Ive been trying all suggested ideas all day, ive uninstalled and re-installed twice. Im now giving up. Thanks Apple, youve really helped on this thread......

  • badtzmartin Level 1 Level 1 (0 points)

    Same problem here...

  • 55Gala Level 1 Level 1 (0 points)

    this didn't work on mine. Windows 7, 64bit

  • trichard Level 1 Level 1 (0 points)

    Finally I found a solution, well at lease for myself. Feel free to try.


    At Windows's Task Manager, I killed ApplePhotoStreams.exe *32 process. Restart the iCloud control panel and voila, all the pictures were downloaded to my Windows 7 PC.

  • 55Gala Level 1 Level 1 (0 points)

    I don't' have that. I do have Apple Mobile Device, which I tried shutting down. Still no iCloud photostream checkbox availability in control panel. (see image)

    iCloud panel shot.JPG

    Windows 7 Home Premium, 64 bit Service Pack 1

    iCloud Control Panel 2.0

  • alexshore1982 Level 1 Level 1 (10 points)

    Hi, I had this problem. I had photostream working fine. My husband then got an iphone as well so i was advised by apple to make a new user account on the pc so he could have his own photostream. I did this and his worked fine. My original photostream however developed this proble. Reinstalled but it didn't help. My solution was to make another new user account for myself and set up a new iclou/photostream. My pc now has 3 user accounts:- General (my old account) Rob (my husband) and Alex (my new one). The general account still has the same prob as you but the other two work fine. Its a bit of a pain as i had to move all my stuff to my new user account (drag and drop stuff into a public file then transfer to a file on my new user account). You could always do this and keep your old account and use the public files/folders to transfer the photostream pics from the new account to your original.


    The other thing to look at is permissions but I don't really understand enough about it to guide you. If you do mae a new user account make sure you are set as an administrater. T o make a new account you need to go to the control panel and go into the uer accounts section. Hope this helps.

  • FernandoMadruga Level 1 Level 1 (0 points)

    This is nuts: the lack of Apple Support is, well, I don't want to write those words here.


    This is the 2nd time in a few weeks that I've had this problem: note to Apple: *NOT* all your iPhone/iPad users have a Mac!


    I've been advocating iPhone to my friends, family and co-workers, saying to them that Apple stuff may be limited in what they allow the user to do (when compared to Android devices) but that they make up for that by making things that *just work*, but this is clearly not the case and has been so for quite some months now with no visible solution in sight... Rather than trying to fix this myself, my next course of action will be to find a *working* alternative to Photostream: it's a shame that this works so badly and that Apple totally disrespects their users by not doing a thing to fix this... I'm not leaving my iPhone, at least not yet, but if this contempt is extended to other areas, then I'll have to consider a more drastic change in the future...


    Just remember this, Apple, you can't ignore your users for long: there *are* alternatives out there, you know?
    I'll copy/paste this into the feedback form, not that it will matter much, but at least I will be able to say that I did my share of warning them. For now it's Uninstall Apple-related stuff from my Windows PC once and for all - at least I'll start 2013 rid of Bonjour and other crappy stuff I didn't uninstall yet fearing I'd break something - there was no need for me to worry about that - Apple did the breaking themselves...

  • WChad Level 1 Level 1 (0 points)

    Here's what worked for me on Win7 Pro 64-bit:


    1. To get rid of the greyed out photostream selection; I had to uninstall, reboot and then reinstall.
    2. Once reinstalled, I enabled photostream again, but no images.
    3. Open Windows Explorer
      1. On the left under favories, there is a PhotoStream option, click it.
      2. Right click the large, iCloud icon that says My Photo Stream and selct add photos...
      3. Pick any image on your computer to add.


    After that, my photos started to download. Very frusturating that this wasn't working, but the above fixed it for me.

  • Brian Wade Canfield Level 1 Level 1 (0 points)

    SOLUTION: ... (Well, at least what worked for me, and what will hopefully work for you too)


    Earlier today, I opened up iCloud on my PC, and found that something was quite "screwy" with the program. When I first downloaded iCloud to my PC yesterday, Photo Stream was working. As I do not have Microsoft Outlook 2007 or later, the availability to check the box next to Mail, Calendars, Contacts & Tasks is not available (although the latter have been backed up to, where I can view them). What I was currently left with was: Bookmarks (with Internet Explorer), and Photo Stream (the latter having an Options tab to the right of it).


    Now, I must first say that my Windows Edition is not Windows 7, but it is a compatible Windows Edition: Windows Vista 64-bit OS (Service Pack 2). This difference may ... well ... make a difference for those with Windows 7, but I am not a technological wizard. (****, I just got my first Smartphone - but I am making strides in learning about this "stuff" each and every day.) In the 4th post above me (posted by 55Gala), there is picture of an iCloud Control Panel on Windows 7 that looks exactly like mine - except for the fact that in the upper right hand corner, his version of iCloud says "2.0", whereas mine says "2.1.1" - which, if the problem has to do with a necessary update, than the solution could perhaps lie there. In my case, I don't think that was the problem, because I believe that it originally said "2.1.1" when I first downloaded it. (But hey - I could be wrong. Some medications give the memory a hard time here. I will say, however, that iCloud is not listed in my history of Installed Updates.)


    So ... When I first downloaded iCloud on to my PC, I was able to check/uncheck both boxes available to me, as well as click the Options tab to the right of Photo Stream. I could make changes, click "Apply", and everything was fine and dandy. Come today, however, I open the iCloud Control Panel, and despite how many times I would uncheck Bookmarks, it didn't matter. I would click "Apply", and it would automatically ask me to sign in again. When I did this, Bookmarks would be checked again. Additionally, Photo Stream was grayed out; I was unable to check the box (which was unchecked), and I was unable to go to Options. I searched the Web, quickly came upon these forums, and found a host of other Apple members having the same problem.


    Somehow, I managed to get my iCloud Control Panel "unstuck", and currently, it is working fine. I did 2 "things" to accomplish this; although I must note that I am not sure if doing both solved the problem, or just the 2nd "thing" in my case. The 1st step listed below, however, is something that I haven't come across as a possible part of a solution. It is something that I just happened to stumble upon whilst searching my PC for possible fixes to the problem.


    Step 1: Find your iCloud File Folder. (On my PC, I clicked the Start button in the lower left corner, then clicked All Programs, and finally scrolled down to where all the folders for various "things" are.) Click the Folder and a sub-list will appear, with items such as Calendar, Mail, etc. Right-Click the iCloud Program icon, and at the bottom of the list that appears, click on Properties. At the top, there are 5 tabs. Click the Compatibility tab, and you should see, at the top, the following words: "If you have problems with this program and it worked correctly on an earlier version of Windows, select the compatibility mode that matches that earlier version." Following these words is a dropbox underneath "Compatibility Mode", and for some reason - I have no idea why this is - the box was checked to run the program in compatibility mode for "Windows XP (Service Pack 2)". (And from what I understand, Windows XP is not a compatible Windows Edition for iCloud, so I have no idea why this box was checked.) If the box underneath "Compatibility Mode" is checked, then it is running iCloud in compatibility mode for any number of earlier Windows' Editions. Uncheck this box, click the "Apply" button, and then click "OK".


    Step 2: Find your PC's Control Panel. (On my PC, I clicked the Start button in the lower left corner, and then clicked Control Panel in the list to the right.) In the Control Panel, click Programs. Under Programs and Features, Click "Uninstall a program" (and bear with me here, because you are actually not going to uninstall iCloud). Now, scroll down the list and find "iCloud". Double-click the "iCloud" icon, and a panel with 2 options should appear: "Repair" and "Remove". Check the "Repair" box, which will reinstall the same iCloud Control Panel, replacing missing or damaged files. ("Remove" will just .. well ... remove iCloud from the computer - or, if you prefer, uninstall the program.) Click Next, and the repairing process will begin and end. And that is it - you're done. Task Completed.


    Well, in the end, this worked for me. Photo Stream was no longer grayed out. I could permanently uncheck Bookmarks (finally). The Options tab for Photo Stream would open. Anytime that I clicked the "Apply" button after checking/unchecking boxes, it wouldn't ask me to sign in again (only to come back to a Control Panel that looked just like it did before I made any changes to it.). And the best part: I created a Shared Photo Stream on my phone using photos from my Camera Roll (to test the program), and the Shared Photo Stream appeared on my PC's Photo Stream in no time. Hopefully, this will work for you too (regardless of the Windows Edition you are currently using).


    ~ Brian


    <Edited By Host>

  • NastyNas Level 1 Level 1 (0 points)

    Hi Brian, thanks for the suggestion; unfortunately it didn't work for me. I'm still having the problem where photostreamsdownloder.exe "kicks-in" (i can see the task start that's supposed to download the pictures), but something goes wrong, and photostreamsdownloader.exe takes 100% cpu until I manually end the task. I've pretty much gave up on this issue at this point. I started using Microsoft SkyDrive to backup my pictures in the cloud, but it adds an extra step.

  • louloumax Level 1 Level 1 (0 points)


    i tried your method awhile ago and it didn't quite work. HOWEVER, if i completely uninstall icloud, rather than try to repair it, it works fine after reinstalling the icloud.

    all was well until apple had an update on icloud which i installed on my windows 7 desktop. then it stopped working again. i had to uninstall and reinstall the icloud program once again. fine so far. thanks.

  • NastyNas Level 1 Level 1 (0 points)

    UPDATE: I have found a solution! Brian's advice didn't work for me at first, but it got me thinking about compatability mode. I had compatibility mode turned off for iCloud.exe, BUT there are some other executables that photostream uses as well, and you need to make sure these ARE NOT in any compartibility mode either:


    C:\Program Files (x86)\Common Files\Apple\Apple Application Support\APSDaemon.exe


    C:\Program Files (x86)\Common Files\Apple\Apple Application Support\WebKit2WebProcess.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\AppleOutlookDAVConfig.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\ApplePhotoStreams.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\ApplePhotoStreamsDownloader.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\BookmarkDAV_client.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\EReporter.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\iCloud.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\iCloudServices.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\iCloudWeb.exe


    C:\Program Files (x86)\Common Files\Apple\Internet Services\PhotoStream.exe


    Check each of those to make sure compatibility mode is not turned on. To confirm there are no remaining compatibility settings, you can check this registry key:


    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers


    In the right pane, there should be NO entries for Apple related services. I noticed even after I thought I turned everything off manually, there were a couple remaining registry entries. If you see anything in the right pane related to apple, icloud or itunes services, delete them.


    After I did that, I uninstalled and re-installed iCloud control panel, and it started working.


    I hope this helps someone. Thanks to Brian for the advice that pointed me in the right direction.

  • wateron Level 1 Level 1 (0 points)

    When I right click on iCloud icon & select Properties there is no compatibility tab. The tabs shown for me are General, Sharing, Security, Previous Versions, & Customize.

  • suntan68 Level 1 Level 1 (0 points)

    i had a quick fix on this issue. I just opened the cloud control panel, signed out, then signed back in. it worked.

  • octopuse Level 1 Level 1 (0 points)

    This sir deserves a medal.

Previous 1 2 3 4 5 Next