Previous 1 21 22 23 24 25 Next 367 Replies Latest reply: Dec 9, 2013 5:09 PM by yojamey Go to original post Branched to a new discussion.
  • Wild Banchi Level 1 Level 1 (0 points)

    Finally got my T-Mobile SIM card in the mail today. However, I tried to remove my AT&T GoPhone SIM and put the unactivated T-Mobile one in, but the 'Cellular Data Network' option is not appearing. I have tried at least 7 times, now. The order for instructions goes 'Settings' > 'General' > 'Cellular' > 'Cellular Data Network' (which is not appearing), right? Where does the 'Cellular Data Network' option appear? Right below the 'Cellular Data: On' bar?


    I don't know what I'm doing wrong. My phone is a LOCKED iPhone 4 running AT&T's GoPhone service. I just don't understand why the option to edit the cellular data network settings do not appear when I put the unactivated T-Mobile SIM card in.


    Please help! :(

  • Wild Banchi Level 1 Level 1 (0 points)

    I should also mention that I did install the AT&T profile from the website. Still not working...

  • SarahJ82 Level 1 Level 1 (0 points)

    I've got an unlocked iPhone 4s on tMobile.  After the update to iOS 6.1, I can not send MMS picture texts (sent plenty before the update).  I haven't seen a definitive answer with my specific variables on this thread.  Can anyone attest to a solution that works in my situation? 

  • Havoc488 Level 1 Level 1 (0 points)

    After ou put the T-Mobile sim in let the phone reboot open your settings>cellular then the network option should appear above the personal hotspot bar. Once it does then you can change out the SIM cards again and the network option should stay visible. There is a video on YouTube showing step by step and it does work!

  • kxcumeum Level 1 Level 1 (0 points)

    This does work. I found alot of the posts in here to be extremely helpful.


    But there is something that I haven't seen anyone mention.


    I tried and tried and tried for hours and it just didn't seem to work for me. Until I UNINSTALLED the unlockit profile. That was what kept blocking the MMS codes from working.


    So for AT&T GoPhone users I would advise you to UNINSTALL the unlockit profile.


    REMOVE the unlock it profile if you want this to work.

    After I removed the unlockit profile, and tried the MMS trick, it worked immediately after! Data and MMS worked and still does!

  • adrianfel01 Level 1 Level 1 (0 points)

    Don't know if anyone tried this yet, but I had a problem when sending a text to both Facebook and Twitter to update status via short SMS number on a Virgin Mobile iP4S with iOS 6.1


    I poked into iMessage settings and after a few test messages turned off "Group MMS." From that point, all of my texts went through without a hitch.

  • fdmar Level 1 Level 1 (0 points)

    Finally, thanks to this message board, there is a solution that works!  I have an iPhone 4, that was off contract but locked to AT&T, and was on the AT&T GoPhone Prepaid $0.10/minute plan without data.



    A)  The phone MUST be unlocked to recognize the T-mobile microSIM. AT&T does unlock iPhones now.  I put in the request, and then received unlock instructions without 2 hours.  You just plug in you phone to iTunes, back it up, and then "Restore" and it is unlocked.


    B)  You need a T-mobile microSIM card.  I happened to have one, I'm not sure it if it was activated or not but it worked.  These can be found for a few dollars on eBay.


    C)  I'm not sure if what you have to input is case sensitive or not, if it's capitalized below best to be safe and follow the same format




    1)  Insert T-mobile microSIM

    2)  Navigate to:

    Settings > General > Cellular > Cellular Data Network ("Cellular Data Network" will only appear with the T-mobile SIM inserted)

    3)  With this screen still open, remove the Tmobile SIM, and re-insert the AT&T SIM, but **stay on this screen** and enter in the following under the "Cellular Data" and "MMS" sections:





    APN: wap.cingular


    Password: CINGULAR1





    APN: wap.cingular


    Password: CINGULAR1


    MMS Proxy:

    MMS Max Size: 1048576

    MMS UA Proof URL:


    4)  Go back by selecting "Cellular" then "General".


    5)  Hopefully it's fixed.  Try to send an MMS.  Make sure "MMS" and "Group Messaging" are set to 'On' under:  Settings > Messages.  (Turn on iMessaging here also for good measure)



    Good luck.  Thank you to everyone who posted the solution on here.  I had been trying for hours trying to work this out, and tried every suggestion possibly found on the internet.  This is only one that worked.

  • nkp555 Level 1 Level 1 (0 points)

    This doesn't seem to work for 3GS on consumer cellular system. (ATT) I can do everything except pix text to non-iphone.

    Very annoying.

  • Wildwomn207 Level 1 Level 1 (0 points)

    I have iPhone 4 with AT&T phone with simple mobile.

    This fit mine able to send pics .





    Select Settings.

    General Settings.

    Select Network.

    Select Cellular Data Network.

    Select APN.

    APN: simple

    Username: Blank

    Password: Blank


    APN: simple

    Username: blank

    Password: blank


    MMS Proxy:

    MMS Message Size: 1048576

    MMS UA Prof URL:

  • SarahJ82 Level 1 Level 1 (0 points)

    Finally resolved my issue (unlocked 4s on tmobile stopped sending mms after last software update): APN for both cellular and mms were erased.  I entered in both boxes, and mms have been fine since.  Simple solution that was hard to find.

  • RMortera Level 1 Level 1 (0 points)
  • timery.s Level 1 Level 1 (0 points)

    I had this issue with my 4S on AT&T after updating to iOS 6. Group Messaging and sending pictures/video via MMS stopped working. Regular SMS messaging worked fine, and sending media via iMessage worked, just not via text messaging. Pictures and videos via MMS would have the "sending" status bar, then fail near the end. Group Messaging would come through as individual messages from each sender and not show other addressees in the group. Whenever I restarted my phone, it would always give a pop up saying "MMS Messaging Requires Your Phone Number. Press Settings to go to Phone Settings and enter your phone number." After going to settings, it already had my number entered. I tried several solutions on different message boards and nothing seemed to work.


    I don't think Apple has officially fixed this yet as I see several people still experiancing this issue, but mine has recently been fixed, and quite unexpectedly too. After getting married this past month, I added a new line to my account for my wife's new iPhone 5. She was previously using a Droid on Verizon, so we just ported her number to the new phone. For whatever reason, immediately after doing this my MMS and group messaging issues were completely resolved... as in that same day I could send media again via MMS. Her phone worked right out of the box of course and hasn't had any of these issues to date. I was shocked and tested this extensively to ensure it wasn't a fluke because I didn't want to get my hopes up. At this point (about a month in) everything is working like it should.


    As stated in previous posts, anecdotal evidence suggests that updating a device to iOS 6 that was backed up using an earlier version of iOS could corrupt certain data in profiles, regardless of whether backing up to iTunes or iCloud. Restoring a phone running iOS 6 from such a backup is also said to cause these messaging issues. It's worth noting that while MMS and Group Messaging are now working properly, my phone still gives the pop up message whenever restarted about entering my phone number. Since we don't have confirmation from Apple on the alleged data corruption bug I can't say for sure, but if legit, my 4S would have been affected by that. My iPhone backup was originally created on my 3GS years ago, restored to a new 4S when I upgraded, dunked that 4S in water, then restored to a second 4S.


    In summary, it's difficult to say what the issue stems from but, adding an iPhone to another line on my account solved it for me.

  • slick6 Level 1 Level 1 (0 points)

    I just wanted to say that the T-Mobile sim card hack worked perfectly for me. My daughter has an iPhone 3GS which we updated to the latest version of iOS 6.1.3. After we updated, we found out we were not able to send or receive MMS messages anymore because it is set up as a Go-Phone plan. I did some poking around on the Internet, found the way to re-enable MMS texting from this support thread and another support thread from an AT&T website. I made sure to reset all settings on my iPhone 3GS before i did anything. I had to do it twice, because I forgot to remove the T-mobile sim card and replace it with the AT&T sim card after I was able to access the cellular settings. Just remeber to do that because the T-Mobile sim card is just to access the cellular settings page on the iPhone. After I inputed all the settings, I did not even had to re-boot the phone. I did a test MMS picture text to my self and it worked perfectly. It even improved it from before, because my daughter said she was not able to send out or receive any MMS while on the 3G network, now she can. Who ever found this hack, I thank you very much!! I included the other forum support page I found on this hack at the bottom of my post. Good luck everyone!


  • stephxbee Level 1 Level 1 (0 points)

    OMG. When I read your answer, I was like, "...I never tried THAT!" And, then, I did it. And, it works. THANK YOU THANK YOU THANK YOU!

  • ybnormo Level 1 Level 1 (0 points)

    i did all the steps and successfully changed the apn and it still will not send mms.  i have an iphone 4 running ios 6.1.3 with just a 4.99 text package.  do i need to upgrade to an actual monthly plan?