Previous 1 2 3 Next 274 Replies Latest reply: Oct 28, 2013 9:30 AM by Jacob6400
cmsmith Level 1 (0 points)

I upgraded to 10.8.2 today and cannot login to Messages, Facetime or Game Center. In Messages I get the error "Could not sign in to iMessage. The server encountered an error processing registration. Please try again later.  " when I enter my Apple ID. It was working this morning prior to the update. In FaceTime i get the error "The server encountered an error processing registration. Please try again later.". I was able to also use this in the prior version (10.8.1).

 

Game Center on the other hand; I've never been able to get that to login. I immediately get an error when I try to login: "The requested operation could not be completed due to an error communicatiing with the server." I was hoping today's update would fix this. (I don't use it often. And it is a different Apple ID than I use for messages/facetime.

 

It looks like an problem on Apple's account side, but I was able to log in to the support community with my Apple ID, and my iPhone/iPad. Hopefully, I'm not the only one, and we can get this fixed.

  • Reserved Egotist Level 1 (5 points)

    This is happening for me as well.  This is what I am getting from Console:

     

    9/19/12 11:59:28.787 PM com.apple.SecurityServer[17]: Session 100014 created

    9/19/12 11:59:32.216 PM Messages[256]: [Warning] Empty account query with service: iMessage

    9/19/12 11:59:32.598 PM imagent[163]: [Warning] TRUST validation failed with result 5

    9/19/12 11:59:32.598 PM imagent[163]: [Warning] FTFaceTimeServerBag: URL bag data invalid (not valid)

    9/19/12 11:59:57.057 PM Console[269]:  Marker - Sep 19, 2012 11:59:57 PM

     

    I upgraded to 10.8.2 from Lion and prior to the upgrade Messages work fine. Facetime as well. What gives? I looked at older threads and none of those suggestions helped (plist, safe mode, killing imagent)

     

    In fact, even putting fake data returns the same error saying "The server encountered an error processing registration. Please try again later"

     

    This is highly aggravating as a user. Any help would be appreciated.

  • onidino Level 1 (0 points)

    PLEASE HELP US

  • Ralph Johns (UK) Level 9 (71,178 points)

    Hi,

     

    Go to Utilities (Applications/Utilities)

    Open Keychain Access

    Find the trust key for the iMessage name and delete it.

    Restart Messages.

     

     


    9:43 PM      Thursday; September 20, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and and iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Reserved Egotist Level 1 (5 points)

    http://support.apple.com/kb/TS3970?viewlocale=en_US

     

    This page solved my issue. The relevant one for me was the fact I edited /private/etc/hosts.

  • pixart Level 1 (10 points)

    Check that your hosts file (/etc/host) is not blocking some important communication with Messages or game center.

     

    I opened my hosts file in TextMate and commented out everything that was not default, saved it, restarted Messages and GameCenter, then logged in.

     

    After logging in I uncommented the comments in my hosts file, saved it, and everything was back to normal.

     

    Hope this helps someone.

  • onidino Level 1 (0 points)

    thank you finally it works!

  • eScdrift Level 1 (0 points)

    where do you find the hosts file? library?

  • eScdrift Level 1 (0 points)

    nevermind, got it to work. thanks for that link.

  • BrynXXX Level 1 (5 points)

    @Ralph Johns.

     

    Nope, your suggestion doesn't work.

  • Ralph Johns (UK) Level 9 (71,178 points)

    Understood.

     

     


    9:30 PM      Sunday; September 23, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and and iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Scott Buchanan1 Level 1 (25 points)

    Any additional ideas out there?  I've checked my /private/etc/hosts file and removed the keys in keychain and I'm still failing and getting the message

     

    9/25/12 10:57:28.790 AM Messages[7696]: [Warning] Empty account query with service: iMessage

     

    in Console.

     

    Thanks

     

    Scott Buchanan

  • Scott Buchanan1 Level 1 (25 points)

    As a follow up I'm now up and running.  To do this I had to go to System Preferences->Mail, Contacts, Calendars and delete my AIM/AOL account there.  I had previously deleted the AIM account in the messages app, deleted all messages preferences (~/Library/Preferences) iChat preference and iChat and Message Caches and Messages directory from ~/Library/Messages to no avail.  Everything came back, apparently from the remnant in the System Preferences.  Anyway this fixed it for me.

  • dave1207 Level 1 (0 points)

    Thanks for the info!  I edited my hosts file and I am now able to login.  But the messages aren't showing the real contact name.  They are just showing 555-555-5555.  I am also still getting "Empty account query with service: iMessage" in the console. 

     

    Anybody else seeing this?

  • Reserved Egotist Level 1 (5 points)

    Actually yes. On a related note, even though I can sign in successfully, it looks like the Keychain behavior is not working very well; every once in a while iMessages will keep bugging me to enter my password. I don't know why. I already reverted /private/etc/hosts to original yet still see the Keychain not actually storing the keys. Has anyone else noticed this too?

Previous 1 2 3 Next