Previous 1 15 16 17 18 19 Next 274 Replies Latest reply: Oct 28, 2013 9:30 AM by Jacob6400 Go to original post
  • Ralph Johns (UK) Level 9 Level 9 (69,330 points)

    Great.

     

    (IMAgent)

     

    Thank you.

     

     

     

     

    3Sigcopy2.png
    8:44 PM      Thursday; February 28, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • _y3k_ Level 1 Level 1 (0 points)

    Ok I have spent few hours on this, reading this thread and trying various options and finally fixed the issue. Here's what worked for me... Forget deleting Library/Preferences files and keychain keys, or resetting PRAM - the issue is that iMessage needs to refer to certificate authorities during activation process. So whatever you've done with the software on your mac before, go find the /etc/hosts file and comment all the lines containing the words like thawte, verisign or other authorities issuing trusted certificates. Or better just revert it to the default look at least temporarily:

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1          localhost

    255.255.255.255          broadcasthost

    ::1             localhost

    fe80::1%lo0          localhost

     

    No need to re-boot then - just go activate your iMessage and then you may come back to restore the previously commented or deleted /etc/hosts lines.

     

    For those not really friendly with UNIX permissions etc. - you may find Textmate editor very useful in this case, it would just ask you to confirm your actions with standard authorization request and you won't need to play with copying /etc/hosts file for editing, copying it back and fixing ownership and permissions on it.

     

    I think this is it. Thank you guys for a great research and you Ralph for helping out!

  • General Mischief Level 1 Level 1 (0 points)

    Soo... If I'm a totally lost regarding handling Terminal, etc, what to do?   Is it possible to get a step-by-step instruction anywhere? 

    Ohh, I'm now on 10.8.3, that didn't fix the issue though.

     

    Thankful for your reply! BR / Erik

  • Ralph Johns (UK) Level 9 Level 9 (69,330 points)

    HI,

     

    IN the Finder > GO Menu > GO to Folder type /etc/hosts in to the dialogue box that appears.

    This will show you the Hosts file in the etc  folder.

    Hosts.png

    It can be opened with TextEdit and a unchanged one looks like this

    Hosts file.png

    Any line that has been added and refers to Verisign or Apple needs to be "Commentated Out" by placing and extra # symbol on those lines  (Anything that Starts # is ignored).

    When you try and Save the System may ask you for your Login Password as you would not normally have permissions to change this file.

     

     

    3Sigcopy2.png
    7:27 PM      Tuesday; March 19, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • General Mischief Level 1 Level 1 (0 points)

    Thank you so much! I have only one more question; when I try to edit the hostsfile and add a # before anything with verisign OSX prompts that I dont have permission to do that and asks me if I want to create a copy. I've done that and saved it to my desktop with the changes made. Can I just replace (and maybe save the original file) the original file with the copy if I rename it?

  • _y3k_ Level 1 Level 1 (0 points)

    The procedure of setting the right permissions and using Text editor would be too complicated for a user asking about # signs and "create a copy" things. Just go google "Textmate editor", download and install yourself a trial version and you can open, edit and just save /etc/hosts without problems of creating copies or setting manual permissions. It would just ask you periodically for authentification as MacOS usually asks when you install something important. Trust me

  • General Mischief Level 1 Level 1 (0 points)

    Well, the thing is I'm denied making changes (see prt.screen)  when opening the file with Text Editor.

     

     

     

    Screen Shot 2013-03-20 at 10.14.22.png

     

    Screen Shot 2013-03-20 at 14.01.35.png

  • Ralph Johns (UK) Level 9 Level 9 (69,330 points)

    Hi,

     

    It was a while ago that I did this and the precise steps I did at the time escape me for the moment.

     

    _y3k_ is suggesting this App to  do the job, Textmate Editor

    This should get around the Permissions thing and the issue with trying to do it Terminal.

     

     

    3Sigcopy2.png
    7:59 PM      Wednesday; March 20, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Thor HoG Level 1 Level 1 (0 points)

    You don't need any of that stuff.  Just get to terminal and do a:

     

    "sudo nano /etc/hosts"

     

    It's text navigation, so use your arrow keys to move around.  when you are done, hit Ctrl+O (letter O), hit enter to save changes, then Ctrl-X to exit.  Changes are immediately refected the next time you perform any dns-related transaction.

     

    Note, it is "Control" not "Command."

     

    t

     

    Message was edited by: Thor HoG   Made the command-line command more clear.

  • General Mischief Level 1 Level 1 (0 points)

    It worked when going through the procedure with a freshly downloaded Textmate Editor 2.0 Alpha! Great job you guys, thanks a lot!  

     

    thumbs.jpg

  • MacEdwinC Level 1 Level 1 (0 points)

    Guys, I have been reading through the post.

     

    issue is comparable, but I see an error in my console that keeps poping up as soon as I try to login to imessage or face time

     

    the message is: check connection.

     

    I tried the DNS 8.8.8.8. I tried to edit the host file... nothing seems to work.

     

    Can anyone shed some light on this? the accounts I used are all valid appleID. I use them on my iPhone and Ipad, none of them work.

     

    would appreciate to hear what I can do next. The certificate list in my macbook has quite a list with apple

     

    com.apple.ubiquity.ssl-cert.403A2B5A-E352-4BA0-BEC5-D44130B65A17

    and also

    com.apple.ubiquity.peer-uuid.403A2B5A-E352-4BA0-BEC5-D44130B65A17

     

    as not being trusted. the experiy date has past (nov 12) issue is that even before this date it never worked on this macbook. (macbook air late 2011)

     

    I am lost...

     

     

    22-03-13 15:51:58,871 apsd[71]: Got connection error Error Domain=NSURLErrorDomain Code=-1202 "The certificate for this server is invalid. You might be connecting to a server that is pretending to be “albert.apple.com” which could put your confidential information at risk." UserInfo=0x7f85ccbfab30 {NSURLErrorFailingURLPeerTrustErrorKey=<SecTrust 0x7f85ceb020d0 [0x1108c4110]>, NSLocalizedRecoverySuggestion=Would you like to connect to the server anyway?, NSUnderlyingError=0x7f85cea22150 "The certificate for this server is invalid. You might be connecting to a server that is pretending to be “albert.apple.com” which could put your confidential information at risk.", NSErrorPeerCertificateChainKey=(

        "<SecCertificate xfxfxfxfxfxfxfxf [xvxvxvxvxvxv]>",

        "<SecCertificate xvxvxvxvxvvx [xvxvxvxvxvv]>",

        "<SecCertificate xvxvxvxvxv [xvxvxvxvxv]>"

    ), NSLocalizedDescription=The certificate for this server is invalid. You might be connecting to a server that is pretending to be “albert.apple.com” which could put your confidential information at risk., NSErrorFailingURLKey=https://albert.apple.com/WebObjects/ALUnbrick.woa/wa/deviceActivation?device=Mac OS, NSErrorFailingURLStringKey=https://albert.apple.com/WebObjects/ALUnbrick.woa/wa/deviceActivation?device=Mac OS, NSErrorClientCertificateStateKey=0}

  • Ralph Johns (UK) Level 9 Level 9 (69,330 points)

    HI,

     

    It appears at some levels that iMessages and FaceTime are separate as you can use different names (Apple IDs)

    However this can make for strange iMessages invokes of FaceTime as the FaceTime Invite is then from "someone else" as far as the contact is concerned.  (i.e. it is possible but I would not recommend it)

     

    It does seems that both services need to check on the Apple ID  and it  would make sense that this was via the same server.

     

    AS to why your certificates have gone out of date without an update I have no idea I am afraid.

     

     

     

     

    3Sigcopy2.png
    9:03 PM      Friday; March 22, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Hascall Sharp Level 1 Level 1 (0 points)

    If the /etc/host file suggestion doesn't fix the problem, then try the solution for Facetime shown here:

    http://pastebin.com/ke3SJLL0

     

    In my case, my host file was fine, but I still had the problem.

     

    I had migrated over from an old MacBook Pro running Lion to a new one running Mountain Lion.

    I had copied over my old login keychain (as "login-old").

     

    I finally tracked down the problem to an old key in the "login-old" keychain -

      "ids: identity-rsa-public-key"

     

    I deleted this key from the "login-old" keychain, then deleted the plists mentioned previously:

      com.apple.imessage.bag.plist

      com.apple.imservice.iMessage.plist

      com.apple.imservice.FaceTime.plist

     

    (all in the user's /Users/<username>/Library/Preferences folder)

     

    Then rebooted. 

    When I started Messages, I re-enabled my account, signed in and everyone worked.

    Hope this helps.

     

    Chip

     

    P.S.  While debugging this, I found that rebooting into Safe Mode hangs on my MBP.

    Workaround was to reboot into Safe+Verbose Mode (Shift-Cmd-V).

  • Thor HoG Level 1 Level 1 (0 points)

    Hascall Sharp wrote:

     

    If the /etc/host file suggestion doesn't fix the problem, then try the solution for Facetime shown here:

    http://pastebin.com/ke3SJLL0

     

    In my case, my host file was fine, but I still had the problem.

     

    Personally, I'm quite surprised anyone's host file would have been screwed up in the first place.  I don't know what circumstances would warrant a process arbitrarily making host entries for 3rd party hosts would be.  My host file was fine as well.

     

    I had copied over my old login keychain (as "login-old").

     

    I finally tracked down the problem to an old key in the "login-old" keychain -

      "ids: identity-rsa-public-key"

     

    I deleted this key from the "login-old" keychain,

    It's a good thing your errant public key was in the "login-old" keychain.  IDs public and private pairs are in the Login keychain by default, and can be used for any number of things, primarily your logon for network access.  The suggestions on Pastebin are actually pretty dangerous for people in the wrong circumstances - disastrous, really.   Not that anyone would, but if someone started going through keychains and deleting keys, the could, say, delete their filevault private key and be completely screwed.   Some keys will be automatically regenerated, like the message: key, but I thought I would at least warn people.

     

    Glad it worked for you, though!  Locking on safe-boot isn't good.  I've only seen that on Hackintosh's.  In fact, I've only seen the iMessage problem on Hackintosh's as well, but TonyMacx86 has a fix for that.

     

    Anyway, cya.

     

    t

  • B. Kennedy Level 3 Level 3 (635 points)

    I don't see what this has to do with the Hosts file. Messages just one day wouldn't let me log in. I went into System Prereferences, removed my iCloud account, rebooted, added my account and it worked again.