Previous 1 2 Next 26 Replies Latest reply: Sep 23, 2015 1:59 PM by anne0660
bsilva728 Level 1 Level 1 (0 points)

I suppose I should start from the beginning.  I do not know what I'm doing exactly, but enough to make things work for a little while at least. I seem to have lost all my photos including everything from the first 2 years of my sons life... I am horrified.


I ran out of space long ago on my laptop, so I bought an external HD to store photos. I hooked up my external HD to my Time Capsule, thinking this would be ideal beacuse I would always have access to my photos. So I moved my iPhoto library to the external HD and that was that. I assumed that since it was hooked up to the TC it would be backed up (I dont think it is because I can't find it.) It worked well enough for a while but it was slow. I had the problem lately of iPhoto not responding and having to force quit, especialy when just quitting the program. I also had frequent errors importing photos and would hve to re-start.


I decided that I should have the most up to date software and I added some RAM. IPhoto '11 installed fine but the problem arose when I tried to "upgrade the library."  Somehow my computer lost connection with my networked external HD and now the application was not responding... Stupidly I force quit. I didnt know that this was a problem.


Now when I open iPhoto there are events but no thumbnails. When I click on photos it shows a triangle with an exclamation point. I previously had approx. 12,000 photos. The library shows that it is 162.67 GB, which seems about right. Also I looked but I can't find a backup of the library.


I tried to repair the library but it didnt work.


I also tried iPhoto Library Manager to no avail.  This is what it did:


It "rebuilt" a library that is only 7.6GB. It said there were 349 photos.  There were 349 errors and so there are 0 photos.


Please help. I feel sick to my stomach and my wife is very sad.  Thanks in advance

MacBook Pro, Mac OS X (10.7.5)
Previous 1 2 Next