Previous 1 2 Next 26 Replies Latest reply: Sep 23, 2015 1:59 PM by anne0660
bsilva728 Level 1 (0 points)

I suppose I should start from the beginning.  I do not know what I'm doing exactly, but enough to make things work for a little while at least. I seem to have lost all my photos including everything from the first 2 years of my sons life... I am horrified.


I ran out of space long ago on my laptop, so I bought an external HD to store photos. I hooked up my external HD to my Time Capsule, thinking this would be ideal beacuse I would always have access to my photos. So I moved my iPhoto library to the external HD and that was that. I assumed that since it was hooked up to the TC it would be backed up (I dont think it is because I can't find it.) It worked well enough for a while but it was slow. I had the problem lately of iPhoto not responding and having to force quit, especialy when just quitting the program. I also had frequent errors importing photos and would hve to re-start.


I decided that I should have the most up to date software and I added some RAM. IPhoto '11 installed fine but the problem arose when I tried to "upgrade the library."  Somehow my computer lost connection with my networked external HD and now the application was not responding... Stupidly I force quit. I didnt know that this was a problem.


Now when I open iPhoto there are events but no thumbnails. When I click on photos it shows a triangle with an exclamation point. I previously had approx. 12,000 photos. The library shows that it is 162.67 GB, which seems about right. Also I looked but I can't find a backup of the library.


I tried to repair the library but it didnt work.


I also tried iPhoto Library Manager to no avail.  This is what it did:


It "rebuilt" a library that is only 7.6GB. It said there were 349 photos.  There were 349 errors and so there are 0 photos.


Please help. I feel sick to my stomach and my wife is very sad.  Thanks in advance

MacBook Pro, Mac OS X (10.7.5)
  • bsilva728 Level 1 (0 points)

    i realize i made a lot of mistakes in how iPhoto was configured but I didnt realize it until now...

  • Terence Devlin Level 10 (137,883 points)

    Hook that external disk up to your Mac directly and then look for the photos on it. Look inside the Library packages:


    Right (or Control-) Click on the Library icon and select 'Show Package Contents'. A finder window will open with the Library exposed.



    Can you find them?

  • bsilva728 Level 1 (0 points)

    i just right-clicked the iphoto library and clicked show package contents. there were photos in the "modified" and "originals" folders... what do I do with them?

  • Terence Devlin Level 10 (137,883 points)

    Are the missing photos in the Originals folder?

  • bsilva728 Level 1 (0 points)

    they appear to be yes... There are many, many folders, but they are indeed giving me a great since of relief... but I'm not sure what to do with them...

  • Terence Devlin Level 10 (137,883 points)

    Well as you have no back up and as rebuilding with Library Manager didn't work, then you need to recover the photos and make a new Library and start over. What version of iPhoto do you have?






  • bsilva728 Level 1 (0 points)

    i have version 9.4. I have made a duplicate of the iphoto library since this happened but i dont know if that was worthless or not. Thank you very much btw... i was horrified

  • Terence Devlin Level 10 (137,883 points)

    To create and populate a new iPhoto 11 library:


    Note: this will give you a working library with the same Events and pictures as before, however, you will lose your albums, keywords, modified versions, books, calendars etc.


    Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Create Library'


    This makes a new blank Library.


    Go into the damaged iPhoto Library (Right Click -> Show Package Contents)  and find the Originals folder. From the Originals folder drag the individual Event Folders to the iPhoto Window and it will recreate them in the new library.


    When you're sure all is well you can delete the damaged iPhoto Library.


    Going forward: You must have an up-to-date back up at all times. You don't want to edit that Library over a wireless connection: If you're trying to edit the Library (that is, make albums, move photos around, keyword, make books or slideshows etc.) or edit individual photos in it via Wireless be very careful. Dropouts are a common fact of wireless networking, and should one occur while the app is writing to the database then your Library will be damaged. Simply, I would not do this with my Libraries. 






  • drabo Level 1 (0 points)

    Hello, I had the exactly same problem with bsilva728, so I tried to follow your instructions above.  I found the Originals folder, however It seems there are no picture files inside of the subfolders.  When I drag each subfolders to newly created I photo library, nothing is happening.  I also checked modified folder and there is no picture files in each subfolder.


    Before I found this thread, I tried to drag the corrupted (?) iphoto library file to new I photo library and I see my pictures, however there are lots of duplicated folders, pictures, face thumbnails.  Also the size of the pictures are now very small. 


    Please advise me if there is anyway I still can recover my pictures with original size.  The size of original Iphoto library is almost 50 GB (pictures from 2007~) and at least I want to recover last 12 months of pictures which are my son's birth through 1st birthday...

  • Terence Devlin Level 10 (137,883 points)

    If there  are no files in those folders then you need to restore from your back up.


    I tried to drag the corrupted (?) iphoto library file to new I photo library


    Never import one Library to another. Every version and thumbnail is imported like a distinct photo, you lose all your Albums, Keywords etc., the link between Original and Previews is destroyed, the non-destructive editing feature is ruined and so on. In summary: it's mess.

  • jwheeler41 Level 1 (0 points)

    Hi Terence, I came upon this thread and took your advice when I upgraded to the new iPhoto (from 09 I think?) and my pictures showed up as gray with exclamation points.  Couldn't see any pictures at all.  Tried the rebuild first but that didn't work, so created a new library and drug all the originals from the old corrupt one into the new one.  When I went to the originals folder, I just saw a bunch of folders by year so I just drug all those to the new library, and all 6k of my pictures came over, but in original form and no albums or events.  That's fine, but now it appears the new library is still pulling the pictures from the old one, because when I trace a pic back to its file from the new library, it's in the old one.  And the new library is only 3 gb but my old one is 115 gb, so the new library is clearly some kind of shell.  But you said you can delete the old one after this process, but obviously I can't.  Do you know why my pics would still be housed in the old library but open up fine and are accessible in the new library?  I'd like to have just one library going forward.  Any help would be greatly appreciated.

  • Terence Devlin Level 10 (137,883 points)

    Are you running a Managed or a Referenced Library?


    A Managed Library, is the default setting, and iPhoto copies files into the iPhoto Library when Importing. The files are then stored in the Library package


    A Referenced Library is when iPhoto is NOT copying the files into the iPhoto Library when importing because you made a change at iPhoto -> Preferences -> Advanced. (You unchecked the option to copy files into the Library on import) The files are then stored where ever you put them and not in the Library package. In this scenario you are responsible for the File Management. 

  • fikoukla Level 1 (0 points)

    Hi - I seem to have a similar problem. I was prompted to update to iPhoto 11 yesterday (don't know why yesterday, I'm in iPhoto all the time). So I followed the instructions, library updated, all existing events and albums are there. I uploaded some more pictures and created a few new albums and did some new year spring cleaning, moving stuff around etc. And I started making a calendar.


    I've opened it up today, my calendar is still there as are all the new events, but the pictures are empty outlines. If I open up a picture I just get the "!" but I can still see the thumbnails showing in the slider in the bottom - I don't know if that means the source files must still be there somewhere, or if it just means it captured thumbnails yesterday.


    I've gone into it via "show package contents" and there just don't seem to be any masters for an upload yesterday. I also just had a look in the last import folder, because of a comment from someone above. As I scrolled down through the folder the images were there and literally disappeared in front of me - by which I mean, the thumbnails were there as I scrolled down and then would turn into empty outlines...!


    All my old folders are still there, thankfully (although they're of course the ones that are also all safely back up).


    Although I have a timecapsule, my photo library is too big to keep on my hard drive, so I keep it on an external drive - so it only gets backed up when I do it manually (thanks Apple for that, I will never understand why it was designed to work - or not work - that way). So if the pictures have been lost then they are gone for good which is super-frustrating (I just got back from South Korea and was in the middle of sorting out all my shots from that trip).  It seems that this can only have happened because of the update - I should have known better than to have pressed yes.


    If you have any ideas, I'd be most grateful!




  • Terence Devlin Level 10 (137,883 points)

    Different problem, make a new thread for it.

Previous 1 2 Next