Previous 1 2 3 Next 35 Replies Latest reply: Jun 10, 2013 12:24 PM by IMRAN
JPHuff Level 1 (10 points)

I upgraded a 3rd gen iPad and an iPhone 4 to iOS 6, then updated my Macbook Pro (2.4 ghz quad core i7, 8GB RAM) to 10.8.2 with the requisite iPhoto update.  Now, iTunes will not show my iPad even though wireless sync is enabled, unless the iPad is connected to the laptop via the docking cable.  Both iPhone and iPad error out on synch with an error 1140 if synching photos is enabled.  Under the photo tab, the button to have "selected albums, events and faces" is grayed out.  So I can only select to sync ALL photos or none.  I believe the error 1140 is stemming from my library being too large to sync to the i-device.  In any case, I can no longer choose certain albums that were enabled under iOS 5.  The area below these options in the Photos tab in iTunes also does not show any albums, where it used to do so in a grayed out fashion even if that option was not selected.  Major issue here.  Have tried all the rebuild and repair of iPhoto library.  The kicker is that both the devices I upgraded have the exact same issue, so I'm thinking this is an update/Apple problem, not an issue with my devices or config.

MacBook Pro (15-inch Late 2011), OS X Mountain Lion (10.8.1), 8GB RAM, BootCamp with Windows 7 Pro 64-bit
  • George Mcgee Level 1 (0 points)

    Same here. iPhoto and iTunes all up to date. Get error 1140 every time and cannot select specific albums or events. Please fix.

  • frafischcgn Level 1 (0 points)

    Same. But: For me it seems not to be an iOS 6 problem, all my devices ar affected: iPhone 4 (update iOS6), iPad 1. Gen. (no update, iOS 5.1.1), apple TV 1. Gen (no update). Problem with iPhoto 11 (update 9.4)?

  • George Mcgee Level 1 (0 points)

    I would have to agree with you frafischcgn. This looks like an issue with iPhoto 9.4 breaking iTunes photo sync. I seem to remember this happening about 18 months ago or so as well. I submitted feedback regarding this issue here Hopefully Apple will fix this soon.

  • TomInGarland Level 1 (0 points)

    I didn't encounter this problem after I initially updated to IOS 6 - the iPhone & iPad syncs both worked fine.  Then I updated to iPhoto 9.4 and the 1140 problems began, so at least on the surface it looks like a problem with the iPhoto update.


    To get through a sync, I'm not syncing photos to my IOS devices until this is fixed.

  • bill194 Level 1 (0 points)

    Same or similar problems here. All my individual albums have disappeared from my iPhone photo library, although all the photos are still there (as single photos, all 4000+ of them, in one large album). And I get the syncing error message with iTunes.


    I updated to iOS6 first thing this morning. I didn't check the iPhone photo library at that time, so I don't know whether the update to iOS6 caused the problem with the disappearing albums.


    Later I updated my iMac to OS 10.8.2, and then, immediately afterwards, updated iPhoto to 9.4. Upon opening that, I got the message about my photo library having to be updated (" version unreadable by older versions of iPhoto"). I went ahead with the libary update, which took surprisingly little time. My iPhoto library on the iMac seems to be just fine, with all photos, events, and albums intact.


    That's when I noticed that my main iPhone photo library had no separate events/albums anymore (whenever that happened, and whatever caused it . . .??) and tried to sync it with the new iPhoto library, via iTunes. Didn't work, got the error message. But I can say for sure that the albums were missing on the iPhone before I physically (via the connector) tried syncing it with my iMac and iPhoto 9.4.


    At this point I'm just waiting for some kind of fix, or notification from Apple, or further suggestions on this thread.

  • Tom Charvat Level 2 (440 points)

    Ditto, no individual photo's/albums can be selected. My original photo selections that were on my iPad remained after the iOS6 upgrade.


    But I cannot download any new photo's from my iMac when synched... area grayed out.


    Also get the 1140 Error when all photo synch is selected...


    Help Apple !

  • JPHuff Level 1 (10 points)

    Just as a follow up, I believe the 1140 error may be popping up because there is not enough space on the iDevice for your whole iPhoto library to sync to.  That's certainly the case for me, anyway.


    Oddly enough, my iPad retained the albums that I had been syncing previously.  I just cannot update or change them on iTunes.  This may be because I upgraded wirelessly while at work yesterday morning and my iTunes library was thus not accessible to the device during the upgrade.  I upgraded my phone while I was at home and my MacBook pro was on with iTunes launched.  So maybe some communication happened between the two.  The result being that on the iPhone, the PHOTOS from the albums I was synching are all still present, but they are lumped into on "iPhoto Library" album.  All I have on the iPhone is "Camera Roll" and then "iPhoto Library" with all the photos that should have been present, but in separate albums.  Fortunately, I guess, my iPad still shows the albums I had previously.


    My iPhoto shows all my proper albums.  I haven't detected any problems at all within iPhoto (knock on wood!).


    I sure hope Apple knows enough about this now and can get a fix out in a hurry!

  • bill194 Level 1 (0 points)

    I don't think the 1140 error, in my case, is because of lack of space. My iPhone is a 64Gb model, and only 37-38 Gb are used (33 of which are photos).


    But, otherwise, I think we are having similar problems and perhaps causes. I do wonder whether there was "some communication" between the iPhone and my iMac while the OS 10.8.2 and iPhoto 9.4 updates were taking place, because the iPhone was powered up and connected to the same WiFi network. That's partly what I meant when I said that the iPhone had already lost its albums before I tried syncing it via the physical connector.


    And my symptoms on the iPhone are exactly the same as JPH's: "the PHOTOS are all still present, but they are lumped into one 'iPhoto Library' album" and there is also a Camera Roll album, as well as one other Album that I created just on the iPhone to hold images that I copied in from emails, messages, and other iPhone apps. And, likewise, I haven't yet found any problems within iPhoto 9.4 on the iMac.

  • Patrick in SD Level 1 (0 points)

    Same problem here. I saw a potential fix involving the iPhot cache. I tried deleting the iPod Photo Cache folder found at Home/Pictures/iPhotolibrary (right click/Show package contents) but that did not solve the problem, even though the folder was huge (more than 11 GB). I know there's no way I can synch All photos, as I shoot in RAW format and my iPhoto library is 192 GB. Never had this issue before iOS6/iPhoto update last night.

  • JPHuff Level 1 (10 points)

    Guys, just a quick update.  I went into time machine (after copying my current iPhoto library so I had a backup) and restored my OLD iPhoto Library file from Tuesday before yesterday's upgrade, and the older version of iPhoto.  Problem solved.  Albums showed back up.  Now, iTunes thought I had NOTHING synched already with my i-devices so I had to re-select them and have iTunes warn me that all photos on the device would be replaced with the selected items, but it worked.  My problems with the devices not showing up wirelessly in iTunes is apparently not related, as by shutting off (not restarting but powering off) the devices and back on, they show up in iTunes.  So at least I don't have multiple issues.


    Since this hasn't been reported really wide-spread as an issue, I'm assuming something went wrong with my iPhoto update or I have some issue with my iPhoto library that came up during the conversion to 9.4.  I'm about to try upgrading to 9.4 once more and will report if my issue crops back up or if it goes away.  If it goes away, I guess the solution will be to reapply the update.  We'll see!



  • JPHuff Level 1 (10 points)

    Ok, all.  I think I found the problem.  In searching for reports of this issue and solutions I found someone that mentioned they had fixed a similar issue with a "free" program called "iPhoto Library Manager."  The app apparently lets you split a library into multiple smaller ones or combine multiple libraries.  Generally it just "manages" your libraries.  I figured I had nothing to lose so I checked it out.  Turns out it costs $19.99 but they do have a free demo. 


    I launched it and it immediately told me that it couldn't display my library and albums due to an issue with the AlbumData.xml file on line 22155.  I read in the documentation of the app under it's "Help" menu that likely causes were a keyword with a "null" character at the end, or a file path being referenced inside the library that had an ampersand or backslash in it.  The person on the board I'd found had had a keyword issue.


    Anyway, I opened the iPhoto library by showing package contents (right click the file to choose this) and loaded up the AlbumData.xml file in TextWrangler, since that displays line numbers.  I found that line 22155 indeed referenced an mp3 in my iTunes library that had an ampersand in it.  Deleted that line.  Then it said line 22156 had an issue so I deleted that, at which point iPhoto Library Manager instantly displayed all my albums.  I checked iTunes and it too now showed my albums and the option to sync only selected albums was no longer grayed out!


    Per the Library Manager's instructions, I saved the AlbumData.xml file I'd modified.  The app said the iPhoto only writes this file out, it doesn't read it.  However, other apps read it to get your album info, hence the issue.  So I had to go into iPhoto and fix the problem, else the next time I exited the app, it would write the file back out improperly.  I noticed in the xml file that where the song was listed it was also referencing one of my albums.  So when I launched iPhoto, I went to that album and checked the slide show settings.  Sure enough, I had set a custom playlist for that album and listed the song I had seen on line 22155 in the AlbumData.xml file.  I removed that song from the settings, and exited iPhoto.  No more issues!  I appear to be all set!


    Now, I'm not clear if I NEEDED to edit the AlbumData.xml file.  Just looking at it showed the error and then I had to fix it in iPhoto.  So you can probably do that.  However, the iPhoto Library Manager software is the only thing I know of that could show WHERE the error was.  Since the free demo works for this purpose, I'd suggest giving it a shot.  This issue is obviously caused by our individual libraries and is not an Apple issue.  Now, the album that had the problem has existed for almost 3 years and I've never had an issue like this arise before so it's anyone's guess as to why it became a problem now.  Fortunately, it's all in the past for me now, though!


    Hope this helps someone.  Good luck!

  • bill194 Level 1 (0 points)

    Thanks, JP, for all the investigative time and advice! I'm not going to have time today to do any uninstalls/reinstalls, or work with "iPhoto Library Manager" -- but I'm definitely going to try out that app to check and possibly edit my files.


    Meanwhile, there's now a lot of talk about this problem on other threads. Here's one in particular:


    The consensus is that it's a problem with the iPhoto 9.4 upgrade, and that Apple is now aware of it. Some will wait for a fix from Apple, others are going to revert back to the previous version of iPhoto and their old photo library. I'll probably give it a few days or a week and just ignore the mess of unorganized, un-albumed photos on my iPhone. Then, if there's no word of a fix, I'll delve into iPhoto library manager.

  • paotr Level 1 (0 points)

    I have exactly the same issue on the 2 macs that I upgraded with 10.8.2 and the new iPhoto. I am told of an error 1140. I can not sync my 2 iPhones any longer if I want to sync photos. The only option activated is the full iPhoto library and no more by albums or events. And if the full library is selected the sync aborts with an error 1140 displayed. I tried to rebuild it. It did not change anything. I tried a utility called iPhoto library manager which says that my library is corrupted. I had saved that same library on a 3rd Mac still on 10.8.1 and there the sync works. The upgrade of the library by the latest iPhoto version seems to be the issue...

  • frafischcgn Level 1 (0 points)

    Time Machine. Back to iPhoto 9.3.2 and the "old" library. Everthing perfect - no more "1140".

Previous 1 2 3 Next