Skip navigation

Aperture 3.4 will not open after 10.8.2 installed

13465 Views 78 Replies Latest reply: Nov 28, 2012 4:09 PM by FarNorth_1 RSS
  • Pachacor92 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 2:23 AM (in response to psychotic1)

    i find the file with 'easy find' and remove it

    It works perfectly for me now

    many thanks from France

  • Dragon9 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 3:30 AM (in response to psychotic1)

    Thanks for a solution that works for this problem, I removed the file and all works well.

  • fof Calculating status...
    Currently Being Moderated
    Sep 20, 2012 4:22 AM (in response to léonie)

    Deleting the plist file did NOT improve the situation for me. I can start Aperture from a different user account, but not from mine, neither after deleting the plist file, rebuilding the library, and even a re-install of Aperture.

    The problem is not associated with an error in the Aperture Library, because it also exists when no Aperture Library is present: Crash on start. No matter what I tried, there is no way to access my images with the updated Aperture.

  • léonie Level 8 Level 8 (46,375 points)
    Currently Being Moderated
    Sep 20, 2012 4:29 AM (in response to fof)
    Deleting the plist file did NOT improve the situation for me. I can start Aperture from a different user account, but not from mine, neither after deleting the plist file, rebuilding the library, and even a re-install of Aperture.

     

    Then you better start a new thread - repeating this post and all fixes you tried sofar, and adding a crash log - the the first 50 lines + the crashed thread.

     

    The reason for your crashes might be something completely different.

  • David Gordon Level 1 Level 1 (115 points)
    Currently Being Moderated
    Sep 20, 2012 4:31 AM (in response to fof)

    Are you sure you have deleted the correct plist in _your_ user account? There are two Libraries, make sure you are in /YourUserName/Library/Preferences and not Macintosh HD/Library. Your Library is hidden by default, access by holding down the alt key and look in Go menu in Finder.

  • fof Level 1 Level 1 (0 points)

    yes of course I deleted the right plist...

  • David Gordon Level 1 Level 1 (115 points)
    Currently Being Moderated
    Sep 20, 2012 4:39 AM (in response to fof)

    Can you open your Aperture Library while in the other user account?

  • léonie Level 8 Level 8 (46,375 points)
    Currently Being Moderated
    Sep 20, 2012 4:45 AM (in response to fof)

    But since Aperture is running correctly from a different User account (did you try it with your Apperture Library?), something in your user library must be causing the problems.

    The usual suspects are:

    • Aperture's user preferences (you checked this)
    • The Caches
    • your Aperture presets
    • your startup items

     

    You could start by deleting the contents of Aperture's cache:

    ~/Library/Caches/com.apple.Aperture/

     

    Then move your presets to the Desktop and move them back, one by one

    ~/Library/Application Support/Aperture/

     

     

    Disable "Startup items" from "Users&Groups" in the System Preferences

     

    Regards

  • fof Level 1 Level 1 (0 points)

    Yes, I can open Aperture in a different user account. I also can open my Aperture Library from there, after I moved it to /Users/Shared and let Aperture repair the permissions opon start. In this way at least I can access my images.

  • fof Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 5:58 AM (in response to léonie)

    @leonieDF:

    I deleted everything you suggested, and more ;-) but the problem persists. Actually I deleted everything that had to do with Aperture and reinstalled from scratch. Did not help. I renamed the Aperture Library (file extension) so that it is no longer recognized by Aperture. Did not help. I created a new, empty Library. Did not help. I moved the Library to /Users/Shared, and opened it from another user account. After repairing the permissions, it worked with no problem at all. Thus, the problem is not with the Library.

     

    Also, I tried to start Aperture after Safe Boot, which does not work because the driver for the graphics card is not being loaded and Aperture consequently says that the graphic card does not meet Aperture's requirements.

    After normal restart, Aperture took longer to load, and then crashed again.

    Ich könnt kotzen...

  • léonie Level 8 Level 8 (46,375 points)
    Currently Being Moderated
    Sep 20, 2012 6:05 AM (in response to fof)

    Ich könnt kotzen...

    better not - wan't help

     

    I tried to start Aperture after Safe Boot

    Safe boot at least will clear caches and reset parameters, no bad move.

     

    Post the crash log - the the first 50 lines + the crashed thread.

    Also look at the Console window, if there are disgnostics (at the time, Aperture launches).


  • fof Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2012 6:11 AM (in response to léonie)

    @leonieDF:

     

    There is nothing obvious in the Console, except that it says that a crash log has been written.

     

    These are the first 50 lines of the crash log:

     

    Process:         Aperture [329]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4 (3.4)

    Build Info:      Aperture-301036000000000~2

    App Item ID:     408981426

    App External ID: 10581304

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [165]

    User ID:         502

     

     

    Date/Time:       2012-09-20 15:46:40.680 +0300

    OS Version:      Mac OS X 10.8.2 (12C54)

    Report Version:  10

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

     

     

    VM Regions Near 0:

    -->

        __TEXT                 000000010cde9000-000000010d53b000 [ 7496K] r-x/rwx SM=COW  /Applications/Aperture.app/Contents/MacOS/Aperture

     

     

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0   com.apple.CoreFoundation                0x000000010f02792b CFRelease + 379

    1   com.apple.CoreFoundation                0x000000010f0bea12 CFURLCreateFileReferenceURL + 850

    2   com.apple.CoreFoundation                0x000000010f0e66d6 -[NSURL fileReferenceURL] + 102

    3   com.apple.Foundation                    0x00000001111312dd -[NSFileManager componentsToDisplayForPath:] + 102

    4   com.apple.RedRock                       0x000000010dafc13e +[RKImageCaptureManager defaultImageCaptureApplicationPathAndAllCandidateApplications:] + 371

    5   com.apple.Aperture                      0x000000010ce448b5 0x10cde9000 + 374965

    6   com.apple.CoreFoundation                0x000000010f06447a _CFXNotificationPost + 2554

    7   com.apple.Foundation                    0x000000011106d846 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64

    8   com.apple.AppKit                        0x0000000111c5060d -[NSApplication _postDidFinishNotification] + 292

    9   com.apple.AppKit                        0x0000000111c50346 -[NSApplication _sendFinishLaunchingNotification] + 216

    10  com.apple.AppKit                        0x0000000111c4d532 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 566

    11  com.apple.AppKit                        0x0000000111c4d12c -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 351

    12  com.apple.Foundation                    0x000000011108712b -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 308

    13  com.apple.Foundation                    0x0000000111086f8d _NSAppleEventManagerGenericHandler + 106

    14  com.apple.AE                            0x0000000114ee4b48 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 307

    15  com.apple.AE                            0x0000000114ee49a9 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 37

    16  com.apple.AE                            0x0000000114ee4869 aeProcessAppleEvent + 318

    17  com.apple.HIToolbox                     0x000000011313a8e9 AEProcessAppleEvent + 100

    18  com.apple.AppKit                        0x0000000111c49916 _DPSNextEvent + 1456

    19  com.apple.AppKit                        0x0000000111c48ed2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

    20  com.apple.Aperture                      0x000000010d25d00d 0x10cde9000 + 4669453

    21  com.apple.AppKit                        0x0000000111c40283 -[NSApplication run] + 517

    22  com.apple.prokit                        0x000000010f95d324 NSProApplicationMain + 378

    23  com.apple.Aperture                      0x000000010cdf89c2 0x10cde9000 + 63938

    24  com.apple.Aperture                      0x000000010cdf8314 0x10cde9000 + 62228

  • léonie Level 8 Level 8 (46,375 points)
    Currently Being Moderated
    Sep 20, 2012 6:28 AM (in response to fof)

    Do you have any third party Notification software installed - Growl or something similar?

     

    Aperture is crashing when it is trying to post the finish notification in the Notification center and reading your user information, that is probably why it is crashing only in your account.

     

    7   com.apple.Foundation                    0x000000011106d846 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64

     

    Also it is trying to construct the path to your default image capture application: Which application have you set to open, when a camera is connected? Image Capture? iPhoto? Aperture? You might try to change this temporarily to "image Capture" by opening Image Capture and setting the preferences.

     

    [RKImageCaptureManager defaultImageCaptureApplicationPathAndAllCandidateApplications:] + 371

     

    Regards

    Léonie

  • bomilcar Calculating status...
    Currently Being Moderated
    Sep 20, 2012 7:15 AM (in response to psychotic1)

    Out **** Standing.  You guys are just great.  Messed with it for 3 hours yesterday before I found your information this morning and it worked just perfectly. Thanks from New Mexico.

    Respetfully,

    Bomilcar

  • léonie Level 8 Level 8 (46,375 points)
    Currently Being Moderated
    Sep 20, 2012 7:15 AM (in response to léonie)

    Added: If the notifications - or any other third party installations are the problem, inspect your start up items in the "System Preferences > Users & Groups" panel for your acconut. Disable anything you do not really need and log off and log in again.

     

    And I can't tell from your answers sofar, if you already tried to reinstallfrom your original installation media and to upgrade directly to the current version. That solved the problem for quite a few posters already.

1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.