Previous 1 8 9 10 11 12 Next 176 Replies Latest reply: Aug 20, 2013 6:54 PM by kap_australia Go to original post
  • pepsiman24 Level 1 (0 points)

    This fix didn't work for me. I have about 4,300 songs and decided to try iTunes Match. iTunes Match backed up some songs but others did not get backed up. Those songs that did not get backed up show a "Waiting" status under the iCloud column in iTunes. Example: all songs in Steely Dan's 2000 album, "Two Against Nature". There is no way I know of to force iTunes to push the song into the Cloud. Because these songs cannot be backed up into iCloud they also cannot be played on other devices, such as iPhone, iPad, Apple TV, etc.


    Is there a fix besides iExplorer and shutting down/restarting iTunes Match?




    Carl Cygan


    P.S. Come on Apple, give us a decent fix. I'm sorry I ever upgraded to iOS 6.0 on my iPhone 4S 64GB.

  • Arnhem Level 1 (5 points)

    This works fine with iFunbox. I did it in this way and solved my iTunes Match problem




  • Arnhem Level 1 (5 points)


    Ok, I used i-funbox (it's free) and deleted the three files below as someone had suggested earlier.


    After I deleted the files, my library on the device showed that it was empty.  I was then able to synch up an album from iTunes to the device.






    This totally worked! A great workaround until Apple releases a patch or fix. Thank you so much!

    I then re-enabled Match on the device, got the dreaded cloud of death, but I got a nice blue progress bar to go with it.  Took a minute or so for the blue bar to complete.


    Now I have all the iCloud music available from the device (approx 8k songs).


    I didn't need to disable iTunes Match for this to work actually. Here were my successful steps:


    1) Force quit the just to be on the safe side

    2) Download iFunBox @ [Windows version available too]

    3) Delete the following 3 files:

    • MediaLibrary.sqllitedb
    • MediaLibrary.sqllitedb-shm
    • MediaLibrary.sqllitedb-wal

    4) Launch again and wait for the cloud progress bar to finish. Everything works now!

  • eggiebirdie Level 1 (0 points)

    Great work - deleting the library files did it for me. Now it synced Match in like 5 min with a maxed out library.

    Had the same thing on apps- when they did not download, deleting the library file did dit for me.

    No reboot or anything needed.

  • Livewire44 Level 1 (0 points)

    Thank you so much!  This was even easier for me.  I simply turned off itunes match on my phone.  Then, closed out itunes on my iphone.  Then I closed itunes on my computer.  Then I launched itunes again on my computer and the option to sync all my playlists was there again.  Reconnected my iphone to the computer and ran a sync again and everything was back.

  • oceanpoetry Level 1 (10 points)

    Thank you for detailed ifunbox workaround! I had been troubleshooting this for a day, was on the phone with Apple technical support. Nothing worked...but I tried the steps listing using ifunbox, and it resolved it perfectly. Much appreciated!

  • blackberry124 Level 1 (0 points)

    I tried all of the above with the exception of buying an outside app and reverting my iPhone.  Finally, I clicked on the more button all the way to the right in the music app.  The last option said "shared."  When I clicked on that, all of my music was back on my iphone. Completely frustrating but at least the problem was solved. 

  • paulafromkaty Level 1 (0 points)


  • oatmeal Level 1 (35 points)

    I had to do this twice. 


    Initially, the progress bar would never move.  When I tried your trick, it finally started over and moved almost all the way to completion before freezing again.  It was exciting, because it represented progress after weeks of frustration.


    I tried it again, and it worked wonders.  Thank you!

  • Tinny77 Level 1 (0 points)

    I wasn't able to sync my iPhone to iTunes Match. iPad is fine but iPhone doesn't update and doesn't let me switch off iTunes Match. This solution by Antgeez  worked fine.


    1. Download and install iExplorer

    2. Plug in iPhone first, then open iExplorer

    3. Delete the iPhone\Media\iTunes_Control folder (you can copy it to your laptop, just in case)

    4. Reboot the iPhone

    5. Turn on iTunes Match in settings.

    6. Start Music app


    You can keep the Ringtones folder if you like.

  • nunoinacio Level 1 (0 points)

    Just used it and worked perfectly! thanks so much. It's even my 2nd iPhone5 and still wasn't able to put iMatch to work on neither of them... guess I was "importing" the malfuction in each iCloud restore.


    can't understand why Apple is ignoring this issue and not presenting clear solutions or fixing it on any of the 2 or 3 iOS updates that have already been deployed after this problem started to be reported. also their customer support seem to don't even know the problem, they were asking me to talk with my network operator.........


    but it's solved now, thanks to iExplorer

  • beardedmonkey Level 1 (10 points)

    Fixed my problem too!  Genius!

  • kap_australia Level 1 (0 points)

    Well, this has been an experience. I tried everything mentioned in this thread. Nothing worked and I didn't want to restore.


    This is what finally worked.


    Device with issue: ipad mini. Device working: ipad 2.


    I copied the itunes control folder from the ipad 2 to the mini and restarted the mini. It is now working.

Previous 1 8 9 10 11 12 Next