Previous 1 2 3 4 Next 149 Replies Latest reply: Oct 24, 2013 1:03 PM by MacUserAE Go to original post Branched to a new discussion.
  • doctordrem Level 1 (0 points)

    I'm going to share my experience, though I know it might not duplicate for everyone. I have an iPad 3, ipod 4 and iphone 4 (verizon). I've got iOS 6 on them all. Today I noticed wifi sync was not working. After consulting a knowledgebase article, I found that the following steps worked:


    1. open itunes on your pc.
    2. plug the iphone into the pc via the sync cable.
    3. open the iphone settings menu to general, itunes wifi sync.
    4. via itunes check the "sync with wifi" option if it isn't already.
    5. on the iphone confirm that the iphone settings, general, itunes wifi sync indicates it's ready for wifi syncing.
    6. unplug the iphone from the sync cable and power it down (not a restart, but a power off).
    7. with the iphone still powered off, plug the iphone into a power source (not the pc). It should automatically turn itself on, but if it doesn't, power it on.
    8. sign in to the iphone via passcode (if there is one).
    9. itunes found the iphone and began wifi sync almost immediately.
  • Philly_Phan Level 6 (13,065 points)

    That has been a temporary fix for others (including me).  The only reliable fix that I have found is to DISCONNECT the device from the charger before opening iTunes.  Yes, that is an IOS-6 quirk or bug and presumably will be fixed in the next update.

  • aubster39 Level 1 (0 points)

    I rebooted my router and problem solved. IOS6, OS 10.7.4 iPhone4 iPad 2

  • martincohn Level 1 (0 points)

    Have tried all of the above.  Temp fix at best.  Sounds like wi-fi sync bug in IOS 6 plain and simple.  Same issue on 2 iPhones , and on iPad on IOS 6, iPad on IOS 5 does NOT have this issue.


    Here''s the only workaround that works, at least until Apple puts out a fix.


    • Plug your device into the computer with the USB cable
    • In iTunes, turn off the checkbox to Sync this (iPad or IPhone) over Wi-Fi
    • Save the setting
    • Delete the old backup for that device. iTunes Preferences/device, delete the device you are working on.  If you want to be parinoid back it up 1st, but it's probably hosed already reguardless.
    • Right click the device/backup
    • Sync
    • Keep syncing via cable.  When I turned on Wi-fi sync again it eventually hosed the backup and I started getting 1156 errors again
  • PDXScully Level 1 (10 points)

    I found that when I turned off the do-not-desturb feature and unplugged the phone from the outlet that the auto sync over wifi started.  But, I am finding - weather by wifi or connected to my computer - an unreasonable "waiting for items to copy" time which usually ends only after thousands of songs start getting copied for some reason. Each sync is requring a long wait and instead of a quick update it's a long, drawn out, inexplicable copy of songs that have already been copied time and time again.

  • Patricia W Level 3 (685 points)

    Thanks for the tip. What worked for me was

    1) connect iPhone via cable to iTunes

    2) Uncheck "Sync With this iPad over WiFi" option.

    3) Apply that

    4) Check "Sync With this iPad over WiFi" option

    5) Apply that

    it started syncing via WiFi immediately.

  • Pappasbike Level 3 (560 points)

    You may find that that's only a temporary fix. With iOS 5 all my devices showed up in iTunes and were able to be synced by wifi. Now it's hit and miss. Sometimes they show up sometimes they don't. If the one I want to sync doesn't show up, closing iTunes, cutting the device on and then relaunching iTunes almost always brings it up. Of course that makes it a less convenint option. Hopefully there will be an update to correct this.

  • Patricia W Level 3 (685 points)

    You are correct. It was a temporary fix. However, I can sync over WiFi as long as I initiate it from iTunes. (That is not what I want and it isn't an answer to the issue as it requires me to be at my desktop.)


    BTW, I discovered that I was also having problems with WiFi shutting down when my computer went to sleep (I am using Mountain Lion.) It was not waking up on Network Access. I think I have solved this now... but it is not changing the problem with WiFi sync.

  • Tech Guy Dre Level 1 (0 points)

    I highly doubt this is the issue. I have an iPad one with the previous IOS. I am able to sync the ipad wirelessly. However, my iPhone 4 does not have the option to wirelessly sync. I did a backup via sync cable and changed my password. I dont think my password had anything to do with it. But, I am now able to wirelessly sync my phone. Try doing a cabled backup and see if the option comes back. I think it is just the update via wireless and the computer not having the data for the new software.


    Connect i-device to computer via sync cable


    Possible change password if the above doesnt work.


    Those three steps cured my issues.

  • mattdbower Level 1 (0 points)

    What worked for me in hopes that it may help others:


    I had to perform a FULL sync with a cable to allow my Mac (MacBook Pro, April 2010) to re-enumerate my iPod (iPod Touch 4th Generation) and vice versa.  My iPad (iPad 2, actually owned by my school) seemed to work fine with Wi-Fi sync from the time of update.  The main difference that I know of is that I updated my iPad with the OTA delta update and my iPod with the wired cable iTunes full update.  Hope that some of that info helps someone.

  • RedpointRik Level 1 (0 points)

    Wow! The suggestions in this thread are the kinds of solutions I expect on the Windows platform, not on the Mac! I just bought an iPod Touch 5th gen, and it will not wi-fi sync under any circumstance. Back to cables for me until Apple gets this fixed. There is no way I am going to waste the time going through all this to "fix" something that should not have been broken in the first place. Now, my iPhone 5 works just fine over wi-fi. Go figure.

  • pcguywithaniPhone Level 1 (0 points)

    I was just having the same problem and tried a lot of things that didnt work until this


    Just turn off the wifi on the computer that you are trying to sync to and then turn it back on while watching the grey "sync now" on your phone and wala, it turns black. Not sure how often I will have to do this yet but it worked for now.

  • RedpointRik Level 1 (0 points)

    Yea, how crazy simple that was - it worked for me on the new iPod (5G).

  • simonfromquebec Level 1 (0 points)

    Well, i've been struggling for a while with that issue so far BUT.

    I finally SOLVED the case and understood why....



    Remember the link with the "renew bail",  solution.

    It works, but you often have to make it to make it work

    That means that since the last sync, your device ip address is no longer "associated" (more or less), thus making the link between itunes and the device not working anymore.


    Itunes, from my point of view seems to be the one that has a problem.


    So if you want to get rid of that problem for good here is a workaround that works for me since yesterday and never failed since then.





    There's always a but......


    First of all be certain that your router firmware's is the latest available...(it'a part of the process)




    By doing that you stay assured that itunes ip address routing adresses never corrupt or get timed-out or else, because everytime it breaks, you lose your wi-fi sync.



    Good luck!

  • Orest75 Level 1 (0 points)

    I m having the same problem! Everything synced fine before iTunes 10.7 upgrade.  Now it is doing the same thing that you described.  I have been reading the mutiple solutions others have suggested on other threads with NO LUCK  When is Apple going to address this?

Previous 1 2 3 4 Next