Previous 1 2 3 Next 1,541 Replies Latest reply: Jan 13, 2015 8:30 PM by kriegison Branched to a new discussion.
clemon85 Level 1 Level 1

I'm currently waiting on Apple support to call me back about this issue, but I thought I would reach out here to see if anyone else is having similar issues.


I upgraded to IOS 6 yesterday afternoon, and immediately after I could no longer connect to the Wifi at my place of employment.  Everyone had this issue, no big deal.


Went home, Wifi worked fine.


Came into work this morning and I am still unable to connect. I have tried all of the various recommended fixes, and even gone so far as to do a complete restore.   I work at a university with multiple networks and access points and have tried connecting to several, both secure and unsecure, with no luck.


This is what happens:

Unsecure Networks: Attempt to connect, wheel spins, Error Message: "Unable to Connect"

Secure Network: Attempt to connect, prompted for password, enter password, Error Message: "Incorrect Password"  (Yes I entered the correct password, I tried multiple times, and the IT tech was able to connect to it with his iPad 2 running IOS 5)


I am also not the only one, everyone on campus who has upgraded their iPad 3 to IOS 6 is unable to connect. (All staff/factulty have iPads, most have upgraded)


I have spoken with the IT department and they are baffled, they have tried rebooting various routers and access points to no avail.


Obviously there is something different happening in IOS 6 that is causing these issues.  My question is has anyone else encoutered this issue, and if so what have you done to fix it?


I have seen people above who have upgraded firmware on their personal wireless routers with success, but for a university with literally hundress of access points and routers this is out of the question, at least in the short term.

iPad (3rd gen) Wi-Fi, iOS 6
Reply by ChrisE22 on Sep 30, 2012 3:09 AM Helpful

drStrangeP0rk - will you please stop insisting that there is no WiFi issue.  Just because you haven't seen it yourself doesn't mean that it does not exist.  I have been working for software product companies for over 30 years and I am fully used to people getting things wrong or misunderstanding things, but in this case I can assure you that something is wrong with IOS6.

This is all about support for legacy infrastructures.  When we release a new or upgraded product, we have to verify that it works with existing environments or, it there are changes that require users to change their environments, these are advised in release notes.  It simply isn't an acceptable option for Apple to advise people to reset, upgrade or downgrade half the routers on the planet, just because Apple choose to use a new feature that many access points cannot support properly.

What you see on the forums is simply the tip of the iceberg - most users will just assume that there's a problem somewhere else, or not even notice until they get hit with a 3G data bill. (I know this, because I have asked less tecchy friends and relatives who upgraded and this was their response - they aren't logging calls, but do see the problem).

The bottom line is, before IOS6 we could connect pretty reliably to the majority of WiFi access points at home, at work, in hotels, cafes and other public places.  Since the upgrade, a significant proportion do not work.

There IS a problem with WiFi in IOS6.

Oh, and if you actually read the article on CNET, the author himself, Brooke Crothers,  is experiencing the problem (read the "...count me in as an affected user..." paragraph), so how can you claim CNET haven't seen the problem? nectivity-wi-fi/

All replies

  • YanafromNC Level 1 Level 1

    I no longer have the issue... In the wifi settings I clicked on my network and went manual and chose to auto login and it has been working ever since... Turn the http proxy to manual n it should be working... Some have done renew lease as well.. Or forget the network n then log back on

  • clemon85 Level 1 Level 1

    I have tried all of these things and none of it works. Thanks for the suggestions though!

  • dubperc Level 1 Level 1

    I am still unable to connect my ipad 2 to my home network. Have tried everything including full restore, but to no avail. My Ipod running ios 6 connects to the same network with no problems, so it would seem to be specific to the ipad.

    It would seem the new ios is making some kind of request via the ipad that certain routers are unable to process, resulting in a failed connection. Obviously not enough beta testing was carried out before release.

    There appears to be nothing i can do apart from wait for a fix from Apple...

    A lot of attention seems to have been given to the problems yesterday with the ping site that went down, and the ongoing wifi issues are not getting much attention yet. This is a very big problem as i see it, nevermind the complaints about maps and youtube, i can't even get that far! Not being able to connect to my home router is bad enough, but how many others will i no longer be able to connect to? Public wifi hotspots? workplaces? hotels?

  • nicksp Level 1 Level 1

    We have 2 wifi connections at home because we have thick walls.  Upgraded both iPad gen 3 and iPhone 4.


    iPhone 4 connects to both networks fine.


    iPad will connect to one network (Virgin super hub) but WON'T connect to the other (Netgear access point)


    iPad keeps saying unable to connect after I put in the WAP key but iPhone works on both.


    Restarted both hubs, iPad several times, reset wifi connections through reset, forgotten all connections, fiddled with proxy, auto join, Bluetooth, history & cookies and more but still refuses to connect!


    Semi-crippled iPad usable only in part of the house until he next iOS update I guess!

  • clemon85 Level 1 Level 1

    That's pretty much where we're at here at work.  The Apple Support rep I talked to on the phone earlier was supposed to call me back 30 minutes ago...not a good sign I'd say. 


    It is sad that this isn't getting as much attention as the issue yesterday, it's something that needs to be fixed ASAP.  Like I said before, I work at a university, so we have 100s of staff with iPads and who knows how many students.  None of whom can connect with IOS 6.  I can definitely see this problem growing over the next few days.

  • wenz6553 Level 1 Level 1

    I'm having the same issues.  I've tried all the fixes out there and no dice.  I've got an iPad 2 and iPhone 4s, both are having the same WIFI issues.  I'm about ready to downgrade to 5.1.1 and just be done with this.

  • dubperc Level 1 Level 1

    I think this problem needs a bit more publicity to force apple to act.


    So far, it doesn't seem to be reported on any news sites or blogs. Presumably the maps farce and yesterdays issues have eclipsed it, so the more people that report this problem and make a noise about it, the better.

  • clemon85 Level 1 Level 1

    On the phone with Apple support again, they have at least confirmed that these issues are caused by IOS 6.  They have not however, provided any new solutions, or anything that works for me.


    This is a repeat but they suggested the following:


    Toggle Airplane mode on and off

    Reset Network Settings

    Reset all settings.


    Again, none of it works, and isn't new. 

  • Mrad1976 Level 1 Level 1

    I am having the same problem with my iPad 3. I upgraded to iOS 6 this morning and it connnected to my home wifi router great. I decided to bring my Ipad into work and it can not connect to my work access point! I checked the DHCP setting and the Ipad is picking up ip address 169.254.247.x, Subnet Mask I have tried clearing my Safari setting, reset my network settings and also set a Static IP address, subnet mask, router, dns. etc. When setting the Static Ip address it will connect to my work network for 5 seconds but then disconnect and the ip address will go back to 169.254.247.x. I will bring my Ipod to work tomorrow to see if it can connect with iOS 6. I have an HTC Thunderbolt phone with android and it connects to my work access point with no problems. Apple please help!!

  • jkecskes Level 1 Level 1

    Same.  I am using a 4S and the same network I used to download the update now is impossible to connect.  It shows up on the list of available networks, then when I click it it responds with "Unable to join the network 'Netgear-0'."


    Yet, I'm able to join many of the other networks that I previously connected to. Stranger still, others who have updated thier phones CAN connect to it. Nothing has changed with the router.  I tried resetting the router to no avail.

  • BigJD82 Level 1 Level 1

    I also have the same issue with my iPad 3 at work but my iPhone 4 connects fine. My colleague has an iPhone 4S that has iOS 6 and this has the same issue as my iPad. Apple need to sort this ASAP!!

  • Skronk61 Level 1 Level 1

    I'm having the exact same issues with iOS 6.


    I've tried all the fixes and nothing has worked so far.


    My iPad 3 and iPhone 4s both show unable to connect messages after I type the WEP key in. But my iPod Touch connected first time! it doesn't make any sense.

    I wish Apple would at least acknowledge that there is an issue here, my non 3G iPad is useless now

  • dhancoc2 Level 1 Level 1

    not me!

  • atchoulie Level 1 Level 1

    Thank god I am not the only one! I thought I was just the unlucky girl who'd received a broken iPad 3 for her birthday since nothing was reported on the web about this issue!


    Since the update, I have tried and tried to connect to my home wifi (Netgear) but it shows me an 'Impossible to connect' message. Just before the iOs 6, my iPad connected to the wifi just fine!


    I have called the Apple support who told me to toggle Airplane mode on and off (done, doesn't work), to reset network settings (did that, apparently for nothing), reset all settings through iTunes (took me forever and still doesn't work).

    Now my brand new personnalized wifi-only iPad is useless...


    Please Apple do something about it and soon!!!

Previous 1 2 3 Next