Previous 1 93 94 95 96 97 Next 1,541 Replies Latest reply: Jan 13, 2015 8:30 PM by kriegison Go to original post Branched to a new discussion.
  • Buzzfuster Level 1 Level 1 (0 points)

    At work, we provide a managed WiFi service, and we have been troubleshooting a handful of WiFi issues that have been really difficult to nail down the root cause.  We have been working directly with the engineers of one of the larger WiFi router manufacturers and found a couple of things that could affect any router, especially 802.11n routers.  These are issues that also affect other devices, but it varies widely on how theyre affected.  But here are a few things you should know, and a handful of things you can try.

     

    - resetting your iOS device won't fix anything.  It might enable you to reconnect sometimes, but so will turning off WiFi on your iOS device (or turning on Airplane Mode).  But this is just making your device drop its connection to your router and then request a new connection. 

     

    - renewing your DHCP lease might help, but again, this is generally not a root cause.  It's treating a symptom.

     

    - resetting your router may help, depending on what is going on.  Where this helps is if your router is set to automatically set itself to the least congested WiFi channel.  Most routers only do,this check once whenever they are powered on.  They do not dynamically change channels because that requires each device to reconnect.  The problem occurs when your WiFi router initially connects to a relatively clear channel, but that channel can later become congested with other neighboring WiFi networks.  That can slow your connection or even cause so much interference that your device cannot maintain a stable connection. This is increasingly likely if you live in an apartment or close to other people who have WiFi routers.  If your router does not auto detect channels, you should manually set your channel to channel 1, 6, or 11.  These channels have the least overlap from the other channels, and, in a perfect world, these are the least likely to have problems.  However, most WiFi routers come off the shelf set to channel 1 or 11, and newer ones are increasingly defaulted to 6, so these might not always be good choices.  Without a spectrum analyzer, there's no good way to check.  You can download InSSIDer, a free spectrum analyzer for PC, MAC, or Android devices, and it will tell you which channels have traffic on them.

     

    - there are lots of things that operate in the same frequency range as WiFi and which cause interference.  Microwave ovens are the worst.  When one is on (even a neighbor's), it will blast all of the WiFi channels above channel 6 and cause quite a lot of noise on the lower channels, too.  This will cause your connection to drop.  If your neighbor turns on a microwave, you'll almost certainly lose your connection until it shuts off.  Bluetooth devices, including App,e wireless keyboards, magic track pads, Mac Minis, Bluetooth headsets, speakers, etc. all transmit intermittent spikes of signal which interfere with WiFi.  In and of themselves, not enough to knock off your connection, but enough to cause slowness and to contribute to the overall noise.  Baby monitors and cordless phones create a lot more noise, and consistent noise which does interfere with WiFi.

     

    - perhaps the single most important change you can make, though, is to check your WiFi router to ensure that it is set to only operate in the 20MHz bands, and not in the 40MHz or "wide and" mode.  This mode is designed to enable you to connect at 300 or 600 Mbps in your WiFi network, but since you almost certainly don't have a broadband connection to your ISP anywhere near that, it's nothing more than a bunch of useless marketing hype.  This speed comes at the expense of reliability (operating at 40 MHz is twice as susceptible as operating at 20).  Your router may also have a setting called something like "40 MHz Intolerance."  Turn this on.  It tells your router to ignore attempts to get it to connect at 40 MHz.

     

    - placement of your router is an enormously important factor.  Make sure your router has the antennas firmly connected.  Missing or loose antennas dramatically inhibit your WiFi signal.  The antennas radiate a signal out around the antenna in roughly a doughnut shape.  Be sure your antennas are pointing up, not down.  Use the antennas that came with your router.  Do not replace them with high gain antennas, because that changes the shape / direction of your WiFi signal, and your 802.11n router's algorithm for properly adjusting signal output (strength and direction) will be off.  Your router should be placed above eye level if possible, and as close to the middle of your house as possible.  Keep it out of cabinets, behind objects (especially video monitors, which create a tremendous amount of WiFi interference), and away from electrical panels, metal shelving, and fluorescent lighting.  This will also help reduce channel bleed / interference from your neighbors.  Your building construction also plays a big role.  Dense building materials, such as brick, cinder block, metal framing, metal roofs, and lathe and plaster (common in homes and apartments built in the 1950's and before), or basements all block WiFi signals.  All the more reason to get as close to the center of your living are as possible.

     

    - if you have an AirPrint capable printer, you might also check to see if it is set to allow ad hoc network connections to your devices.  If so, try turning off the ad hoc networks.  Allowing ad hoc networks in essence lets your printer work as a second access point, and you wind up with two WiFi networks interfering with one another instead of everything going though your router.

     

    - If your router supports both 5 GHz and 2.4 GHz, you should experiment with trying to connect to one or the other.  Give them different SSIDs so you can tell which one you're connected to.  Since 2.4 GHz is much more congested than 5 GHz, you might get better connections out of a 5 GHz connection.  On the other hand, 5GHz signals are more prone to being blocked or attenuated by walls and sources of interference, so those signals may not spread well through your house.  I have learned that my Cisco router has a manufacturing hardware defect with the 5 GHz radios, and they have very poor signal strength.  I also found that there were problems with OSX Mountain Lion that caused poor performance with 2.4 GHz WiFi, but that won't affect your iPhone or iPad. My observation has been that my iPads and iPhones do very very poorly with 5 GHz WiFi networks.

     

    - Finally check your router to see how many concurrent devices it is set to allow.  Many routers have a limit of 16 or so devices, and depending on your network, you might be surprised to find how many WiFi enabled devices you have connected (game consoles, computers, blue ray players, Roku, Apple TV, audio systems, TVs, etc), especially if your network is open and not encrypted.  You might also want to set your DHCP lease for a shorter interval, like 1 or 2 hours, and you might also want to configure your router to used assigned IP addresses for your devices, so,that each time your device connects, your router will assign a fixed IP address to it every time. 

     

    If you have an iPad 2, I think the antenna is along the top where the camera is, and runs parallel to the edge of the iPad.  When using your iPad, try to keep your hand off that edge as it covers the antenna.  I have noticed that holding the iPad along that edge seems to drop my signal strength by one full bar when I'm in the rooms farthest from my router. 

     

    Unfortunately, almost all of these issues are inherent WiFi problems, not iOS problems, so you're not going to find a silver bullet.  But, if you do all of these things, they might not fix 100% of the problem you're experiencing, but they will definitely have a concrete impact. 

     

    Good luck!

  • sana168 Level 1 Level 1 (0 points)

    the pointers you gave are very helpful.  but how can you explain given i have 2 ipad 2, one ios6.1 the other 5.1.1.  the one having problems connecting to the router is the 6.1.  given that all circumstances are the same.  i have done all the resetting/renewing in the 6.1 .  before the update, the wifi signal from my asus rt-n66u and rt-n56u (accesspoint) to my bedroom can be seen/received by the 2 ipads., with the macbkpro having the strongest signal, followed by ipad2 then iphone4.  now, iphone 4 can see my wifi/neighbors' wifi but ipad can barely see and received the 5ghz signal with intermittent dropping of connection, it can not connect to the 2,4ghz unless i go nearer the router which is 2 rooms away. i might have to stay in the den just to surf on the ipad or use my iphone/mcbkpro in my bedroom. oh, and even in public wifi, i noticed that with signals 2bars and below, ipad 2 ios6.1 can not detect the wifi network.

    is something wrong with the hardware or the software????????

  • ugetsu Level 1 Level 1 (0 points)

    Updated an iPad 4, iPod touch and iPhone 4S from 6 to 6.1 at the weekend and then encountered wifi issues on the iPad and iPod Touch. A connection to the network is made, I get full bars, but after I connect just a small amount of data transfers and then it seizes up. The iPhone 4S works just fine (go figure). I'm in the UK, using a BT HomeHub2.  If I switch from WPA2 to WEP  encryption, the problem disappears (along with the security of my wi-fi connection)...

     

    HERE THE INTERESTING PART: I spoke to a BT Technician to confirm that the router's firmware was up to date. He then told me that they'd been receiving a LOT of calls and suggested switching to WEP encryption. I told him I'd already   discovered this workaround, but didn't see it as a secure long term solution. He said it was the only way around the problem for the time being, the reason being he said that Apple's update doesn't conform to WPA2 standards.

     

    I've been using Apple products for over a decade and never had a problem until this latest iPad arrived in November. First, there's been an issue with a fluctuating backlight / automatic power-saving algorithm during video playback (still unresolved) and now this crazy Wi-Fi problem: both of which appear to be software-related, both of which many other people have posted about online, but not enough of us to matter it seems as these issues have yet to be addressed. Bottom line, if a fix hasn't arrived and I'm not once again able to connect my iPad to my router via WPA2 by the end of the month then I'll be switching to Android going forward.

  • JimHdk Level 7 Level 7 (27,745 points)

    My ipad 3, iPad 4, and iPhone 5 all using iOS 6.1 work fine with WPA2.

     

    The BT home hub has been fraught with problems. The BT guy was full of it.

  • ugetsu Level 1 Level 1 (0 points)

    That these devices are working with your particular router means nothing. The reason for setting a technical standard is so that a device will work universally with all other devices using that same technical standard. Now the fact is, lots of people are having the same problems as myself, as evidenced in this thread any others (eg. suggest you look at the iPhone 5 forum), and not only with the Home Hub but with many other routers, Netgear, etc. In all cases, the common factor is an update to iOS6 or 6.1. Go figure...

     

    Also, if the BT Guy is "full of it", why was his immediate, unprompted advice to switch to WEP encryption correct?

  • JimHdk Level 7 Level 7 (27,745 points)

    That your particular device does not work with your BT hub likewise proves nothing.

     

    I am well aware of WiFi IEEE standards.

     

    That the BT guy knew of the WEP work-around simply means that BT has gotten a lot of complaints about their WPA2 implementation.

     

    Consider the possibility that iOS 6 is now using some parts of the IEEE 802.11 standards that were not previously used (it does) and that those features now encounter bugs in missing/untested router code.

     

    Time will tell.

  • GSchraderfromfl Level 1 Level 1 (0 points)

    I'm another victim of the upgrade.

     

    My new iPad 4 sees no wifi signals in my condo residence while my laptop sees 6.

     

    I am able to connect to my Belkin router successfully however if I manually enter the SSID and password.

     

    Have done everything suggested with no luck.

     

    Please help Apple!

  • Skream Level 1 Level 1 (0 points)

    Sorry for late reply, i did this through the device.

  • Skream Level 1 Level 1 (0 points)

    What have you tried so far ? Bit hard to try and help without knowing what you have and have not tried.

  • ugetsu Level 1 Level 1 (0 points)

    WPA2 isn't new and I've never had connection difficulties with any other device or operating system. The iPad and iPod were working just fine too before the upgrade to 6.1. Further, my case is one of many according to the BT Technician.

     

    BT are the largest broadband provider in the UK, so even if it's only their routers effected then that's something Apple should be looking into. But, as we can see from this thread and the numerous others around the forums, the problem doesn't only afflict BT routers but also Netgear, DLink, Belkin, even Apple's own, and it's not just happening in the UK but in countries all over the world. The common link in all cases being a recent update to iOS6 / 6.1.... But, no, of course, you're right, it must be all BT's fault!

     

    ... Oh, and if all of your devices are working just fine, what is it exactly you are doing on page 95 of this thread I wonder?

  • Skream Level 1 Level 1 (0 points)

    I have to agree with some of what you say, it cannot be down just to the router(s) I had problems with Netgear and Cisco ones.

     

    But my problem was i kept getting "incorrect password" when trying to connect. Long story short for me, full factory reset of my device without using Itunes fixed this.

     

    As for why jimHdk is on this page 95, why does it even matter? I'm on page 95 as i want to try and help the other users on here with this problem. Just because i fixed my own problem, I'm not just going to leave. If we all did that then there would not be many people around to help would there?

  • JimHdk Level 7 Level 7 (27,745 points)

    Good luck with your BT hub. I hope you get your issues sorted.

  • ugetsu Level 1 Level 1 (0 points)

    I guess I don't see how attempting to shift the blame away from Apple onto another company is helping others, but hey.

  • Skream Level 1 Level 1 (0 points)

    In certain cases it has been peoples routers which have been at fault. So that would be why the blame is being shifted.  But of course it's not the same for everyone as you know.

  • ugetsu Level 1 Level 1 (0 points)

    That's the line Apple seem to be pedalling, yes.

     

    But it shouldn't necessary to buy a new router (or, in this case, switch internet providers, since the HomeHub is part and parcel of the BT Infinity package) just to have the chance of connecting to the internet with a tablet or smartphone via WPA2 - and what then happens when you go out of the house and want to use a hot spot elsewhere?. A well designed operating system for such a device should work with routers old and new - especially  considering that the WPA2 standard has now been around for 9 years.

Previous 1 93 94 95 96 97 Next