Previous 1 2 Next 17 Replies Latest reply: Oct 12, 2012 1:03 PM by Chris Lent
Sol88 Level 1 (0 points)

Hi everybody!

Yesterday I've updated to ML 10.8.2 and xCode 4.5. And I've got a trouble. In C++ Console Application I can write only one symbol in console. I can't write any more untill press enter, then 1 more.

Output does well.


Does anybody have the same problem?? With xCode 4.4 everything was OK.


Thanks for help!

  • izuchukwu.elechi Level 1 (0 points)

    Also expriencing this issue with Xcode 4.5, OS X 10.8.2, and Xcode 4.5 Command Line Tools. I've also noticed that switching to a different output setting ("Debugger Output" or "Target Output") shows all previous input but still truncates new input until the output setting is switched again., or i


    One workaround I've found is to install a copy of Xcode 4.4.1 (I keep it in an "Xcode Archive" folder in my Apps folder) and use the older install for C++ development, though Xcode 4.5 improved C++ development, so I'd love to see a better solution.

  • Sol88 Level 1 (0 points)

    Yes, yes...

    This is not a solution. I tried to find something in the Internet, but unfortunately I haven't found anything useful =(

    I hope that it will be fixed with some update soon...

  • GUANZHONG WANG Level 1 (0 points)

    yes. I have same problem. my debugger just can show only one mumber in console. but output does well. why?

  • vindicadi198 Level 1 (0 points)

    I too am having the same issue with c++ and c projects, i havent checked with objective-c. the console shows just one character while taking input but whatever has been typed is taken as input even though not displayed.

    Hpefully it will be solved soon

  • HateMyself Level 1 (0 points)

    It's the same bug that i have with my Xcode 4.5. No sulution found

  • tony92532 Level 1 (0 points)

    Same problem.  I thought it was just me.

  • Sol88 Level 1 (0 points)

    I also thought so...

    Has anybody found a solution? Or has anybody written a bugreport or something like that?

  • Mark Szymczyk Level 4 (1,985 points)

    There's a discussion of this issue on Apple's paid developer forums. It's a bug in Xcode 4.5. Apple's engineers are looking into the issue, but there's no fix yet.


    There are two workarounds. The first workaround is to run your command-line app from the Terminal. In the Xcode project navigator select your executable from the Products folder. Right-click and choose Show in Finder. Double-click the executable in the Finder to launch it in the Terminal.


    The second workaround is to install Xcode 4.4. Choose Xcode > Open Developer Tool > More Developer Tools to access Apple's developer downloads site.

  • Jürgem Level 1 (0 points)

    Thanks... the second solution work well

  • A694ME Level 1 (0 points)

    I downloaded and ran xcode 4.4 as previously suggested, but the application wont load or open and I have to force quit.

    Is anyone else experiencing this same issue?

  • Chris Lent Level 1 (0 points)

    Developed a WORKAROUND today :-)


    Choose File > New > New Window


    Resize the Window so that the window covers the existing Xcode window, BUT leave the existing

    xCode windows "All Output" showing underneath. 


    Click into new (upper/covering ) "All Output" window to put the keyboard focus in the upper window.


    Run your application.  Upper/covering window will show only first input character per line, but

    lower window's "All Output" section will show all characters as they are typed in.


    See a picture of this at: -input-echo-problem


    I filed a bug report on this, with the workaround included:


    Problem ID: 12383367

    Title: Console Input to "All Output" window echoes only first character of each line

    Originated Date: 26-Sep-2012 11:03 PM (EDT)

  • s.mclaughlin Level 1 (0 points)

    I like the suggestion of running the application in the Terminal best but what debugging?

    I hope the Apple engineers can fix this problem soon...

  • Chris Lent Level 1 (0 points)

    Happily, it looks like this bug was already logged, but sadly still open.

    Update: September 29, 2012

    This is a follow up to Bug ID# 12383367. This bug has been closed as a Duplicate. The issue is being tracked under the original Bug ID# 12333057 which is also listed in the Related Problem section of your bug report. To check the status of the original bug report, please visit the Related Problem section of the Problem Detail view of your closed duplicate bug.

    The status of Bug ID# 1233057 is Open at this time.

  • Ian the Smiler Level 1 (0 points)

    It looks like using cut and paste also shows all the text entered.

Previous 1 2 Next