14 Replies Latest reply: Apr 30, 2013 3:14 AM by Barlicow
Some Dude Level 1 (55 points)

Is anyone here using a bonded network interface on their XServe, running 10.8.x?  I have an Early 2009 (3,1) XServe with dual Gigabit interfaces built in, and cannot bond them together for the life of me.  As soon as I do, I lose all network connectivity, despite the switch being set up perfectly in unison with it.  I've done this for years with my Mac Pro running 10.6.x Server, without any issue, same switch setup for those 2 interfaces.  I see talk in several Mac Pro forums mentioning the problem, but was just curious if anyone with an XServe is also seeing this issue with the stock embedded dual-Gigabit links. 


Thanks for the help.  Oh, and yes, I've tried 10.8.0, 10.8.1, and last night's 10.8.2, and still cannot resolve the issue. 

Xserve, OS X Server, Early 2009 (3,1)
  • LAS IT Department Level 1 (0 points)



    I can confirm that we have managed to get LACP Bonds to work in 10.8.0 - 10.8.2


    It as a Very Painful process as once again, we had to change the configuration of the LAG on the Switch.


    I cannot remember the exact history, but play with the STATIC / DYNAMIC option on you LAG setting at the switch.


    NOTE:  This server was running 10.6.8 with a 5 x GB port LACP Group (en0 was used for management) running fine for more than 2 years.  Did an inplace upgrade to 10.8.0 and everything broke loose.


    Everything has been stable now for 5-6 weeks (incl upgrades to 10.8.1 and last week 10.8.2)

  • Some Dude Level 1 (55 points)

    Interesting, but not enough to convince me.  For one, my switch runs LAG groups for all kinds of devices perfectly, and does so just fine for Snow Leopard machines.  I am not going to go mucking with advanced LAG settings on the switch to try and get LACP working on ML properly when it is clearly an OS issue.  I will wait for Apple to fix it, and in the meantime, I will just use a single GigE port, which has the added benefit of allowing me to use LOM.  I only wanted 2xGigE with the built-in ports, nothing like your 5xGigE ports you have.  I rarely saturate the 1xGigE link anyway.  Drive I/O limits always seems to crop up before GigE saturation, generally speaking.

  • kjvictory Level 1 (5 points)

    I am having the same issue as Some Dude. To be clear, link bonds can be created and will connect to my switch fine. I can ping, surf the internet, etc. However, the bonded interface will NOT show up in Server.app under Hardware > Server > Network tab. Weird issues then show up in different services inside Server.app. For example, Netinstall will not allow you to choose the bonded interface because it doesn't show up in the list of available interfaces at all.

  • kjvictory Level 1 (5 points)

    Also, it sounds like LAS IT Dept is using a different adapter than the built-in ones. I am using a Mac Pro 2012 with the built-in interfaces and it doesn't work...

  • LAS IT Department Level 1 (0 points)

    Hi de Hi


    You are 1/2 correct.  We are not using both builtin Ethernets in the same LACP Bond (or any bond for than matter)


    eth0 = Management IP (and LOM)


    eth1, PCI 1,1 PCI 2,1 = LACP bond used for Deployment (netboot & deploystudio)


    PCI 1,2 & PCI 2,2 = LACP bond for Software Update


    I probably didnt make myslf very clear in that if i try to install 10.7 or 10.8 on the xServe, LACP will not function for ANY service.


    I have to install the xServe with 10.6.8 and configure the LACP as I Require before upgrading to 10.8.x


    I will admit that this is not ideal, but it does actually work 100%

    BUT do NOT try to change settings on the interfaces in the Server.app. This will (as kjvictory has mentioned) destroy the link between the Service and the LACP Group.


    I do remember reading somewhere in a 10.6 manual that LACP bonds were NOT supported on netboot (but I did it anyway, and it worked 100%) and there was no mention either way for Software Update and DHCP


    It feels like OSX10.7 and 10.8 have been coded for the MacMini Servers with a Single Ethernet. BUT with the Thunderbolt -> GB Ethernet, They also can have a decent LACP bond available so I guess apple have decided to drop LACP support in Server.app


    I can configue DHCP via the Terminal - BUT have not yet been able to do this for netboot as yet.

  • mart30lon Level 1 (0 points)

    I posted a bug at Apple 3 months ago about this as well as speaking to the enterprise AppleCare team.


    Still nothing... We all seem to be off Apple's radar now... More interested in iOS and iPads...

  • christianhuening Level 1 (0 points)

    Hey guys,


    had the same issue and just found the solution. Here you go:


    1. Edit /etc/bootpd.plist with an editor of your choice (e.g. vi, vim). NOTE: need to be root I think. Use sudo
    2. Look for a line saying: „<key>netboot_enabled</key>“, insert it if not present
    3. Enter a next line and add  „<string>interfaceOfYourChoice</string>“ . Where interfaceOfYourChoice is your bonded interface. In my case it’s „vlan0“, ´cause i’ve always added vlan to the bond.
    4. The excerpt from bootpd.plist  should look something like this:














    5. Make sure that there is no <false/> or anything else but just the next <key> entry after <string>interfaceName</string>


    6.Save the file (:w in vi, vim)


    7. Execute „sudo serveradmin start netboot“ in Terminal.


    8. Verify via „sudo serveradmin status netboot“ and Server.app (might need restart oft he app) that NetInstall is running.


    Hope that helps!

    kind regards,


  • guillaumefromgeneva Level 1 (0 points)

    Marvelous !!!!


    Thank you very much Christian Huening !

    It works nice for me now !


    Best regards,


  • christianhuening Level 1 (0 points)

    You're very welcome


    Maybe someone can sign this as solved, so that more people may find the solution?!

  • guillaumefromgeneva Level 1 (0 points)

    Sure! I'd like to do so but I'm probably stupid 'cause I did not found where can we sign a discussion as solved ??

  • Some Dude Level 1 (55 points)

    Folks, the workarounds put in place earlier in this thread do not equate to "solving this issue" the correct way, which is for Apple to update its code to handle this properly right thru the UI, without requiring command line mod's. 


    That said, 10.8.3 is now out, and appears to have resolved this for non-Server users.  There is still an issue here, that Server OS 2.2.1 (the current version) does not show the bonded interface properly in the GUI of Server app.  We are closer, but not quite there.  I am leaving this case "un-Solved", because it until it works as designed it is not solved.  Hopefully, we will see a Server app update that will resolve this in the next few days.  We'll see. 

  • guillaumefromgeneva Level 1 (0 points)

    Hi "Some Dude",


    That's right, not everything is resolved...

    It's a step forward anyway ;-)


    Wait 'n see next ServerApp update !



  • Denise Hutchinson Level 1 (0 points)

    I have same issue as described here.  I am running 10.8.3/server 2.2.1 on a Mac Pro.


    Bonded ethernet works fine from status perspective and accessing internet services but does fail to publish netboot sets.  I have edited the plist suggested above by christianhuening.  I can see my edits are holding, enter the server command to start netboot service etc, netbooting service is enabled but still no entry in the Server GUI nor are netboot sets being published for clients to see.   Is there some other subtle item to the christianhuening solution that I could be missing?

  • Barlicow Level 1 (0 points)

    Still the same issue and still UNSOLVED!
    We recently bonded both nics of an XServer and also of a MacPro running 10.8.3/server 2.2.1. with just a little pain regarding the switch.

    After we realized that we can't select this virtual interface for the DHCP-server we edited the bootpd.plist (as suggested by christianhuening) from <string>en0</string> to the default value for bonded nics <string>bond0</string> and deleted the existing lease-file /var/db/dhcp_leases. DHCP-server is up and running, clients get IP's.

    In the server GUI the interface is still not selectable thou, where on the the XServe it shows an empty field and on the MacPro it's wrongly displaying WiFi (which is in fact deactivated)!