Previous 1 2 Next 23 Replies Latest reply: Oct 2, 2012 5:47 PM by Shamino
wildting Level 1 (0 points)

After I updated the iphoto to 9.4 none of my iPhoto albums show up in iTunes under the Photos tab when synching my iPad or iPhone. I only have the option to synch the whole library (which generates a 1140 error since it's too big for my device). The option to sync only selected albums, faces or events is grayed out and now albums are shown grayed out below. looks like i need to go back to older version before they fix the problem.

  • JPHuff Level 1 (10 points)



    I posted in another thread about this.  I have the same issue on both my iPhone 4 and 3rd gen iPad.  I just tried restoring my old iPhoto library and old version of iPhoto (From Tuesday before the update) using Time Machine and the albums are now displayed.  iTunes didn't show any of the albums as selected to sync as they had been before the update, so when I selected a few I got the warning that all photos would be replaced on the target device in favor of the albums I had selected but it works!


    This hasn't been reported as a major issue- I haven't seen it on any of the tech news sites, so I have to believe this is a more limited problem.  Perhaps something went wrong with our upgrades or there was some issue with our iPhoto library files that resulted in this?  In any case, I'm going to try the update again to see if the problem persists or if another update results in no issues.  I'll try to tag this thread so I can post results.  At least I know we can get the feature back.  The disturbing part is that since I haven't seen this problem widely reported, it's unlikely there will be an Apple issued FIX.  So we're probably on our own if it doesn't work.  Good luck to you!

  • Terence Devlin Level 10 (137,920 points)

    Is the Library available in other apps - Pages, iMovie etc?

  • W M R Level 1 (145 points)

    I even downloaded iPhoto again, repaired the library etc.. but still have the same issue...

  • JPHuff Level 1 (10 points)

    Ok, all.  I think I found the problem.  In searching for reports of this issue and solutions I found someone that mentioned they had fixed a similar issue with a "free" program called "iPhoto Library Manager."  The app apparently lets you split a library into multiple smaller ones or combine multiple libraries.  Generally it just "manages" your libraries.  I figured I had nothing to lose so I checked it out.  Turns out it costs $19.99 but they do have a free demo.


    I launched it and it immediately told me that it couldn't display my library and albums due to an issue with the AlbumData.xml file on line 22155.  I read in the documentation of the app under it's "Help" menu that likely causes were a keyword with a "null" character at the end, or a file path being referenced inside the library that had an ampersand or backslash in it.  The person on the board I'd found had had a keyword issue.


    Anyway, I opened the iPhoto library by showing package contents (right click the file to choose this) and loaded up the AlbumData.xml file in TextWrangler, since that displays line numbers.  I found that line 22155 indeed referenced an mp3 in my iTunes library that had an ampersand in it.  Deleted that line.  Then it said line 22156 had an issue so I deleted that, at which point iPhoto Library Manager instantly displayed all my albums.  I checked iTunes and it too now showed my albums and the option to sync only selected albums was no longer grayed out!


    Per the Library Manager's instructions, I saved the AlbumData.xml file I'd modified.  The app said the iPhoto only writes this file out, it doesn't read it.  However, other apps read it to get your album info, hence the issue.  So I had to go into iPhoto and fix the problem, else the next time I exited the app, it would write the file back out improperly.  I noticed in the xml file that where the song was listed it was also referencing one of my albums.  So when I launched iPhoto, I went to that album and checked the slide show settings.  Sure enough, I had set a custom playlist for that album and listed the song I had seen on line 22155 in the AlbumData.xml file.  I removed that song from the settings, and exited iPhoto.  No more issues!  I appear to be all set!


    Now, I'm not clear if I NEEDED to edit the AlbumData.xml file.  Just looking at it showed the error and then I had to fix it in iPhoto.  So you can probably do that.  However, the iPhoto Library Manager software is the only thing I know of that could show WHERE the error was.  Since the free demo works for this purpose, I'd suggest giving it a shot.  This issue is obviously caused by our individual libraries and is not an Apple issue.  Now, the album that had the problem has existed for almost 3 years and I've never had an issue like this arise before so it's anyone's guess as to why it became a problem now.  Fortunately, it's all in the past for me now, though!


    Hope this helps someone.  Good luck!

  • John Glenn Level 1 (0 points)

    THAT'S IT!! JPHuff, your iPhoto Library Manager trick fixed my problem!! Which had become critical path, because I just got an iPhone 5 and couldn't use it until I could successfully sync again!


    You *don't* need to manually edit the AlbumData.xml file. I just played the slideshow for each album that had custom music containing an ampersand. iPhoto lamely re-assigned the default music to the album, but that solved my problem, and I don't play those slideshows any more. It would be interesting to test assigning a new song that contained an & and see if that generates the problem again or not (it might get escaped properly going forward).


    Note that TextWrangler (free) has Command-J to let you go directly to a line number without scrolling.


    I've reported this bug on Apple's internal bug reporting system. Let's see where it goes...

  • r5notes Level 1 (0 points)

    This worked for me on three different IOS devices running IOS 6 along with iPhoto 9.4 on my iMac. The problem was caused by two different slideshows each containing a song with an ampersand. I changed the songs and all is well. After I made the slideshow changes, I deleted the AlbumData.xml file and restarted iPhoto which re-created it with the new values. iTunes was now happy and I was able to select which albums I wanted to sync.

  • Shamino Level 1 (0 points)

    Thank you.  Your suggestion solved my problem as well.  I pulled by AlbumData.xml into Emacs and looked for an "& " pattern (that is, an unquoted ampersand) and found it on the music for the slide shows on each album.  Interestingly, it was pointing at songs that no longer exist (I had long since renamed the album that had a "&" in its title)


    I fixed it by going into iPhoto and for each album (fortunately, I only have five), I played the slide show and reset the music back to the theme default.  Quit iPhoto, restart iTunes, and photos sync again.


    As a test, I tried setting a different song with an & in the title.  The xml file was once again produced with the corrupted string and iTunes failed to sync photos.

  • Laubers Andy Level 1 (0 points)

    I had the same problem. Isolved it by deleting all my slide shows and left the rest untouched.


    After that all my albums were back in iTunes and I could stream again all photos to apple tv. So everything is all right again and I hadn´t to work with library manager and text wrangler.


    Good luck to everyone



  • misterfalcon Level 1 (0 points)

    This trick solved my issue. Thanks for posting!

  • JPHuff Level 1 (10 points)



         GREAT!  Glad it worked for you and the others.  Thanks for confirming that you DON'T in fact need to edit the album.xml file.  I kind of thought that might be the case, but I'd already done it.  As long as you can find where the problem is in iPhoto, should be easy to fix.  Now of course, the question is WHY this suddenly became an issue.  I created the album with the problem in 2008, so that's a LOT of other iPhoto upgrades that didn't have an issue until this one.


         Also, don't forget that instead of an '&' being the problem, this can apparently also be the result of a bad keyword in a photo or album.  If the keyword has a "null" character at the end, this same thing can happen.  Anyways, good news and good luck with iOS 6!

  • r5notes Level 1 (0 points)

    This problem existed before. I believe about a year ago. The same solution solved the problem. Although Apple fixed the problem in a subsequent release. Now it's back. Makes you wonder how they manage their software builds/releases.

  • Shamino Level 1 (0 points)

    Actually, it seems to be just with the slide show music.  I've got "&" characters in picture, event and album titles.  It is properly quoted in the XML in all those contexts.


    But I haven't tried any keywords.  I haven't used keywords since iPhoto version 1.  Apple has since made their UI so inconvenient I don't bother with them anymore.

  • danykaffee Level 1 (0 points)

    Thanks for your help guys! As a matter of fact, I will now have to get used to search forums with OSX (and Apple programs) bugs as I use to do when I have problems with Linux programs... Best OS in the world... my foot! Poor Steve, if you knew what they've done...

  • Dave7474 Level 1 (0 points)

    Thanks to all. I coudn't synch my iPad or iPhone since I upgraded to iPhoto 11, 9.4 -  I just deleted the only slide show I had in iPhoto. Synching now all fixed. This was OK for me, the slide show was only a test but I don't see this as valid option for a lot of users. Apple really neads to adress this issue.


    Message was edited by: Dave7474

Previous 1 2 Next