Previous 1 2 Next 23 Replies Latest reply: Oct 2, 2012 5:47 PM by Shamino Go to original post
  • Brad Nailer Level 1 Level 1 (0 points)

    JPHuff:  you rock.  This fixed my problem and I learned a bunch on the way.

     

    Thanks for your generosity.

  • Apple Gardener Level 1 Level 1 (5 points)

    My problem was also fixed by deleting my slide shows. How odd???

     

    I still think apple need to sort a bug fix for this issue. I've logged in via iPhoto support

     

    Thanks again

  • PaulNerve Level 1 Level 1 (0 points)

    thank you JPHuff! been searching a week for a solution, it's only your solution that worked. and is even the simplest. have all my photos back in my 4s now via iTunes synced with my iPhoto library

  • gerrycgc24 Level 1 Level 1 (0 points)

    iTunes 10.7, Iphoto 9.4. I could not sync to Apple TV, 1st generation from Itunes. I was getting error message, apple tv cannot sync photos to the apple tv unknown error 1140. I edited file, albumdata.xml in Iphoto, backed up original first. Used find and change under edit ,Changed & to n.

     

    Apple TV is, at this moment, is putting all my photos back on to my Apple TV. I had removed them from Apple TV to see if it would help. Removing the & symbol from that file worked for my problem. It is still syncing.

     

    Thanks!!

  • gerrycgc24 Level 1 Level 1 (0 points)

    Next day, same problem back again.. DId not work...

  • Shamino Level 1 Level 1 (0 points)

    This is not surprising.  The XML file is not iPhoto's primary source of data - it reads its settings elsewhere.  The XML file is re-generated every time you run iPhoto.  Hand-eding the XML file is never going to produce a result that sticks.

     

    The proper fix is to find out what attribute the offiending line corresponds to (in my case, it was music selections for slide shows) and edit the value using the iPhoto app itself.  Then it will generate a new XML file with the new value.

  • Gideonblaze Level 1 Level 1 (50 points)

    Good call. Totally fixed the prob.

     

    1) I used TextWrangler to find the albums with a slideshow containing music from an artist with an ampersand.

     

    2) In iPhoto, I updated the slideshow music for those albums.

     

    3) Quit iPhoto (believe this is necessary to write the changes to AlbumData.xml file

     

    4) Open iTunes and voila... Photo synching now works as expected.

     

    THANKS!

  • gerrycgc24 Level 1 Level 1 (0 points)

    Iphoto 9.4.1 is out, 4:29 PAC TIME, Iphone and Apple TV syncing now.Hurray...

  • Shamino Level 1 Level 1 (0 points)

    Confirmed.  9.4.1 fixes the bug for me too.

Previous 1 2 Next