Previous 1 2 Next 17 Replies Latest reply: Apr 15, 2013 5:39 PM by stef-matt
TNigimoto Level 1 Level 1 (25 points)


I'm having trouble with iMessage after updating both of my iPhones to iOS 6 and not being able to use iMessage with one of the phones.


Some background:

-I have two iPhones, one on AT&T in the U.S., and one on NTT DoCoMo in Japan, both with separate phone numbers, using the same Apple ID.

-The AT&T iPhone is a 4, the NTT is an unlocked 4S.


On my 4 (AT&T), on iMessage, I have the option to send/receive as my U.S. phone number and my Apple ID. Works just like before updating.


On my 4S (NTT), on iMessage, before I updated, I was able to send/receive using my Japanese number and Apple ID. After updating, I have the option to send/receive using my U.S. number and Apple ID. My Japanese number is greyed out and I cannot select it. When I turn on iMessage, it says "Waiting for activation..." and does not do anything. Turning iMessage off and on, some times I get an error message staying that activation cannot be completed.


I have rebooted the phone multiple times, turned on/off iMessage and FaceTime, turned the Set Date & Time Automatically option on/off, and reset Network settings several times. Nothing works; iMessage will not activate on my NTT 4S. Please help!

iPhone 4S, iOS 6
  • TNigimoto Level 1 Level 1 (25 points)

    I realized after posting that I upgraded the NTT phone first, and then the AT&T the next day. The NTT phone was able to iMessage using the Japanese number, on iOS 6, before I updated the AT&T phone to iOS 6. After that, my Japanese number is greyed out but I can use the AT&T number on my Japanese phone for iMessage.


    Still cannot activate.

  • AfzalS Level 1 Level 1 (0 points)

    Hi i just updated 2 iphone 4s and 1 iphone 4. Both the iphone 4s face simmilar problems. The imessage and facetime just show " waiting for activation". Suprisingly i can recieve and make facetime calls and imessage on apple id's but both the phones do not show the option for recieving on the number. Both the iphone 4s were updated using different computers and have different apple id's. so i guess its a bug within the ios6 os. The iphone 4 works perfectly thou

  • TNigimoto Level 1 Level 1 (25 points)

    Just an update for those who may have the same problems and questions I did:


    It is possible to link two phone numbers to one Apple ID. People on here have had success. So that is not the issue.


    I'm still stuck, with both phones now, waiting activation to use the phone numbers. I can use iMessage with my Apple ID just fine, so at least I have that.



    Your situation is a little different than mine as you are using multiple Apple IDs, but sorry to hear that your phones are not working as they are supposed to. Hopefully a fix will come out soon!

  • Carl_NZ4578 Level 1 Level 1 (0 points)

    I just fixed my two iphones on one account through the imessage settings.


    Goto -> settings -> messages -> send & recieve


    Under here you will find your imessage account contacts and you should be able to add or remove any problems


    Hope this helps

  • TNigimoto Level 1 Level 1 (25 points)


    Thanks for the reply, but that doesn't work for me.


    My phone number for each phone, respectively, are greyed out and cannot be selected.

  • Matt1979 Level 1 Level 1 (0 points)

    Was there any resolution to this? I have having the same issue.  My wife and I share an iTunes account. She updated her iphone to ios6 last problems. After I updated today, I got a message that said her iphone is now using my phone number for imessage and facetime. Under the messages/facetime settings on my phone I cannot edit the phone number, it is greyed out...and I assume it will be the same on her phone.

  • TNigimoto Level 1 Level 1 (25 points)

    Nope. Called Apple twice today. Spoke with two different representatives who could not help solve this problem.


    Matt, could you clear up your post?


    You said your wife updated her phone with no problems. So at that time, she was able to use iMessage with both your shared Apple ID and her phone number, correct?


    Then you updated your phone, and you received a message saying that her phone is now using YOUR number. That makes me think that your phone number was properly activated.


    On your phone, which number can you not edit and is greyed out? Your phone number? Is there a check mark next to it? Is there any option to use her phone number?


    Have you checked her phone yet? If so, can you list up what options you're seeing for iMessage, like this:

    Matt's Phone: Matt's #, Wife's #, Apple ID (shared)

    Wife's Phone: Matt's #, Wife's #, Apple ID (shared)


    Mine is still:

    iPhone 4 (AT&T): AT&T #, Apple ID (shared)

    iPhone 4S (NTT): AT&T #, Apple ID (shared), NTT # greyed out (and not checked)


    I really hope Apple will fix this issue soon, as I've seen many people with the same problem all over the world.

  • frogstyle7 Level 1 Level 1 (0 points)

    I'm having this same issue with my wife's phone and mine. We've done the checked/unchecked numbers and it will be okay for a little bit and then go back to receiving imessages from our own phones and double messaging.  I heard there was a way to set up 2 apple ID's under one iTune account.  I'm not sure how to do this but willing to try if it will help.  Beyond annoyed at this point.

  • AfzalS Level 1 Level 1 (0 points)

    I understand if apple has teething problems with maps. Its quite a task to have every street in every corner in the world mapped. But imessage and facetime are the key features of an apple product !  Really disappointed

  • keithloweart Level 1 Level 1 (0 points)


    Thanks man, I was getting 2x texting from the two numbers I had on my apple account when I upgraded to iOS6. Was searching Google for an answer. Went into the settings you messaged on this thread and disabled the 2nd phone number to send messages from (basically the wasy it was set up it had both phone numbers sending a message when I texted, so in essence I was sending a text from my wifes phone to myself as well as her but with the same message). Kinda crazy.


    Anyways I know your post didn't help on this particular thread, but it did help me today :-)

  • sirloin113 Level 1 Level 1 (0 points)

    I just did the ios6 update on my phone, my wife's phone and our ipad and not only were we double messaging everyone and each other, the messages were showing up as emails. I talked to a tech guy at Rogers and he suggested another Apple ID for my wifes's phone. The only problem is it requires a new email address in the set up but the one she wants to use is linked to My Apple ID. This is a freakin drag!!!!!!


    If only there was a way to delete my number from her phone in the messages->send and receive menu. 


    I shouldn't have updated my phone, now there's no turning back.

  • ChrisJ4203 Level 8 Level 8 (42,910 points)

    You can set messages to receive at, and only have the phone numbers listed and selected. You should be able to delete your number.

  • TNigimoto Level 1 Level 1 (25 points)

    Finally resolved this issue after months of off and on troubleshooting.


    I have no idea exactly which steps "fixed" the issue, but here's what I did. None of the basic troubleshooting steps that are on here worked for me, and this is including restoring both phones in iTunes as a "last resort" step that two Apple technical service representatives suggested.


    I found a post on here from user "tungddao" who suggested:


    "Turn on iMessage then make a phone call to : 011+445773142076

                 With Facetime & Siri: 011+447786205094"


    I called both numbers with my NTT 4S, and both numbers hung up right away. I also texted both numbers, and the FaceTime one went through, while the iMessage number did not. I then checked my SMS blocking settings with NTT. There were no blocks, but I reset the settings to "unblock all" anyway.


    I was able to activate iMessage and FaceTime with my Apple ID and my NTT phone number. Halfway there.


    I then turned on my ATT 4, and while I could send/receive using my Apple ID and NTT phone number, the ATT number was greyed out, which was the opposite of what had happened before, when I could use the ATT number, but not the NTT one. On my NTT 4S, I could select my ATT number, but it was stuck on "verifying" for days, and I knew it wouldn't go through.


    So, I signed out of my Apple ID on iMessage and FaceTime on my ATT 4, and turned both services off. I turned on data roaming, and turned off WiFi. *This step was key to activating both services, as they would not activate over WiFi for some reason.


    I turned on iMessage and FaceTime without signing in to my Apple ID just yet. They both activated successfully, and then I signed into my Apple ID on both services, and from then on, I can use both numbers and my Apple ID on both phones! Finally!


    These are my current options:

    Phone 1 (4S on NTT): Phone 1's #, Phone 2's #, Apple ID

    Phone 2 (4 on ATT, roaming here in Japan on Softbank): Phone 2's #, Phone 1's #, Apple ID


    Hope this helps someone out there, as this issue was real frustrating for me.

  • Guywrj Level 1 Level 1 (0 points)

    This reply is over 30 days old, but I ran into an exact issue that Matt1979, et al. had - updated two iphones to os6 (4 and 4s), my wife's and mine and both phones had our cell numbers and email addresses in the "send & recieve" settings for messages.  I would receive my wife's messages and she would receive mine.  I figured anyone with an Iphone that sent a message, both of us would recieve the msg. This can be confusing!  i finally fixed this cluster f*** -


    on my phone   >   'Settings' - 'Messages' - 'Send & Receive' - delete email account of other user [(my case my wife's) - phone number will still be there] go to - 'Send as SMS' - toggle on and off and other phone number will disappear.  do same with other phone 

Previous 1 2 Next