12 Replies Latest reply: May 4, 2013 9:17 PM by gordon142
marsmars2 Level 1 (0 points)



I am using the updated version of Keynote (5.2 version 1125) with Mountain Lion (10.8.2), and I just noticed:


When I save a Keynote file, a dupliate is automatically generated in the same folder as my original file.  If my file was called "Test", then tne new file is "Test~" (with a tilde character).


Under "Preferences - General", I have tried checking, unchecking, re-checking and re-unchecking the "Back up Previous version" options as well as the "Save new documents as packages" buttons.  I believe the "back up" option created a *third* duplicate file (with "backup" at the end) - crazy!


Can anyone help me get rid of the dupliate (with the tilde ~ character) file?  Is this a bug in the new Keynote version?  Or something I'm missing?  I can keep deleting the unneeded files, but.... what a drag.  Suggestions appreciated!


Thank you for your help!

MacBook Pro, Mac OS X (10.5.2)
  • marsmars2 Level 1 (0 points)

    OK, no replies, and I understand... I wanted to add more details, maybe someone will have an idea.


    I *completely* uninstalled everything iWork - all of the apps, supporting files, and every pref file I could find that contained iwork, Keynote, Numbers or Pages (I used the handy "Find Any File" program to do this.)  I then reset my permissions, performed cron, etc. (using YASU), and then re-installed the iWork suite from scratch.


    And guess what?  The "duplicate file" phenomenon is still present!!!


    I am wondering now if this is a deeper System preference gone crazy.... I don't think it is part of iWork, but I have no idea even what to look for at this point.


    Any ideas?


    Thanks in advance; peace!


    p.s. it's only iWork - I don't see this behavior in iLIfe (I use Garageband and iMovie a lot), Office, the Creative Suite, anything!  But I probably use iWork the most, so naturally.... *smiles*

  • Gary Scotland Level 6 (12,818 points)

    I believe this is Mountain Lion creating a tempoary backup file and is normal for other applicationsto do the same.

  • Casey 5ense Level 1 (0 points)

    Yeah, it's a joke. To me, it seems like a teriible idea. Can anyone shed light on why you would want this to happen? For instance, this is supposed to be "save" not "duplicate". I am consistently frustrated by the tilde (~) auto save/duplicate process. I have finally found this one thread in which someone found this unsettling.


    Is there anyway to remove this feature?

  • jersmi7 Level 1 (0 points)

    This is supposed to be a response to the original post by marsmars.


    Me. too.


    All apps with saveless documents are generating these dupes with tilde. They are adding up across my computer. Totally annoying.

  • Gary Scotland Level 6 (12,818 points)

    you may want to respond directly to Appleabout this issue using  Apple Support Feedback:


    Apple Support Feedback

  • Casey 5ense Level 1 (0 points)

    Check and check. I already have, hopefully there will be a revision come next release.


    I was hoping there might be a workaround or a method to prevent or modify the behavior of these tilde '~' saves?

  • jersmi7 Level 1 (0 points)

    I reported it, too. Ad I was wondering about a fix/workaround as well, like maybe a Boolean switch that could be turned on/off in terminal.

  • marsmars2 Level 1 (0 points)

    I appreciate all of your feedback, and at the very least, I'm glad I'm not the only one!!!   The iWork team at Apple contacted me, but they were unable to replicate this problem... *growls*  I like the Boolean switch idea, I just suggested that as well.  Thanks again!

  • Casey 5ense Level 1 (0 points)

    That's really interesting, I've never done something like that but perhaps it is a simple switch.


    I noticed that this auto-save/tilde process could not occur if the file was write protected. I was doing this with a Quartz Composer file in /System. There was a little message that appeared in the title of the program indicating it could not do so. Not that you'd write protect all your files but perhaps there is a simpler oceans that you could deny.

  • GodoorSun Level 1 (0 points)

    yeah. I am using Pages(4.2) and mountain lion(10.8.2).

    I have the same problem.


    I turn off the autosave and versioning with the tutorial here


    and comp up with this problem


    when i turn that on, the duplicate file won't generate, but the versioning is really annoying and use  a lot of my space.


    So, I can't find a way to solve this problem even now



  • marsmars2 Level 1 (0 points)

    Thank you for all of your responses.  I tried all of the items mentioned in the posts, but alas, they did not help.


    But on the upside: due to another problem I experienced, I re-installed the Mountain Lion software (pressing command-R at startup).... this took roughly two hours to complete ("additional software" was needed), but voila! my "duplicate files" are no longer present in any of the iWork suite programs!  This was a wonderful benefit, and now only one file is being displayed... so I do not know what file(s) were causing this phenomenon, but reinstalling the system files (and leaving the rest of my files intact) did the trick, at least for me!, and hopefully you too if you are seeing this kind of behavior....


    Good luck, thanks agian, and peace!

  • gordon142 Level 1 (15 points)

    I thought I would provide some more information for anyone else who might run into this:


    I was encountering precisely the same issue. In my case, I had deleted the Document Revisions database at the root of the drive to solve an unrelated problem with backups. I had assumed the database would simply be recreated the next time a file was saved in a versions-supporting application. This was not the case however. Apparently when an application is unable to save a version in /.DocumentRevisions-V100, it instead renames the current version of the file to "filename~" and saves a new version with the original name.


    In my case, all I had to do to fix it was to restart the system. This caused the database to be recreated, and saving started working normally again. This is clearly not exactly the same as what the happened to the original poster, but the symptoms are the same, and I'm assuming the same basic cause (the OS is unable to save revisions to the revisions database.) If I were in the original poster's position and had not already reinstalled my system, I would try deleting the .DocumentRevisions-V100 directory, restarting, and seeing if this fixed it (WARNING: deleting this directory will remove all but the latest saved version of all your files)


    To delete .DocumentRevisions-V100, open Terminal and enter "sudo rm -rf /.DocumentRevisions-V100"

    Hopefully this helps someone.