Previous 1 4 5 6 7 8 9 Next 131 Replies Latest reply: Oct 11, 2013 7:29 AM by Maroquio Go to original post
  • marcusreese Level 1 Level 1 (5 points)

    I tried rchealey's instructions and it did not work for me. When I got to the sudo chmod -R AppleHIDMouse.kext command I got a response that showed me the usage code options when using the chmond command, -R, -H, etc. Is that normal when you issue that command?

  • rchealey Level 1 Level 1 (5 points)

    Sorry...step (3)should say

    sudo chmod -R 755 AppleHIDMouse.kext

  • Philip Keller Level 1 Level 1 (0 points)

    He's a lucky dog, that rchealey! I also tried replacing AppleHIDMouse.kext with a "known-good" copy from another computer (after yelling "Eureka!" and kicking myself for not thinking of that myself), but unfortunately it didn't work for me.

     

    One difference between myself and rchealey is that I don't have access to Mountain Lion; my extension came from another computer running MacOS 10.7.5. In fact, a quick diff showed that the supposedly "known-good" driver was identical to the "bad" driver. The plot thickens...

     

    Now I'm wondering how that could possibly be. One difference between my "good" and "bad" 10.7.5 systems is that "bad" is the only one running the 32-bit kernel/extensions and "good" is running 64-bit. But I just tried rebooting "good" in 32-bit mode (by holding the "3" and "2" keys down during reboot), and it's still "good".

     

    The reboot in 32-bit mode takes a long time, which, as I understand it, is because the OS has to rebuild the extension cache. That made me wonder whether the problem with my "bad" system is a corrupted extension cache. Has anyone tried rebuilding it? (for how to do this, see, for example, Japamac's response in this thread:

       https://discussions.apple.com/message/16518704#16518704 )

    I'm going to try this as soon as I get home.

    -- Philip

  • Philip Keller Level 1 Level 1 (0 points)

    Update: rebuilding the extensions cache didn't change anything. I still have no clue why the same driver right-clicks on one system and not on the other...

    -- Philip

  • kg23 Level 1 Level 1 (115 points)

    After trying everything listed in this thread, I ended up doing a reinstall of Mountain Lion. That fixed the problem.

     

    * Reboot

    * hold down option

    * select recovery image

    * reinstall ML

     

    It seems that all my previous settings were maintained.

     

    Overall, a lame experience having to reinstall the entire OS just to recover right-click functionality on my mouse.

     

    Apple. Give your QA folks more time/money.

  • jdstach Level 1 Level 1 (0 points)

    I used this method, and it worked perfectly for a few days... then reverted back to no right clicking.  I think it happened during a reboot, but I can't be sure.  I use this machine as a media center, so I don't have to right click very often.  I got a copy of the mouse kext from another 10.7.5 install, maybe that had something to do with it.  I think my father in law's Macbook is running Snow Leopard, so I will try that version of the file and report back.

     

    My details: 1.83 ghz Core 2 Duo Mac Mini, 4 GB Ram, 10.7.5, Bluetooth Mighty Mouse

  • piratx Level 1 Level 1 (0 points)

    Wow! Thanks again!

  • kg23 Level 1 Level 1 (115 points)

    After reinstalling Mountain Lion, I've opted to stay at 10.8.1 and not accept the 10.8.2 upgrade since that seems to be what caused the mouse button issue. I'll try 10.8.3 when it arrives. So far, I've been fine at 10.8.1. The clicking issue hasn't resurfaced.

     

    The mouse click issue some are experiencing with 10.7.5 may be a completely different one, however.

  • MadHgts Level 1 Level 1 (0 points)

    So like most, if not all of you I've done everything I could to get my right click to work after a reinstall of Lion. My original problem was the dreaded fan speed which turned my computer room into the landing strip of Detroit Metro Airport.

     

    So I reinstalled Lion not once, not twice, but three times in the last week to no avail with the fans, however, the new problem of no right click now reared its ugly head...

     

    So I follwed the adivce above about removing the plist file, but didn't just stop with the mouse driver, I eliminated the: com.apple.driver.AppleBluetooth plist as well and it now works. I also removed the AppleHIDMouse.kext from the expansion file and put it in the trash without replacing it. And it works fine. I'll keep that file if something goes goes bad, but the mouse is working perfectly. I tried a wirless bluetooth and a USB connected Mouse neither of which would right click or click on buttons 3 &4. Now they both work fine.

  • semifocused Level 1 Level 1 (0 points)

    BartHmr's fix worked for me, using Mighty Mouse on 10.7.5.  Slight mod to the path:

     

    mkdir ~/Quarantine

    sudo mv /System/Library/Extensions/AppleHIDMouse.kext/ ~/Quarantine/

     

    # then reboot

     

    # after reboot, right click functionality was working

  • rae53cr Level 1 Level 1 (0 points)

    I had the same problem, but i figured out the fix. Choose for the #3 button Dashboard . For the side buttons do not choose the #4, choose Mission Control, then these buttons will work the way they were working before the 10.7.5 update.

  • rae53cr Level 1 Level 1 (0 points)

    Make sure the right button is set as secondary button.

  • MadDogZ06 Level 1 Level 1 (0 points)

    I don't fully understand.  Can you add some more detail in your instructions?  If this really works, a BUNCH of people will want ot use it.  A few screenshots would be very helpful.

     

    Rich

  • rae53cr Level 1 Level 1 (0 points)

     

    Message was edited by: rae53crScreen Shot 2013-01-15 at 2.21.15 PM.png

  • rae53cr Level 1 Level 1 (0 points)

Previous 1 4 5 6 7 8 9 Next