Previous 1 5 6 7 8 9 Next 131 Replies Latest reply: Oct 11, 2013 7:29 AM by Maroquio Go to original post
  • MiraclesMW Level 1 Level 1

    Your post are from some time ago.  Hopefully you all found a solution, but if not, I have one that works most of the time.  I am not sure of everything, but on the dock, if I right click and pause for a few seconds, the pop-up menus shows.

  • Damack Level 1 Level 1

    BartHmr,

     

    Thanks for your suggestion of deleting the AppleHIDMouse.kext from the folder.  I rebooted and shazam!  That worked!!!!  Wohooo!!!

     

    By the way, I like many others tried the USB overdrive software and while it does resolve the issue, I felt a lot of quikyness from the mouse and irratic movements using this software.  At the end of the day, it got the job done, but as long as you're willing to accept it's not perfect.  I myself prefer the native Apple control for the mouse. Hope this helps others as I've been searching for a LOOONG time now for a solution to this problem.

  • Till von Reumont Level 1 Level 1

    Hey,

    I just talked to German Apple telephone support. They fixed the problem for me! With fresh  installs of 10.7.5 the problem is that two files are missing that are needed for the mouse. In my case I could get them from another computer I own that ran Lion and did have the files. To get to the files you need do this:

     

    Go to

    /System/Library/LoginPlugins/BezelServices.loginPlugin

     

    control-click that file and choose "show contents"

    now in the finder window navigate to

    Contents/PlugIns/

     

    In this folder should be two files named

    AppleBluetoothHIDMouse.plist

    and

    AppleHIDMouse.plist

     

    If you don't find these files, you need to get them and put them in.

  • Dfhughes Level 1 Level 1

    Posted this on the other thread as well,

     

    Thanks Till this does work!

     

    Since October Apple has no fix and claim they could not duplicate the problem but following your solution I find I did not have the files listed, I took the files from my Macbook from the same location running Lion 10.7.4, copied them to the plugin file, had to authenticate, rebooted and it works!

     

    Now how do I indicate your post solved my problem?

  • marcusreese Level 1 Level 1

    YES!!! That worked. I was missing those two files and I copied them from an older version of Lion and restarted. I have my right click on my mouse again in Lion 10.7.5. Till von Reumont, thank you so much.

  • Philip Keller Level 1 Level 1

    Add me to the list of happy customers. I was able to restore those two files from a Time Machine backup. Now I even get battery-level reports again... right after having to replace dead batteries in extremis, of course.

     

    I hope NG7 is still following this thread, since I imagine that it's the original poster who has to mark the issue as resolved.

     

    Thanks for posting, Till!

  • PERockwell Level 1 Level 1

    Add me as well to the list of people that now have a working Magic Mouse. Recovered the files from a Time Machine backup and all is well again. 

     

    Would love to know how Till got the German Apple folks to figure this out when the US Apple crew couldn't - or didn't want to bother.

     

    You can bet I will have a few things to say on my open bug report.

  • MadDogZ06 Level 1 Level 1

    Anyone tried this on 10.8.2?

  • Joe Zollner Level 1 Level 1

    Thank you, Till!  Looks as though this is the solution, at least until Apple issues an "official" fix.  I checked the folder indicated in your post and indeed, I'm missing the two files.

     

    However, I purchased 10.7.5 direct from the App Store, meaning I can't get copies of the two files from 10.7.4. 

  • Dfhughes Level 1 Level 1

    Hey Joe!

     

    If you want I can email you the two files, they are only 3k or so. I can enable my email address on my profile if you so desire.

     

    Dave

  • RG777 Level 1 Level 1

    Hi Dfhughes, can you please email this files for me too?

    (using appstore version, have not TM backup)

  • piratx Level 1 Level 1

    Nice fixes and alternatives! I think though that the right way is to remove the extension so you can put it back when Apple officialy relase something that will fix it!

  • Dfhughes Level 1 Level 1

    Sure RG, you either have to turn on your email under your profile \privacy settings or click on my name as I have enabled my email address to be shown to registered users. I checked your profile while signed in and I don't see an email address.

     

    Thanks,

    Dave

  • RG777 Level 1 Level 1

    Thanks Dave, done with this.

     

    RG

  • nel134 Level 1 Level 1

    Thank you for this!

Previous 1 5 6 7 8 9 Next