Previous 1 6 7 8 9 10 Next 148 Replies Latest reply: Feb 21, 2014 10:18 AM by Todd Jacobs Go to original post
  • Christopher Murphy Level 3 Level 3 (555 points)

    Oh and Spotlight and Time Machine aren't even partition aware. They only care about JHFS+/X volumes.

  • stcinder Level 1 Level 1 (0 points)

    Another data point:


    I bought a new hard drive yesterday to do a TM backup onto.


    I formatted it with the LaCie software, and then formatted and encrypted it with Disk Utilities.


    When I tried to do the TM backup, I was back to the same problem. I had to turn Spotlight off, do the backup and then turn it back on again. When I turned it on, Spotlight was stuck on the indexing again...

    Did the /var thing again, and back to normal.


    So is it something in Disk Utilities which is putting a file in the folder which is catching Spotlight out?

  • Christopher Murphy Level 3 Level 3 (555 points)

    I don't know. I only become (inconclusively) suspicious of the contents of /var/folders because one of those random-name folders contained items mds and sandbox-cache.db which mdworker kept getting stalled on according to the command

    sudo opensnoop -n mdworker


    You could try using that the next time Spotlight slows down and see where it's stalling out. Not all of these reported Spotlight slow downs necessarily have the same source problem or fix.


    And also the next time someone has this problem they should try manually adding /private/var/folders to the Privacy tab of Spotlight in System Preferences, instead of deleting those folders. Since I can't reproduce the conditions of the slow down yet so far, I can't do anymore testing.

  • baltwo Level 9 Level 9 (62,205 points)

    stcinder wrote:

    I bought a new hard drive yesterday to do a TM backup onto.


    I formatted it with the LaCie software, and then formatted and encrypted it with Disk Utilities.

    Bad move using LaCie's software. All that 3rd-party SW is crapola, especially the stuff Western Digital puts out. Wipe the HD and just use DU to format it properly. Then, try TM and Spotlight.

  • baltwo Level 9 Level 9 (62,205 points)

    All Intel Mac have (U)EFI firmware, which requires an EFI System partition. This partition is hidden. There's no reason it needs to be visible because it relates to the firmware and bootloaders, and isn't considered user domain. Same for the Recovery HD partition that appeared with Lion. It's a hidden partition, users aren't meant to interact with the contents directly.

    But do note that one can enable DU's Debug menu and it's Show all partitions option, which displays all partitions. That allows users to ascertain with of many bootable volumes on a partitioned disk might have the Recovery HD. I find it very useful, since I six bootable ones, one for each OS and their clones. Some have the Recovery HD and some don't.

  • Christopher Murphy Level 3 Level 3 (555 points)

    I've read elsewhere that slow downs recur for some people merely when mounting any additional (non-boot) JHFS+/X volumes. So I don't think there's a relationship between what software is used.


    Further, any GUI application necessarily obscures what it's actually doing to the disk. You'd have to permute the features in the software and scan the disk with utilities that truly show the on-disk effect in order to correlate any GUI app's capabilities to reality. Even Disk Utility obscures "hidden" partitions, and as I've exhaustively detailed in the Boot Camp discussion lists, Disk Utility will nuke critical partition information rendering Boot Camp unbootable in certain (and not unreasonable) instances, such as adding an additional partition to a disk, and will not warn you in advance that doing so will cause Boot Camp to become non-bootable. And the only prescribed method to fix it is to blow away your whole drive, and reinstall everything from scratch and from backups (fortunately I've discovered a number of ways around the prescribed method rather than starting over but it's 100% command line based, because again the GUI utils basically lie, just by their nature of trying to make complicated things simpler).

  • Christopher Murphy Level 3 Level 3 (555 points)

    DU's Debug menu and it's Show all partitions option


    The Terminal command,

    diskutil list

    will show all partitions on all devices.


    sudo gpt -r -vv show disk0

    where disk0 is one of the disks listed in the first command, typically the boot disk, will show a fairly complete listing of the GPT entries for the disk, including the partition type GUIDs (which you can look up in the partition type grid on Wikipedia).

  • baltwo Level 9 Level 9 (62,205 points)

    Some people are Terminal adverse and prefer using a GUI. Both of which are user tools, which was my basic point.

  • somewhitechick1 Level 1 Level 1 (0 points)

    My big update is that I have no update. After speaking to a senior tech at Apple Care, he called me back yesterday. I missed the call. His voicemail said the engineers had given him some additional commands they wanted me to run. I called back but he is off until Tuesday. I tried speaking with another senior tech and they cannot access the first tech's notes. I spent 45 minutes holding and being transferred around for nothing. I guess I wait until Tuesday. This is so awesome. I'm starting to get extremely frustrated. And I find it absolutely beyond that no one at Apple Care has heard that this problem exists.

  • kilgo Level 1 Level 1 (0 points)

    Upgraded to Mountain Lion 10.8.2 and this fixed everything.


    I caved...I'm ashamed to say. I paid Apple the extortion fee and downloaded and installed ML 10.8.2. Spotlight does index but normally...It took 15 min to index 200g HD. Then Time Machine worked fine.


    I hate myself.


    Now, until a new paid OSX system comes out were safe to run the current one! Then they break the old one forcing you to upgrade...tricky.

  • Christopher Murphy Level 3 Level 3 (555 points)

    Yeah well some as|hat has posted a work around, so there are that many few people complaining about the problem. I have posted opensnoop output in this discussion thread if it helps them narrow the actual problem.


  • kilgo Level 1 Level 1 (0 points)

    I was on the phone the other day for over 2 hours! Still nothing was resolved. Same old stuff, do this try this "no I haven't head of the problem" "yes we read the discussion forums"...bla, bla, bla,...lie, lie, lie...


    most of these "teck-nuckle-heads" are just young kids with no knowledge of how to fix a problem which they are kept in the dark about anyway!


    The purpose of these discussion boards are not for the users to help each other, they are a test lab for the coders. Apple senior programmers release this crap then set back and pool complaint results. That tells them where the problem is most likely.


    In the mean time they kick back and wait for critical mass.


    YOU, are i a sense just a component in a vast circuit board.

  • andi islinger Level 1 Level 1 (0 points)

    hi christopher,


    i am having the same issues with spotlight and timemachine, send bug report to apple....


    have been for hours online researching how to fix this, its driving me nuts...


    i want to try your suggestion... but i am weary to make mistakes... my question starts with not finding /var/folders can't do a search as spotlight indexing for months... do i have to delete the contents of this folder, put into trash and empty trash?


    i have found the terminal, never used it so i want to make sure.... you say entering the 2 commands, but are't there 3 commands?

    sudo mdutil -i off /

    sudo mdutil -E /

    sudo rm -Rf /var/folders/*


    do i have to copy each of the 3 seperately or copy paste in one go and then hit enter?


    then i reboot and then go to terminal paste


    sudo mdutil -i on / and hit enter?

    sorry for my ignorance this tech stuff is all fairly new to me


    is this still all working for you?


    thanks so much



    I might have a working "fix". Based on the constant stalling on sandbox-cache.db I decided to take a chance and delete all folders found in /var/folders using the command. What I actually did, in order:


    Restored Evernote, Colloquy, LibreOffice back to /Applications (from the Trash).

    Quit all applications except Terminal, issued the following two commands:

    sudo mdutil -i off /

    sudo mdutil -E /

    sudo rm -Rf /var/folders/*




    sudo mdutil -i on /

  • ptoal Level 1 Level 1 (0 points)

    Okay... So I have tried:


    1. Wiping out my spotlight indexes

    2. Rebooting in Safe Mode

    3. Removing /var/folders contents.


    #1 and #2 helped me get my spotlight index back for my files (this was my major issue).


    I was still having problems with my Time Machine backups, though.  They would stall at a few kb or a few mb of backup.


    #3 Seems to have fixed the rest of everything.  I'm currently creating a new backup and it is now working at maximum speed.  I'm going to give it a couple of days to make sure, but I think that wiping out /var/folders was the magic ticket.



  • andi islinger Level 1 Level 1 (0 points)

    i googled a bit more and worked out



    got to



    its located in macintosh HD private (which seems to be inactive)




    i have 3 folders in there

    1. 9w

    2. xc

    3. zz


    do i have to delete the 3 folders or do i have to delete the root folder called "folders"

    just put in trash or empty trash?


    thanks so much....

Previous 1 6 7 8 9 10 Next