1 6 7 8 9 10 Previous Next 148 Replies Latest reply: Feb 21, 2014 10:18 AM by Todd Jacobs Go to original post
  • 120. Re: Spotlight not working correctly
    Christopher Murphy Level 3 Level 3 (525 points)

    @andi islinger

    are't there 3 commands?

     

    In fact there are three commands. I aded a command after the fact, but failed to update the number of commands count.

     

    do i have to copy each of the 3 seperately or copy paste in one go and then hit enter?

     

    One command per line. If you exactly highlight the first and last character of a line, you can copy and paste.

     

    is this still all working for you?

     

    So far no negative consequences. Unclear if it's a long term solution or not.

     

    do i have to delete the 3 folders or do i have to delete the root folder called "folders"

    just put in trash or empty trash?

     

    Delete the folders inside the one called "folders".

  • 121. Re: Spotlight not working correctly
    Stohler151 Level 1 Level 1 (0 points)

    Hi Christopher (and everyone else affected by this issue),

     

    I'm not totally sure I'm having the same issue as everyone else since my Spotlight seems to have never indexed after I upgraded from Snow Leopard to Lion. I discovered the problem when tyring to set up a bootcamp partition and finding that Finder showed 90GB free and Disk Utility (and consequently bootcamp assistant) showed only 68GB free of 250 on my 2009 MBP. On the advice of Apple tech support I forced a reindex (or I guess maybe just index) of my HDD. Adding and removing the entire disk from the Privacy tab on Spotlight did not start an index so I had to start it through Terminal. Since starting the indexing, Spotlight has moved from 3 days to now up to 2 weeks. (FWIW, I could/can still make TM backups to my external drive just fine).

     

    I'm trying your fix by adding /private/var/folders to the Privacy tab on Spotlight. Simply adding the directory did nothing. Spotlight continued to report "About 2 weeks" to index my HDD.

     

    I then went in to Terminal and disabled indexing using the two commands you suggested (1. sudo mdutil -i off / and 2. sudo mdutil -E). I then restarted indexing using sudo mdutil -i on.

     

    It has been approximately ten minutes and Spotlight is still estimating the time it will take to complete the index.

     

    I will post here again to let you know if it completes the index or not. If it does not, I will try deleting the priate/var/folders directory and then restarting the index and post my results.

     

    If anyone wants more information about my particular system/problem, just let me know and I will post.

    Thank you all for your help (especially Christopher)

  • 122. Re: Spotlight not working correctly
    stcinder Level 1 Level 1 (0 points)

    Well I tried it on 10.8.2

    It didn't seem to work the first time, and I thought that I had completely stopped Spotlight from working.
    I did it again and Spotlight returned to normal, and TM backed up. Previously TM was just sitting on "Preparing Backup"

  • 123. Re: Spotlight not working correctly
    Martin Sénéclauze Level 1 Level 1 (5 points)

    Dear all,

     

    I managed to get Spotlight working by doing the follwoing:

         Stop spotlight using sudo mdutil -a -i off

         In th spotlight control panel, under the Privacy Tab, put all your disks

         Restart Spotlight using sudo mdutil-a -i on

         Erase the spotlight database sudo mdutil -a -E

     

    Things look OK (so far). Time machine started to backup at a reasonable speed but more than what was changed since the upgrade. I'll keep you posted in a few hours how things are going.

     

    Martin

  • 124. Re: Spotlight not working correctly
    ErikHendrix Level 1 Level 1 (10 points)

    I tried adding /private/var/folders to the Privacy tab of Spotlight and it did not help. Deleting the folders as per your earlier suggestion and then restarting did work however.

     

    Thanks.

  • 125. Re: Spotlight not working correctly
    Phil Coleman Level 1 Level 1 (0 points)

    Hi all,

    I've had this problem and thanks for the tips. The fix described above (disable indexing, remove /var/folders/* ...) worked yesterday but the problem returned today!

     

    I've noticed that apple have released a supplemental update to 10.7.5 that is supposed to address this issue (available through software update) so I'm hoping that will put it to bed.

  • 126. Re: Spotlight not working correctly
    Looter Level 1 Level 1 (55 points)

    Apple just released 10.7.5 supplemental that is meant to address this specific issue.

     

    http://support.apple.com/kb/DL1599?viewlocale=en_US&locale=en_US

  • 127. Re: Spotlight not working correctly
    Aikasse Level 1 Level 1 (0 points)

    This update solved my indexing spotlight and time capsule backup issues.

     

    Thanks

  • 128. Re: Spotlight not working correctly
    Jean-Luc Level 1 Level 1 (0 points)

    Apple 10.7.5 solved this concern

  • 129. Re: Spotlight not working correctly
    rowenacherry Level 1 Level 1 (0 points)

    I have OS 10.4.11 and my spotlight is not working. What should I do, please?

  • 130. Re: Spotlight not working correctly
    dmgva Level 1 Level 1 (0 points)

    Checked for Lion update and found 10.7.5 Supplemental Update, it seems to have solved my slow & continuously long indexing.

  • 131. Re: Spotlight not working correctly
    deborah278 Level 1 Level 1 (0 points)

    I have 10.6.8 and mine is not working now.  Did you get an answer to your problem with Spotlight?

  • 132. Re: Spotlight not working correctly
    rowenacherry Level 1 Level 1 (0 points)

    I'm sorry. The Spotlight did come back on my 10.4.11. I cleared the cache and emptied the trash and unlocked a file (that should not have had anything to do with anything as it was a list of writers' charities) that had become mysteriously locked. I then gave up. Turned off the computer. The next time I logged in, all was magically fine.

     

    It was a solution, but not an answer, because I cannot say whether Spotlight came back by coincidence or because I had too much trash.

  • 133. Re: Spotlight not working correctly
    KeepItFunky Level 1 Level 1 (0 points)

    I upgraded to 10.7.5 and spotlight is still telling me that i have 7 days remaining on index.  Also I tried to install 10.7.5 supplemental update but that said my volume was invalid for the update, not sure why.

     

    Help please, it's impossible to use my comp with out being able to search for things!

  • 134. Re: Spotlight not working correctly
    lauhub Level 1 Level 1 (0 points)

    Did you try this:

    • Disabling Spotlight
    • Deleting existing index
    • Deleting /var/folders/*
    • Re-enabling Spotlight

    ?

1 6 7 8 9 10 Previous Next