Previous 1 2 3 4 5 Next 148 Replies Latest reply: Feb 21, 2014 10:18 AM by Todd Jacobs Go to original post
  • jflow Level 1 Level 1 (0 points)

    I am having the same issue.  Spotlight indexing says anyware between 3 weeks to 20 hours.  Ran all night and still no luck.  TimeMachine is also taking forever! 

     

    Errors from console:

    9/28/12 12:40:09.437 PM mds: (Error) ImportServer: <MDSImporterWrangler: 0x7f7f58e4f0c0> still waiting for plug-in info from mdworker

     

    I tried resetting spotlight several times via terminal and via putting the hard drive into the privacy section of spotlight - then removing it, but no luck. 

  • razmarin Level 1 Level 1 (0 points)

    and it wont be any luck until apple fixes this. i was thinking that restoring home permissions did the trick, but after several restarts spotlight was still showing endless times. & i decided that this is a good moment to move to 10.8 and wasnt dissapointed at all - spotlight did its thing perfectly right after upgrading and increasing of overall performance was like bonus. so if you are on compatible machine, it will be easier just to upgrade to ML 

  • pacific.impeto Level 1 Level 1 (0 points)

    Some have traced the problem back to lsboxd (launch services sandbox daemon)

     

    I tryed to clean all caches system wide, but did not work. At the end I downgraded to 10.7.4 using recovery boot and Time Capsule (with recovery boot still workes).

  • baltwo Level 9 Level 9 (61,805 points)

    Booted with SL, used sudo mdutil -E on the Lion volume, saw a bunch of these, but reindexed in about eight minutes. I'll check later by booting into Lion. If the issue persists, then it's time to file bug reports. Upgrading to ML won't help those stuck in Lion. The problem needs addressing by Apple.

     

    Sep 28 10:17:09 localhost mdworker[1970]: Cannot find factory 548A3091-3C5D-498A-A329-B532A6C896BB

    Sep 28 10:17:39 localhost mdworker[1970]: CgBI: unknown critical chunk

    Sep 28 10:17:45 localhost mdworker[1970]: Cannot find factory FC0957C6-10A1-469B-AA54-5A9FFE718A93

    Sep 28 10:17:45 localhost mdworker[1970]: CgBI: unknown critical chunk

    Sep 28 10:18:19 localhost mdworker[1970]: Cannot find factory 548A3091-3C5D-498A-A329-B532A6C896BB

    Sep 28 10:18:19 localhost mdworker[1970]: Cannot find factory 548A3091-3C5D-498A-A329-B532A6C896BB

    Sep 28 10:20:33 localhost mdworker[1950]: iCal.mdimporter: could not find component keys: /Volumes/Lion/Users/username/Library/Application Support/iCal/Sources/648D1455-E922-475C-8F0E-559FC74F0F80.calendar/corestorage. ics

    Sep 28 10:20:41 localhost mdworker[1950]: failed to get locale ID from LCID 854

    Sep 28 10:24:05 localhost mdworker[1950]: Error, could not create MachMessagePort for com.apple.AddressBook.abd

    Sep 28 10:24:06 localhost mdworker[1950]: *** Failed to decode 7bit; data, treating as binary

  • HerrDrKarl Level 1 Level 1 (15 points)

    Thanks razmarin and baltwo for testing and confirming that the same volumes will index fine in either SL or ML.

     

    As baltwo says, upgrading to ML won't help Apple diagnose and fix thie problem in 10.7.6 (which I sure hope is coming really soon now)...  but, people need to get work done, so if downgrading to 10.7.4 or upgrading to 10.8 lets that happen, then that's good to know.

     

    I'm sticking with 10.7.5 for now as I had entered a bug report last week and was just contacted yesterday by support wanting various logs for the engineers.  Don't want to upgrade to ML in case they want more data...

     

    BUG ID: 12355407 is the report that I made that references this thread - so hopefully engineers are watching all of our comments here, too.  If any of you enter additional bug reports, you might mention bug ID 12355407 so that they tie all of the reports together.

     

    Misery loves company.  I do wonder why this issue isn't reported on any of the Mac blog/rumor sites (that I've noticed), unless for some reason the vast majority of 10.7.5 updaters have not had any problems?

     

    Karl

  • kilgo Level 1 Level 1 (0 points)

    10.7.4 > 10.7.5

     

    Same problem here Spotlight advises that it will take anywhere from 4 months to 3 days to index my drive. (depending on how it feels I guess)

     

    There are SO many fixes out there, SO many conflicting reports...some are too easy to be true, others require it be done only in zero G.

     

    I finally completely erased my HD. Reinstalled lion from Snow Leopard, Migrated my old system and docs, did the Software Update for hours and hours, and finally, today am back up-and-running.

     

    Incidentally my only issue was that Migration assistant installed Safari 5.6.1 and I found a download link to Safari 6 which alleviated the crash-on-start.

     

    BTW. Spotlight is now indexing and it will take 3 years to complete.

  • vykor Level 2 Level 2 (290 points)

    Having this exact same issue with the same "still waiting for plug-in info from mdworker" and lsboxd error logs, on OS X 10.7.5.  The problem is larger in scope than just long indexing time: even if you complete indexing, Spotlight will no longer index any new files. 

     

    I have a suspicion that people aren't noticing this problem.  I didn't notice this problem myself until about a week into 10.7.5, trying to search for a document I created days ago that never showed up in Spotlight.  Old documents were still indexed and searchable, but new ones were not. I had to manually run mdimport to get files loaded into the index.

     

    • I tried a number of things, including the usual voodoo like Safe Boot (same problem), permission repairs (as usual, useless), and cache clearing (I don't know why people even try this sort of nonsense).
    • What I did notice is that lsboxd no longer starts up properly.  On OS X 10.7.4, lsboxd is running immediately when I log in.  On OS X 10.7.5, that is no longer the case -- lsboxd isn't on the active process list.  However, manually starting lsboxd did not help.  I have a suspicion that lsboxd is a related symptom of an underlying problem.
    • Clearing the Spotlight index and caches just made everything worse.  Now nothing is searchable and reindexing was not going to happen.

     

    I had to restore to 10.7.4 from a Time Machine backup.  I copied over the new documents I created, rebooted into Recovery Mode, and restored from the last 10.7.4 backup.  Problem fixed.  Not going to upgrade again, security vulnerabilities or not, until there is a clear indication of a fix for this issue.

  • HerrDrKarl Level 1 Level 1 (15 points)

    kilgo wrote:

     

     

    I finally completely erased my HD. Reinstalled lion from Snow Leopard, Migrated my old system and docs, did the Software Update for hours and hours, and finally, today am back up-and-running.

     

    Incidentally my only issue was that Migration assistant installed Safari 5.6.1 and I found a download link to Safari 6 which alleviated the crash-on-start.

     

    BTW. Spotlight is now indexing and it will take 3 years to complete.

     

    Not enough sleep last night, so to be sure:  you're saying that after a complete reinstall of Lion - including the 10.7.5 update - you're back where you started, with Spotlight taking forever (and presumably TM not working when Spotlight is running)?  If so... bummer, but i guess that confirms the 10.7.5 issue.

     

    OT:  thanks for the info on the Safari 6 update.  I had installed Lion from scratch on a new volume on another computer and migrated, and crashed and couldn't figure out why... and so gave up on that.  Good to know.

     

    The only 'different' things about my two Macs that are indexing forever is that (1) they both are running Parallels Desktop 6 [which has extensions live even when Parallels is not running], and (2) the User folders are repointed to a volume other than the SSD boot volume - via the advanced option in Preferences > Users.  Anybody else have one or both of these things going on?  Just wondering if one of these is related to why the entire world is not screaming over the 10.7.5 indexing problem, and only the handful of us here...

  • Larry Nolan Level 2 Level 2 (165 points)

    I'm having the Time Machine + Spotlight issue, but on my iMac 10.7.5 the lsboxd process is there and running (at least right now).  And, new documents I've created under 10.7.5 are searchable and found by Spotlight (the ones I have checked at least).

     

    Other things that run with icons on the Menu bar are : Dropbox, Junos Pulse, Google calendar and email notifiers, Crashplan.  I don't use Parallels or Fusion (currently), but do run Virtual Box 4.2 - I don't think it has any always-running processes though.

  • HerrDrKarl Level 1 Level 1 (15 points)

    Good to know it is probably not Parallels then.  Should have said we run Dropbox on both machines, too...

     

    Weird thing about recent file indexing... is that recent files seem to be indexed on my Mac Pro, but they are not indexed on my wife's Macbook Pro.  Also, Mail is not properly indexed for either of us - cannot search content.

     

    I see lsboxd appear and disappear in Activity Monitor - mostly it is not there. mds and mdworker also come and go.

  • kilgo Level 1 Level 1 (0 points)

    I ALMOST found a fix! Although I have paid a heavy price...losing three fingers.

     

    I made a deal with an organization from the future to send me back in time so that I could find the tech who initiated this insane update. I was only supposed to take clothing, one energy bar, antibiotics and chewing gum.

     

    Paying the travel fee, I let them put me under, I awoke in a field of tall grass, it was raining. Groggy, and disoriented I stood on wobbly legs when I heard a voice. French, I think? An old man with two teeth in his head shouting at me his breath smelled like a combination of fish and old socks.

     

    He was laughing and pointing at my clothes, and said...Tu vas prendre froid dans ces vêtements. Vous êtes perdu? Vous êtes un imbécile ... n'êtes-vous pas? Suivez cette route jusqu'au prochain po garde du roi sont ce soir! méfiez-vous!

     

    From here the story gets weird.

  • stcinder Level 1 Level 1 (0 points)

    Resetting spotlight is the kiss of death. It will never work again...

    Turning Spotlight off using Spotless fixed the Time Machine problem for me.

    It took me a while to realise the source of the problem. At first I just thought my backup drive was failing. Two external hard drives later...

  • kilgo Level 1 Level 1 (0 points)

    Yeah, except Spotless is totally incompatible with 10.7.5! At least the version is that I downloaded.

  • HerrDrKarl Level 1 Level 1 (15 points)

    I was (earlier posts) able to disable Spotlight in order to run TM backups ... and then to re-enable afterwards, although then it started reporting insanely long times again.  (Has never finished on either machine.)  Found this in other threads...

     

    From Terminal:

     

    sudo mdutil -s /Volumes/*

     

    just displays the current indexing status of all volumes.

     

    sudo mdutil -a -i off

     

    turns spotlight indexing off for all volumes (-a is all - otherwise you can specify volumes if you have multiple disks/partitions).  TM should be able to run at normal speed then.  Then:

     

    sudo mdutil -a -i on

     

    after your TM backup completes, turns indexing back on, such as it is in 10.7.5

     

    Other threads (and the mdutil man page) have info about how to delete the spotlight database info via mdutil or physically removing .Spotlight-V100 folders ... but starting fresh did not improve this 10.7.5 problem for me at all, so won't repeat it.

     

    Might be worthwhile backing up by some other means anyway (Carbon Copy Cloner, etc.)...

  • Christopher Murphy Level 3 Level 3 (555 points)

    I have the same problem with 10.7.5. Normally a reindex is 2-3 hours. I'm at 8+ days for the estimate and all the md related processes are hung. There is nothing interesting in console except:

     

    Sep 29 12:48:15 mingisapsycho mdworker32[3596]: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

    Sep 29 13:00:31 mingisapsycho mdworker[3608]: Unable to talk to lsboxd

     

    My question for all is if anyone knows the relationship between Time Machine and Spotlight indexing? Is fsevent database that tracks changed files for backing up completly independent of Spotlight? Or is it possible that Time Machine backups will be adversely affected by this (increasingly obvious) bug?

Previous 1 2 3 4 5 Next