12 Replies Latest reply: May 6, 2015 2:42 PM by MadEngineer
cslhilo Level 1 Level 1 (0 points)

Email messages from my tagged VIP's do not end up in the VIP folder.  They show a star next to them in my regular inbox, but my VIP folder is always empty.


iPhone 4S, iOS 6, VIP mail not working
  • jenkman61 Level 1 Level 1 (0 points)

    If you have a rule set up for a particular VIP it will not show up in iCloud or iOS. It will show in OS X mail.app. Delete the rule and it works. iCloud.com/mail click on settings gear and look at the rules. Delete the one that is a VIP.

  • cslhilo Level 1 Level 1 (0 points)

    I just want to use the vip function on my iPhone and iPad.

  • cslhilo Level 1 Level 1 (0 points)

    Looks like it might be an issue with my existing mail filters.

  • LK81 Level 1 Level 1 (0 points)

    Did you manage to get your VIP mails to work?  I've set up mine, but when the VIP mails me, I don't get the email on my phone at all.  I do receive this mail on the pc though...

    All the alert settings are fine.  I just don't get any emails, not even in my normal inbox.

  • MLadd Level 3 Level 3 (660 points)

    The VIP box is like a smart folder of "saved search" it has nothing to do with physically sending or receiving E-Mails from a user. That would be your E-Mail settings, or mail rules on your desktop/laptop client.

  • Verde Capucho Level 1 Level 1 (0 points)

    I am having this exact problem.. logged a call with Apple tech support yesterday.. even the Level 3 techs could not find a way to resolve.. yet..

     

    -R

  • philipjamesbowen Level 1 Level 1 (5 points)

    Do the emails from your VIPs go into your inbox, or are they filtered to another mailbox/label. On an iOS device the VIP mailbox only shows items in your inboxes. Even if they are cached in another mailbox. Therefore you won't receive notifications for them (iOS Mail only supports notifications for emails going to your inbox).

     

    On the Mail app on a mac you can change the notification settings so that Mail sends notifications for every mailbox though. (In Settings --> General).

  • pips7000 Level 1 Level 1 (0 points)

    same  here

    apple  support  not  good from apple

  • Verde Capucho Level 1 Level 1 (0 points)

    I have since found out the cause of the problem for me..

     

    I have custom rules that sort based on email sender's domain that router into sub-folders of the ibox and the VIP feature ONLY supports the actual inbox..

     

    the worst part of Apple support is that the software developers do not provide a manual to the frontline team and they are left to disover these "features" with the customer..

     

    nothing I enjoy more than paying for AppleCare and teaching the techs..

     

    -R

  • shayokoh Level 1 Level 1 (0 points)

    I found that after I unselected Organize By Thread in the Mail, Contacts, and Calendar settings , it started to work for me.

  • myhandmd Level 1 Level 1 (0 points)

    I used this workaround and it seemed to work for fixing the VIP problem.

    After deleting and killing as suggested, the iCloud Helper restarted and the cache repopulated with fresh ones.  I then clicked on inbox and back onto VIP's and they were all there!

     

    https://discussions.apple.com/message/25003487#25003487

     

     

     

    Try deleting the contents of ~/Library/Caches/com.apple.iCloudHelper and then kill the com.apple.iCloudHelper process in the activity monitor.

  • MadEngineer Level 1 Level 1 (0 points)

    If you're filtering a particular contact to their own folder you'll need to configure the push settings to also get push for that folder.  Settings -> Mail, Contacts, Calendars -> Fetch New Data -> tap the account -> tap the folder the contact's mail goes to (under "PUSHED MAILBOXES")

     

    Otherwise the device doesn't know about their incoming mail and will never show you their notifications as by default it only synchronizes the inbox.

     

    I've noticed that it seems the device won't sync existing mail to the VIP folder, only new mail after this is enabled