Previous 1 2 3 Next 33 Replies Latest reply: May 25, 2015 1:26 PM by fedtho Go to original post
  • rabman Level 1 (0 points)

    I had the same non-result as lunatic77.  The terminal entry worked fine until the latest update. 

  • La_Fouinard Level 1 (5 points)

    Found something that seems to sort mine. Reset the NVRAM (http://support.apple.com/kb/HT1379) and try the sudo command again in Terminal and reboot.

     

    Mine's now back to normal, the 10.8.2 update did mention something about a firmware update so I suspect that's what's knocked it off.

  • lunatic77 Level 1 (0 points)

    This worked for me also. Thanks!

  • Lindberg Level 1 (0 points)

    The procedure works until I restart the machine!  Does this happen to you too?  Now I try to do the resetting procedure again.  But it doesn't work any more.  Very sad.

  • rabman Level 1 (0 points)

    This works for me until I lift the lid of my MBP, then it is the same old thing.  And I had used the same Terminal command prior to the update and it worked fine.

  • sethde Level 1 (0 points)

    Same. Rebooting the machine causes breaks this for me. Running a sudo command and clearing the NVRAM everytime I reboot isn't going to work as a long term solution.

  • yectep Level 1 (10 points)

    I've whipped up a little plist for you all to add to launchctl so the command gets run on startup every time. You can download it here: http://stork.yectep.hk/public/iog_plist.zip (via Amazon AWS). To run it, copy the plist into /Library/LaunchAgents, then open Terminal and run the following command:

    sudo launchctl load /Library/LaunchAgents/com.personal.iog.plist

    To verify that it's there and will run the nvram command on startup, use:

    sudo launchctl list | grep 'personal'

    If you get an entry saying com.personal.iog is loaded then it's safe to restart your machine. Before login, your Mac will load that plist and run it.

     

    For those of you who care about security, the contents of the plist are as follows.

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

        <key>Label</key>

        <string>com.personal.iog</string>

     

        <key>OnDemand</key>

        <false/>

     

        <key>ProgramArguments</key>

        <array>

                <string>nvram boot-args="iog=0x0"</string>

        </array>

    </dict>

    </plist>

     

    Let me know if it works for everyone!

  • Thomas Brahe Level 1 (0 points)

    Same problem here. Clean Mountain Lion 10.8.2 install on mid 2010 MBP - external monitor only works when MBP lid is open. Otherwise just black. Haven't tried any earlier 10.8.x versions (coming from Lion 10.7.4).

  • Robottinosino Level 1 (0 points)

    Same issue here. "Upgrading" to 10.8.2 has broken a fundamental usage model of this crappy Mac. This company quality control is now useless (without Jobs?) Maps on iOS is also a joke, who the **** said "yes" to that product's QA?

  • Chip a Dee Level 1 (10 points)

    Guys there's a pretty simple solution to this, well it worked for me anyway. Since Mountain Lion it seems that sudo command no longer works for keeping your mac lid open but screen off and only using your external, also it now causes the external monitor to keep cycling in and out of sleep mode.

     

    So to be able to use your external while in clamshell mode as normal type this sudo command into terminal:

     

    sudo nvram -d boot-args

     

    Then reboot, plug your external back in and everything should be fine for using your external in clamshell mode. As for opening the lid back up for better airflow while using the external it seems the magnet trick is the only work around I can find at the moment.

  • quangtam2159 Level 1 (5 points)

    Was having the same problem... Searched on Apple... found this article and it worked. Easy and no hassles! Then  pressed detect and mirror displays... closed MacBook Air - blue screen then it worked!

    A small amount of your computer’s memory, called “parameter random-access memory” or PRAM, stores certain settings in a location that OS X can access quickly. The particular settings that are stored depend on your type of Mac and the types of devices connected to it. The settings include your designated startup disk, display resolution, speaker volume, and other information.

    Note: To print these instructions, open the Help Viewer’s Action pop-up menu (looks like a gear) and choose Print.

    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Immediately press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.Continue holding the keys down until the computer restarts, and you hear the startup sound for the second time.
    5. Release the keys.

    Resetting PRAM may change some system settings and preferences. Use System Preferences to restore your settings.

  • sjrlexlibris Level 1 (0 points)

    I was having the same problem.  Then I happened to plug in my external power supply and the problem went away.  In other words, I only have the problem if I am running my Macbook Pro on battery power.

  • RickAce Level 1 (0 points)

    This did not work for me (resetting PRAM)... I hope Apple brings back this functionality. All I want is to have my external monitor on while the MBP is open and the screen is off (for me it is mainly to hear the sound from the speakers better).

     

    Previous method used:

     

    1. Boot Computer

    2. Close top of MBP

    3. Wait for external monitor to flash off then it would come back on as only monitor

    4. Hit space bar on external keyboard

    5. Hear Superdrive cycle

    6. Open top of MBP

    7. MBP screen black and off

     

    Apple, please bring back this functionality.

     

    Thank you.

  • autnagrag Level 1 (45 points)

    I was also frustrated. Using 10.8.2 on my MBP 7,1, the sudo command to change the nvram boot-args worked for me for a while (from 10.8.0 through 10.8.2s), but for the past few days I could not get my built in display to be dark with the external display connected. I LOVE my trackpad and want to be able to use it when an external display is connected, but I don't want to manage multiple displays. Some servers I connect to (Citrix XenApps) have tantrums when they find multiple displays.

     

    Take a look at the freestanding app to enable closed clamshell mode written by Misha Cargal, called ReClammer.app -- he posts the code for review, in case you worry about this or that. https://mbcargal.wordpress.com/2012/08/10/reclaiming-clamshell-mode-under-lion

     

    After I ran this, my machine hung once at boot. I disconnected the external turned it off. Then, I booted the MBP, rapidly closing the lid, plugging in the cable to the external and powering up the external, all before the chime sounded. I opened the lid to select the FileVault2 user and enter the passphrase, hit return, closed the lid, and let the boot complete. I opened the lid -- recently a moment of frustration and hissed oaths -- and Voilà!

     

    I hope ReClammer works for other frustrated people.

  • autnagrag Level 1 (45 points)

    Whoops. This is in a MBA thread, and should be in a MBP thread. I do not know if this method works for the MBA hardware. I hope a moderater will move my post to its proper place.