Previous 1 2 Next 20 Replies Latest reply: Oct 22, 2012 9:25 PM by monolaker
BeamRider47 Level 1 (0 points)

Yesterday I updated both devices. (iPhone via iTunes, iPad via Air)

Both were capable of accessing the same WLANs befor the update!


the iPad had no problems after all, re-accessing them, but my iPhone4s since then is very picky!

It will only access the WLAN of a Deutsche Telekom Consumer-Speedport-Router, belonging to my father in law.


My own, "professional business" WLAN-Router (LANCOM 1821) can´t be accessed anymore.

I set up a few new different SSIDs with different encryptions, everything between WEP64 and WPA2.

At first I thought it might have to do with the encryption algorythms...but after having tryied all of these, I don´t think so anymore.

Result is always the same, the iPhone cannot connect to the network(s), while the iPad could access each and every single one without problems.

The alternative router, where it can establish a connection is also protected via WPA1/2.

I also tried to "reproduce" the settings and transfered the SSID and passphrase to my office router, copied the exact settings, but this didn´t help either.


I´ve tried every hint, tip and advise, that has been swirling around the net (except the one, where someone says, that You should put Your phone in the freezer for 30 mins. and it will connect again) but nothing has helped so far.

Wether it is reset of networks, turn mobile data off and on again...oh and by the way, for those who give the "clou" of "select Your Network, ignore it and re enter the parameters":

In Order to do so, You have to be connected to a certain network, to drop and ignore it...if You can´t connect to any network anymore, You can´t dismiss it!

I did not change anything in the original setup, which allowed iPad2 and iPhone4s to connect to the same networks.


So my thoughts are more and more down to an "artificially forced" chipset compatibility problem between certain manufacturers, caused by some code lines in the new iOS6 on certain devices.

At this moment this is my most logical thought on why after the update my phone can´t connect to a networks it has been running with ever since.


If anyone has any different ideas or solutions to pinch the iPhone back into the wireless, I´d be very glad to hear about.



with the best regards from Germany



iPhone 4S, iOS 6
  • BeamRider47 Level 1 (0 points)

    hmmm, has nobody a clue....or has to fight with the same problems?

  • Sk8Dreams Level 3 (855 points)

    Does your phone show the network, or do you get the "Unable to Join Network" message?  If it shows the network, then you can select it and do "Forget this Network".  One more silly thing to try, if you can see the network, but are unable to join, is to enter a deliberately wrong password, then try again with the correct password.

  • BeamRider47 Level 1 (0 points)

    my phone shows all the networks in my neighbourhood ;-)

    all the old ones, all the new SSID´s I setup for testing.

    Even when the WiFi is open, unprotected and not secured I just can´t connect to it.

    I did the reset of network settings now about 25 times, I can´t drop or forget the networks, because in order to forget or drop a certain connection You have to be logged into the WiFi/SSID...and since I cannot connect to them...round it goes, You see ;-)


    I just get the German-Message "Verbindung zum Netzwerk XXXXX fehlgeschlagen" i.e. connection with/to Network xxxxxxx failed.


    I also re-started my router several times, changed the WLAN channels, encryption methods, keys and changed/modified every little piece of stuff I could modify with no effect.


    also tryied the password tip (thx 4 that)...but with no success at all...sorry


    Since my 4s won´t even connect to totally open and unsecured WiFi-SSIDs I´m through with my knowledge, I don´t know what´s causing this...maybe I should consider putting it in the freezer :-D

  • svenbrencher Level 1 (15 points)

    I have exactly the same problem with the same router with both my iPad and iPhone. This is making my iPad completely worthless as it is not a 3G model. Hope Apple will give some feedback or fix that issue soon.

  • Christian Rank Level 1 (5 points)

    We have the same problem with iOS 6 and iPhone 4S (and iPad 3) connectivity on our campus Wi-Fi network. It seems to be caused by some additional data sent to the AP during the association phase. See my post at


    As a consequence, we have issued warnings to our users about the iOS 6 upgrade:[tt_news]=2529&tx_ttnews[backPid]=5518&cHash=d45ab790ec97be45cf614e9121521509

  • BeamRider47 Level 1 (0 points)

    well least I don´t have to doubt on my technical skills and understanding anymore or blame it on the meds :-D


    but seriously

    @Christian: Do You know what kind of WiFi-Chipsets are assembled in the HP-AP´s?! (Aegere, Atheros?)

    @sven: as I stated earlier: I blame it on the chipset interop between Phone/Pad and AP (as Christian´s mention hardenes my assumption)...and concerning apple´s reaction and flexibility:

    I wouldn´t count on that pretty soon! although they mentioned several teams being in "lockdown" state, I consider ourselves as "colateral damage", since the majority seems to have no problem with their consumer or CISCO AP´s :-)

    It would not surprise me, if they give out the advise to contact the AP manufacturer and ask them for a fix/work around...

  • Christian Rank Level 1 (5 points)

    @BeamRider47: According to my latest findings, it's not a chipset problem, but a different interpretation of standards: At least the iPhone 4S with iOS 6 sends a parameter "Extended Capabilities" in its association request to the AP. This "Extended Capabilities" parameter has a length of 4.

    Now, the "IEEE Std 802.11n-2009" states that this parameter should have only 3 as valid length. Contrary to that, the current "IEEE Std 802.11-2012" defines the valid length between 3 and 8.

    It seems that our HP/H3C equipment treats "Extended Capabilities" parameter length == 4 as fatal error and rejects the association (instead of just ignoring this parameter).

    From the formal point of view, Apple's implementation is correct, and HP should correct its firmware. We've got in touch with HP about this issue and are now awaiting their response.

    Nevertheless, I hope that Apple updates iOS 6 that no "Extended Capabilities" parameter is sent during association, since its purely redundant, as it contains just

        Tag: Extended Capabilities
            Tag Number: Extended Capabilities (127)
            Tag length: 4
            Extended Capabilities: 0x00 (octet 0)
                .... ...0 = 20/40 BSS Coexistence Management Support: Not supported
                .... ..0. = On-demand beacon: Not supported
                .... .0.. = Extended Channel Switching: Not supported
                .... 0... = WAVE indication: Not supported
                ...0 .... = PSMP Capability: Not supported
                .0.. .... = S-PSMP Support: Not supported
            Extended Capabilities: 0x00 (octet 1)
            Extended Capabilities: 0x08 (octet 2)
            Extended Capabilities: 0x00 (octet 3)
                ...0 .... = Peer U-APSD Buffer STA Support: Not supported
                ..0. .... = TDLS Peer PSM Support: Not supported
                .0.. .... = TDLS channel switching: Not supported

    Now, let's see what happens the next days ...

  • svenbrencher Level 1 (15 points)

    Found this info at the Lancom Forum and they are considering an update to the router:,63834,0872671cc011034e851de5092a3655f6.html

    Hopefully they will update their firmware.

  • No-Nonsense Level 1 (0 points)

    LANCOM has released a fixed firmware for the LANCOM 1821 Wireless router:

    iPad mit iOS 6 kommt nicht mehr ins LANCOM 1821 WLAN


    On my 1821 it works like a charm. Don't be confused because the version and release number did not change. The build number and build date did change.


    Greetings from Germany,


  • blockfish Level 1 (0 points)

    @Christian Rank


    We also have the same problem but since my client uses H3C kit at over 10 locations worldwide the problem is widespread. Any luck in getting a software update out of HP/ H3C for all affected units (AC: WX-5004, WX-5002, A-3000-10G-PoE+ and AP: A9952)?


    I've filed a case with Apple. Hopefully they'll let us know if they will patch iOS 6 or expect the vendors to instantly comply with the new IEEE Std 802.11-2012 that was just released in March 2012. I don't expect the Apple to move quickly in any case as they will need to go through their whole iOS release cycle for this, as I have little hope HP will move quickly for the same reasons (plus added delay as they have to relay this through H3C).


    When I hear Apple's stance on this I'll let everyone know. If someone else finds a firmware from H3C that corrects the issue please, please let us know. I'll do the same if I can get an update from H3C.


    Good luck out there,



  • Christian Rank Level 1 (5 points)



    A case has been opened by our reseller with HP. No information about a solution yet. I'll post an update when there are news.

  • Christian Rank Level 1 (5 points)

    We've got today firmware WX5004-CMW520-R2308P07 from HP support. Will test it next week during our regular maintainance schedule. I'll post about the results.

  • blockfish Level 1 (0 points)

    @Christian Rank


    We too have filed a case with our supplier and now are waiting on HP to get back to us. Unfortunately we need new firmware not only for the WX-5004 and WX-5002 Access Controllers, but the A-3000-10G-PoE+ Wireless Switch, and the A9552 Access Points. Hopefully they'll get back to us soon. I'll post my results as well as soon as I can get my hands on the firmware - unfortunately upper managers across ten sites have updated their iDevices (iPhone 4s and iPad 3) to iOS 6 and they are now very unhappy. The sooner I get the firmware the better, as I need to calm down the clammer.


    @Apple (I know they won't respond)


    Dear god, give us a way to manage iOS upgrades.

  • steve@merton Level 1 (0 points)

    We are experiencing the same issue here.  I would be "very" interested to know how you get on with the new firmware.

Previous 1 2 Next