Previous 1 101 102 103 104 105 Next 4,659 Replies Latest reply: Oct 29, 2014 11:58 PM by jasonb b Go to original post Branched to a new discussion.
  • Crowie85 Level 1 Level 1 (0 points)

    Mine also would connect to wpa and wpa2 networks but ceased to transfer any data after at the most two minutes tried several different routers worked absolutly fine on wep was able to demonstrate this to an apple rep in store on sunday in brisbane australia. They replaced the phone straight away without any questions. Still a little pi#%ed off that i had to drive two hours to th apple store to do this but the new iPhone 5 hey gave me works great so all is well now. While i was there i asked about this problem and was told the apple enginers know of this problem and think it is definately a software bug in ios 6. Also i made them aware of this thread and showed them it was quite a large issue. I recomend anyone going into store to do the same the more apple is aware the faster somthing might happen about it. (Hopefully)

    I hope everyone else is as lucky as me and can resolve this issue too.

  • farshadthebest Level 1 Level 1 (0 points)

    I did everything that was suggested in this forum. I tried WEP, WPA, WPA2, different channels, g, n, b, anything you name it, none of them worked. Decided to do a root cause analysis and found out that the iPhone 5 does not renew its IP lease and therefore timing out after 30-60 seconds. Timing out has nothing to do with wireless technology (b, n, g) or the security mechanism you select (WEP, WPA, WPA2, AES, TKIP, ...). It's a network layer bug (IP related stuff, there must be a bug in the iOS 6 software). Don't return your phone because this is not a hardware issue, it's a software bug and hopefully will be fixed in next update.


    So here is the workaround I used to fix this issue:

    This is how my iphone was connected to Internet before:

    iPhone 5 --> Access Point(D-Link DIR 505) --> Router (CISCO) --> Internet


    I had the luxury of switching my Access Point to a Router so now here is my setup:

    iPhone 5 --> Router(D-Link DIR 505) --> Router (CISCO) --> Internet


    I set up my D-Link Router to start IP from instead of, just to not confuse the two networks created by the two routers. Both routers are using DHCP and my iPhone MAC starts with 88:53:

  • Luc Vanhoorickx Level 1 Level 1 (0 points)

    I already noticed my iPhone 5 wifi connectivity issues when it was taking longer at the office to connect to the wifi network then it used to do on my iPhone 4, but didn't mind too much.


    Now I'm really sure it has a serious issue as at home when playing video to AppleTV using AirPlay, the video keeps on dropping or crashing, like the wifi signal is not stable or fast enough. When playing the same video, either from internet or saved on the device, with my iPhone 4 (that I still have, present for my wife ;-) it works without a problem. Same iOS 6, all things equal except for the phone.


    I just can't seem to make it work properly on my iPhone 5. I tried stuff in this forum, including changing my (Linksys E2500) router setting, switching off Bluetooth, etc. Nothing works, just very bad wifi connections. I almost want my iPhone 4 back – it’s slow but at least working properly.


    Then I was thinking… as iPhone 5 is the first one to be able to use the 5Ghz channel, which is supposed to be less crowded but at the same time it has less range, I thought maybe that’s the problem: my iPhone 4 using 2.4Ghz doing it fine, but my iPhone 5 using 5Ghz might not get enough signal with the one new antenna. So I created two wifi networks on my router, one for 2.4Ghz and one for 5Ghz, and choose the 2.4Ghz one on my iPhone 5 hoping it would now connect and stream over wifi properly like it did on my iPhone 4 using the 2.4Ghz channel. While I have the impression it’s a bit better, it is most definitely worse than the iPhone 4, and totally not bearable to watch video, too frustrating that it drops every other minute.


    So I don’t know, I just fear it’s indeed a hardware issue: the iPhone 5’s new wifi combined antenna just being weaker than the one in the iPhone 4, a compromise for a thinner lighter model?? It’s disappointing, just keeping fingers crossed for a software update that might resolve the issue. Or does somebody has another solution to try out?


    Cheers, Luc.

  • JonnyITokyo Level 1 Level 1 (0 points)

    To do some more close benchmarking I decided to download a file (about 49 MB) from internet through WIFI to my previous iPhone 4, and my new iPhone 5. The internet connection in the back is pretty/normally fast and the iPhone 4 ends the download after a couple of seconds or tens of seconds. The iPhone 5 takes minutes maybe ten or fifteen minutes... remember I told you my iPhone 5 gets around 0.3 Mbit/s down in an earlier comment. This is on a secure network (WPA2, not possible to see/alter AES or anything like that on this FON router).


    So I shut off the password making the WIFI totally open. Reconnected both devices. Downloaded the same file. I get the exact same/similar download speeds. iPhone 4 downloads normally/fast. The iPhone 5 has serious troubles.

    I can't still say for sure if this is an iOS bug or not - the iPhone 4 is running iOS 5. I am leaning towards hardware problem though.


    So I'll just reiterate. The password protocol probably has nothing to do with the problem, at least not in my case.

  • bcbishop90 Level 1 Level 1 (0 points)

    iPhone 5 16gb, connects to any wifi network but does not open anything or download or upload.

    It will work for a couple seconds when you connect but then doesnt work at all. (still will show it is connected to wifi)

  • JonnyITokyo Level 1 Level 1 (0 points)

    That article does not cite any sources.... Any real link to that acknowledgment would be necessary.

  • V_77 Level 1 Level 1 (0 points)

    Guys, my problem is SOLVED!


    Wherever I go, I have good wi-fi reception with my iPhone 5. At my parents or sisters house, reception is fine. However, at home it was really poor, around 1Mpbs.


    What did I do to solve the problem?

    I changed the AES encrpytion from WPA2 to TKIP, and now I get 22,9Mbps :-)

  • schneiks Level 1 Level 1 (0 points)

    This is my first time ever posting in here, but I'm furious too that my iPhone 5 loses wifi signal on my WPA2 network after just a few seconds.  Then no data is transferred at all.  It works perfectly on non-secured networks.  I have an appt with the Genius Bar in a couple hours, but **** I'm ******.  My Address begins with 88:53.


    Glad I spent $300 on a phone that can't even connect to the internet at my house.

  • sethmark Level 1 Level 1 (0 points)

    Try this...


    Go to Settings > Safari > Clear history / Clear Cookies and Data.  Then reboot. 


    For a ridiculous as it sounds, my wifi came back wide open as soon as I tried that fix.  This phone is the replacment for the first one that had the exact same problem.  It worked great for a week then stopped.  This worked perfectly. 


    Worth a shot and 2 seconds.


    I went from ZERO wifi to 30 mb/s downloads.  One change. 

  • AustinGreen Level 1 Level 1 (0 points)

    darn.  This didn't work.   While the phone would come out of lock and find the wouldn't connect to the internet.   I would open the phone and clearly see 3G for a second and then the SSID would pop up as if it just found the network but it wouldn't establish a reliable connection.   **** Apple.  Fix your POS.

    AustinGreen wrote:


    Ok, I also have the same exact WEP issue.  I'm trying your fix now.  So far so good.  I'll ck back in an hour.  If we make it through an hour you are a STUD!

    BSalita wrote:


    Sweetness. I discovered an almost perfect fix for my iPhone 5 WiFi issue. The 5 would not remember the WEP password. I had to re-enter it every time. After the fix it always remembers the password -- except after a reboot.


    Here's the fix: Settings->Wi-Fi->Choose a Network...->Other (yes, deliberately ignore the shown SSID)->Name (enter your SSID)->Security->(enter your security type)->Other Network (to return to previous screen)->Password (enter your password)->Join.


    Voila. My 5 now remembers the password every time.

  • Kimberly Seiz Level 1 Level 1 (20 points)

    Nothing to add, but I've noticed that when I get the full 3 bars on my WiFi, I get "No Service" under my Cell. When the WiFi goes down to 2 bars, I will get one or 2 bars on the Cell. Hmmmmmm

  • karlos8744 Level 1 Level 1 (0 points)



    Finally thanks to people posting on here my issues MAY be resolved.  I embarked on the following:


    I updated the my Netgear router with the very latest firmware and changed security to WPA 2and this solved the connectivity with my iPad 2 which had been 'upgraded' to IoS6. 


    For my iPhone 5 i entered the router SSID and password manually and it now seems to retain connection and remember my phone whenever I return home. 


    Fingers crossed this will be a temporary fix until Apple address the issue in more detail.

  • Patsywright Level 1 Level 1 (0 points)

    My first iphone 5 started with 88:53 tried everything would not work. Got a new iphone 5 wifi Address 98:FE works great. My friend has the same iphone5 wifi Address 88:53 will not work. I really think Apple put out some bad iphone they should just work right out of the box. If you get a new one  try to look at wifi address before you leave the store.

  • Bryen67 Level 1 Level 1 (0 points)

    YOu know your  problems is the same as mine. I've had issue with my home WIFI not connecting to my new iPhone 5 for weeks.  I've try a lot of things like going out to a different place to try my phone to connect to a free wifi hot spot. Some place will connect to my phone , and some doesn't . And I even compared my phone to a sale person who workd at the radio shack store too and his phone connected to the wifi in that store and also work at his home and my phone doesn't connect to the same wifi.

    Why ????. Just about more then a week my DATA USAGE IS OVER THE LIMITED. So yesterday 10/8/12 I got a new replacement phone. Now I'm try to connect to my home wifi and it doesn't wanted to connect to it . But when this new replacement phone finally connected to my home wifi , it was really slow and kept dropping out of my wifi and at the same time my iPad 2 , iphone 4, 4s are working fine. I even test it to the public free wifi hot spot in the store and it's keep dropping out and really slow too.  Video load really slow. This replacement phone works a little better then the old one.  When I called Apple support they said may be it is home wifi and even suggested to update the firm ware on my router. It doesn't make sense to me. This iPhone 5 can connected to some wifi hot spot but not connect to my home wifi and why the think its my wifi problem. Like you and me and a lot of folks who complain about this wifi problems. you were right.  It is not our problems to try to fix all these , It's the apple problems.  WE PAID GOOD MONEY AND GET STUCK WITH A CONTRACT AND APPLE WHO GETS THE PROFITS AND THIS IS WHAT WE GOT THE JUNK STUFF.... Apple please fix it soon. Thank you

  • Cesar Dario Level 1 Level 1 (0 points)

    Totally agree with you! It's really disrespectful to the Apple user. It shows that Steve Jobs is no longer the Head-company.