Previous 1 3 4 5 6 7 Next 4,659 Replies Latest reply: Oct 29, 2014 11:58 PM by jasonb b Go to original post Branched to a new discussion.
  • AndrewCapon Level 1 Level 1

    Same issues here for me trying to connect tp WPA/WPA2, connects fine, full signal. Dies after a few seconds.


    Works with WEP or no security.

  • KJF18 Level 1 Level 1

    I have exactly the same situation as Joe Winn. iPhone 4S, iPad 2, various laptops all connect to wifi with no problem. iPhone 5 connects only if within a few feet of the router. If I walk only a few feet (like less than 10) away from the router, the iPhone 5 drops the connection. Have tried it at two different locations, with separate networks and different brands of routers, with same results. Have tried the various remedies suggested in this thread to no avail. Not even turning off all security on the router helps. Feels like an antenna or other hardware problem.



  • LNGU Level 1 Level 1

    same problem here. joing belkin dual band n network shows signal 0. it seems working through the router but after reading some posts, it might be just going through 3G. not sure.

    and I don't know what Apple used as 3G chip. it's slower. side by side comparison with 4GS on a same carrier. please update soon.

  • dsg76 Level 1 Level 1

    Possible solution:  My D-Link 655 router was set to 20MHz/40MHz in the "Channel Width".  


    I changed that to 20MHz, and left the phone for a few minutes.  


    I was still connected and working fine when i used it again.   So far this has worked for me.   Hopefully this will help you guys too until Apple releases a fix. 

  • OneMoreAnimal Level 1 Level 1

    Same problem with WPA2 here. Got extremely slow speeds (around 500 kbps), changed to WEP and now get 8+ Mbps. iPhone 4 and iPad 3 speeds are good on both WEP and WPA2.

  • Singx2 Level 1 Level 1

    Apple needs to respond/address this issue quickly. Is this a hardware issue or a software issue...any network engineers out there that can give their 2 cent regarding this matter?...Can a hotfix on the iOS fix this issue.  This is obviously not an isolated incident. With the inconsistency of the wifi problems surrounding iOS 6 and the iPhone 5s, it won't surprise me that it can be BOTH.  I'm going to take mine back tomorrow for an exchange to see what happens.  How can you mess up WIFI Apple!

  • Goldi0812 Level 1 Level 1

    I restored my iPhone and now it works fine with my wifi connection now.

  • iBryan85 Level 1 Level 1

    I tried that same thing, and I still had the issue. For me, it's all related to WPA.

  • Goldi0812 Level 1 Level 1

    Thats weird. Because mine is WPA2 and its working. But what i did find really weird is that when i put my iPhone on top of my router like some people said they were doing here and for some reason it restarded my router and it didnt want to turn on for a little bit.

  • David Pearson Level 2 Level 2

    Well i'm joining the game sadly.

    Wifi on then nothing reconnect on then off again...


    Using BT hub in UK

    So reset phone to factory

    Forced hub to WPA2 only

    forced hub to Channel 2


    2 hours in seems to be working.


    if anyone comes across anything working tweet me @allmec please.


    Other wise LOVE the phone

  • vasquez40 Level 1 Level 1

    I have the 4S in having the some issue it started after I update the new software. iOS 6.0     Apple need to fix this NOW

  • dbslayer Level 1 Level 1

    Same issue for me too.  Using WiFi and WPA2 on iPhone 5 and it is so slow it is not useable.


    Turned off WiFi for now and using LTE from home which is REALLY fast!


    Please fix this Apple!

  • Fridgey Level 1 Level 1

    I've been having problems as well with my iPhone 5. I have a Billion 7800N router (2.4ghz only) and an Airport Extreme (dual band). All of my apple devices (including my iphone 5) will connect to the Billion and surf the web happily. However my home Home Sharing does not work between any of my devices. If I use my Airport Extreme all of my devices, except my iphone 5, can happily surf the internet and I have Home Sharing working.


    Interestingly my iphone 5 will happily do home sharing with the Airport Extreme but the web refuses to work (again all other devices have no problems accessing the web). I would be interested to see if this is a dual band issue.

  • David Pearson Level 2 Level 2

    Speedtest on WPA2 1mb

    Speedtest on WPA 6mb


    well I know how to configure my set-up it is clearly a WPA2 authentification issue...


    Cheers folks thread gave me the pointers

  • hudsonmanx Level 1 Level 1

    Same issue here in the UK, got my iPhone 5 64GB yesterday, try connecting over wireless with WPA/WPA2 and no go just will not download anything is like going back to an old 56k modem.


    I setup another wireless SSID on my Draytek router only this time with WEP and 128bit key, connected the phone and works.


    So clearly either a software fault with iOS6 or I hope its not hardware related, my iPhone 4S on iOS6 worked fine on WiFi with WPA/WPA2 so must be an issue with iPhone 5 handsets only.


    Hope Apple can fix this as it's disappointing to get a phone and then have to alter all your network just to get the phone to do what it should.


    Glad I found this thread was spending hours last night trying to figure it out.

Previous 1 3 4 5 6 7 Next