Previous 1 5 6 7 8 9 Next 4,661 Replies Latest reply: Oct 29, 2014 11:58 PM by jasonb b Go to original post Branched to a new discussion.
  • opmisk Level 1 Level 1 (0 points)

    Same problem here. If a create a guest network with no security, wifi works perfectly. But as soon as I connect to a wpa2 enabled network, my connection becomes very unstable... will work for a few seconds and then drop. Oddly, my wife's iPhone 5 is functioning perfectly when connected to our wpa2 enabled network.

  • Bigfish212 Level 1 Level 1 (0 points)

    Im using a BT home hub new revision and have a similar problem. Connected fine then suddenly im knocked down to 3g, few minutes later it reconnects. Have just forced WPA2 and forced channel 2 as advised above and will see how that goes.

  • Bigfish212 Level 1 Level 1 (0 points)

    Also I get 28mb wifi speed test on Bt home hub WPA and 44mb on forced WPA2

  • tobyfromsanta clarita Level 1 Level 1 (0 points)

    I found that joining the network by choosing "other" (not your network name in the list) and adding the details by hand solved it. I was getting horrible Wifi speeds  and I have a 50 meg connection but all is dandy now. No idea why.

  • John Laury Level 1 Level 1 (30 points)

    Well, it's not a hardware issue, here's how I got it to work:

     

    my iPhone 4, which connects fine to to my Linksys WRT54G shows this when examining the connection:

     

    IP Address             192.168.10.101

    Subnet Mask          255.255.255.0

    Router                    192.168.10.1

    DNS                       209.18.47.61,209.18.47.62

    Search Domains      neo.rr.com

    Client ID                  (blank)

    ------------------------------------------------------------------------

     

    When I try to connect with my iPhone 5, I never get the checkmark, just a continuous spinning indicator, and when I look at the connection I get:

     

    IP Address               169.254.228.34

    Subnet Mask            255.255.0.0

     

    Router, DNS, Search Domains and Client ID all remain blank.

    -------------------------------------------------------------------------

     

    What I did was set the IP address from DHCP to Static, and manually input the next host address (192.168.10.102), then manually put in the same info from the iPhone 4.

     

    I did nothing to the router which is set to WPA Preshared Key (TKIP)

     

    Voila, it connected right up to the router and started working over wifi.  I'm positive it was a wifi connection as I was getting 20 Mbps speeds with SpeedTest and I was watching TV with my TWC TV cable app (which streams my cable to the phone over wifi), wifi indicator on... I'm only in a 4G (not LTE) area, so it can't be an HSPA connection (I'm only getting 5 Mbps over cellular in my area).

     

    I don't consider this a "fix" because I want to be able to connect to other WIFI sources, but I was able to get it working at least, which means it's NOT a hardware issue.  Hopefully Apple will fix this software issue sooner rather than later.  I would assume so since the "anti-Apple" community dives on any Apple issues and makes a huge deal out of nothing.

  • Lon Seidman Level 1 Level 1 (5 points)

    I think the problem goes a little deeper than just a DHCP issue.  I'll be connected and working fine for a brief period of time and then the iPhone just stops communicating via Wifi even though it's still connected and has an IP address. The only way to resolve it is to completely reboot the phone which is something I've done now at least 5 times since yesterday. 

  • rmellio Level 1 Level 1 (0 points)

    I have the iPhone 5 and it can only connect to WIFI when it is within 1 meter of the router or connected to a hot spot from my old iPhone 4. No problems with my 3 iPads and 3 other iPhones, all connect to WIFI with stong signals with no problem. Only iPhine 5 won't work. Have set up as NEW phone, reset; set up from backup of my iPhone 4, reset it twice and still no WIFI. Not happy Apple! This is Apple's fith gen iPhone, surely the bugs would have been worked out by now! They have this same issue nealy ever release.

    Fix or new phone please Apple.

  • AndyDoc80 Level 1 Level 1 (0 points)

    This is exactly the same issue I get - sitting in the same room as router I have wifi signal - moment I leave the room, wifi drops off and can't even see the network - I'm literally 2mtrs away - this is stupid!!!!

  • dsg76 Level 1 Level 1 (0 points)

    Again, this FIXED it for me-

     

    My D-Link 655 router was set to 20MHz/40MHz in the "Channel Width". 

     

    I changed that to 20MHz, and left the phone for a few minutes. 

     

    This fixed it for me.  Even the next day.

  • Pachmielas Level 1 Level 1 (0 points)

    My iPhone 5 connects to hub no problem but its ultra slow browsing iPhone 4S

    Was 2x faster

  • Lon Seidman Level 1 Level 1 (5 points)

    My gripe is that I'm using Apple's Airport Extreme. On each boot of the phone I'll get connected for what amounts to a single download of a web page and then it goes into limbo until I reboot the phone. I'm fully connected with an IP address with decent signal strength too.

  • Lon Seidman Level 1 Level 1 (5 points)

    Just an update  -- turning off WPA encryption appears to the resolve the issue.  I'm now able to connect with a reliable connection using my Airport Extreme's guest network with WPA turned off.  Hopefully this gets resolved soon.

  • aligrace Level 1 Level 1 (5 points)

    thats weird lol ive had to change router settings from wep to wpa for mine to work and added the router name manually on my iphone 5 now it works fine,before if i turned phone off then on i had to put key back for wifi all the time 

  • macvol88 Level 1 Level 1 (5 points)

    Alright, just went to the Apple store. They confirmed that the issue regarding poor network performance on WPA/WPA2 protected wireless networks is a hardware issue. They swapped my black iPhone 5 16GB for a new one, and the new one works flawlessly on protected WiFi.

     

    I suggest people that are experiencing this issue visit an Apple store close to them as soon as possible, because replacements are limited.

  • Jonathan Young Level 1 Level 1 (45 points)

    Any idea how to tell if they have stock of a particular model? It's about a 90 minute round trip so I'd hate to do it for nothing...

Previous 1 5 6 7 8 9 Next