Previous 1 2 Next 22 Replies Latest reply: Nov 9, 2014 11:57 PM by Hugligan
tcpudp Level 1 (20 points)

Original post:


Just installed 8.2 and the new Server and now my Jabber server will not start.


It just says can't read settings in the ui and at the command line I get:


jabber:error = "CANNOT_LOAD_BUNDLE_ERR"


ML Server is pretty awesome but it's been a disaster so far for me. I am thinking if I could just find the settings file maybe it's corrupt and I can force it to recreate them.. ?


Mac mini Server (Mid 2011), OS X Server
  • Erich Wetzel Level 2 (320 points)

    Same experience here.


    Took advantage of backup made before update.  Returned to 8.1.

  • rsweeneyjci Level 1 (0 points)

    10.8.2 completely hosed my server.  Everything was running great on 10.8.1.  Updated to 10.8.2 this morning, now Jabber doesn't work ("Error reading settings") and I can't send/receive email.

  • BisonMac Level 1 (0 points)

    I had the same problem, installed OS X Server 2.1 and the jabber server quit working.


    What, I did that fixed it.


    Removed Server app from the applications folder.


    Restarted the server.


    Reintalled Server app using App Store.


    Launched Server app and followed the configuration wizard.


    Did nothing until the progress wheel quit.


    At that point Calendar and Messages services were not running.


    Selected Calendar and restarted the service, again I waited until the progress wheel was done spinning.


    Selected Messages and re-started the service, this time jabber is running and clients can connect again.


    Hope this helps.

  • Mark23 Level 3 (975 points)

    It appears as if there is a problem with permissions:

    I can't edit user or group permissions to access services on the server via ARD.

  • Mark23 Level 3 (975 points)

    I use server monitoring to monitor my servers and since the upgrade I'm being flooded with a vast majority of messages stating my server is down, sometimes alternated with a message a server came back up.


    The port it monitors on is 5223 TCP as I use a wildcard SSL certificate and the monitoring is set to Robust from Sensitive, but that didn't seem to aid my problem anyway...

  • Mark23 Level 3 (975 points)

    I have Messages working on a machine where I did nothing special, I only upgraded to the new version of server (2.1). So it seems that one server does and the other doesn't get through the update very well...


    On the server where I moved my Messages service I did reset the host name (to another name: from to and made sure that the reverse DNS (rDNS) is properly set both on IPv4 and IPv6. So I actually dedicated the machine to Messages and it seems to work


    When upgraded to 10.8.2 and server 2.1, I made sure that the SSL settings for all services were reset since some were altered during the upgrade.

  • Miggl Level 1 (75 points)

    This solution worked for me, thanks!

  • Dan-Grenada Level 1 (0 points)

    I have the same problem. I do think that for a server update Apple have made some serious errors. Please please please Apple try these updates out before sending out for people to use!!!...


    The update:-

    • Turns OFF most of the services which I configured, its easy to turn them back on but why doesn't the update?
    • I now have no Messaging service - Error Reading Settings.


    Do I remove the server app and do as it says above (my server is in Grenada and I am in the UK so I cant just plug in a keyboard locally, etc.) or do I go back to a backup?



  • rsweeneyjci Level 1 (0 points)



    I had the EXACT situation you've just described.  When I started my services (Calendar, Contacts, Mail, and Messages), none of them worked properly. 


    After trying numerous things to get it working, I ended up quitting the Server app, trashing the "/Library/Server" folder and then I restored a copy of the "Server" folder from Time Machine that had backed up approximately 1 hour prior to running the 10.8.2 update. 


    I rebooted after restoring the "Server" folder and then launched the Server app.  Everything worked normally after that...and has been working great for serveral days. 



  • Dan-Grenada Level 1 (0 points)



    I am going to try it and let you know...


    By the way - I kept one of my servers to the older Mountain Lion Server standard. I just updated it remotely and its fine - in fact it always is... It seems so much more solid (and still has WebMail)...


    I do think with Mountain Lion Server it felt more like playing with Meccano... Now with OSX Server it seems more like Stickle Bricks ;-)





  • Dan-Grenada Level 1 (0 points)



    No luck, just did exactly as you tried and its all working other than Messages - Still says Error Reading Messages.


    I know the restore is good as I sent myself an e-mail (just before restore) and this was not there after the restore.


    Any clues what to do next by chance?





  • Miggl Level 1 (75 points)

    Hi Dan,


    I did not go the restore-from-TimeMachine route, but instead, did the following:

    1. Turn off Server app.
    2. Go to Applications, drag Server app to Trash.
    3. Empty Trash (may be important).
    4. Reboot server.
    5. Install Server app from App Store.
    6. Enable each service one by one, each time waiting until the cog is finished processing before moving on to the next service.


    This worked for me first try.


  • rsweeneyjci Level 1 (0 points)

    I didn't do an official "restore".  I manually copied the folder from the TM backup drive into the Library folder while logged in as root.

  • Dan-Grenada Level 1 (0 points)



    Its sorted. I deleted the Server app, emptied the bin (important to do), restarted - re-installed the Server App (with my Apple account password) and - hey presto after being patient it all worked OK.


    I think I know what the problem is...


    If you buy the Mac Mini (or other server machine) with Server App on (pre-installed image), it gets confused when doing the update. This is because the pre-installed Server App has a different update account setting (other than say apps you purchase with your normal iTunes account and what you are probably logged into) - for some reason this screws the permissions up. I also purchased OSX Server APP for another machine, so once I installed the Server app again with my correct purchase details from the app store - the permissions were all OK and it worked.


    I think that may be it...


    Cheers for all your help - I am smiling again and can now watch a movie with a glass of wine in peace ;-)



Previous 1 2 Next