Previous 1 12 13 14 15 16 Next 628 Replies Latest reply: Sep 6, 2014 11:42 PM by sbock Go to original post
  • andre.s Level 1 Level 1 (0 points)

    Deactivating spotlight using 'sudo mdutil -i off /'

     

    Currently, I'm in the restoring data with the migration tool ;-)

  • macony Level 1 Level 1 (0 points)

    Downgrade as a solution

     

    To downgrade from 10.7.5 to 10.7.4 first I install Lion 10.7 then I updated it to 10.7.4 by combo update.

    I've found two issues so far.

    After downgrading Safari need to be replaced by these from original 10.7.5 distribution (I mean the whole Programs/Safari.app directory). There is also an issue with iPhoto - it should be replaced by that which comes from 10.7.4, Beware the iPhoto requests to recreate your iPhoto library (hopefully I am a man who does not use iPhoto)

  • Larry Nolan Level 2 Level 2 (175 points)

    I"ve been running OK by stopping Spotlight everytime I want to do a Time Machine backup.  The backup runs quickly and then I start Spotlight again in 10.7.5.  Though I've had talks with Senior AppleCare advisors, Engineering hasn't offered a fix yet.

     

    I'm going to buy a 8GB USB flash stick to put the 10.8.2 Installer on and then will backup once more with Time Machine to a external drive and create a clone of the Macintosh HD on a separate external drive so I have all the OS X stuff of 10.7.5 as well as some user directories that don't get backedup by Time Machine (iTunes library, a couple VMs, Download folder, etc.).

     

    Next step is to run the 10.8.2 installer under 10.7.5 and assuming it works, see if 10.8.2 works for me and Spotlight and Time Machine run nicely.

     

    If there are problems with 10.8.2, then what I will do is to use the Recovery partition and have it restore my Mac from the last 10.7.4 Time Machine backup.  I will use SuperDuper to restore the /Users/ directory files from my 10.7.5 clone so my user files on the Mac matches what I have on 10.7.5, and then reinstall and applications that are different from my last 10.7.4 (done on Sept. 20). That will give me an up to date 10.7.4 until Apple comes up with a fix to the Spotlight-Time Machine glitch.

     

    My big error was not having my usual system clone up to date with 10.7.4 before installing 10.7.5.  My clone is of 10.7.3 (somehow I had not updated it after updating to 10.7.4).  So I have a 10.7.3 clone, a 10.7.5 clone and the Time Machine backups available to me.

     

    As Monty Python crew said...."no one expects the Spanish Inquisition" (from Apple).  Lesson learned.

  • Larry Nolan Level 2 Level 2 (175 points)

    Change: I plan to use Migration Assistant to bring in the user files from the Super Duper clone of my 10.7.5 current system - I think.

  • poflynn Level 4 Level 4 (1,300 points)

    What worked for me was disabling Spotlight, running Time Machine, then reenabling Spotlight (since I do use it). We'll have to wait for the (hopefully forthcoming) fix from Apple.

  • poflynn Level 4 Level 4 (1,300 points)

    Thanks for the info AMH. Spotlight did disable (at least to the point of only coming up with webpage results for whatever I entered) Time Machine ran lickety-split, and I reenabled Spotlight. It took a very short time to re-index.  Now let's hope Apple will bother with the Lion fix since they're on to Mountain Lion now.

  • michaelfromseal beach Level 1 Level 1 (0 points)

    FYI, Apple techs had me run an archive and restore tonight, effectively reinstalling Lion 10.7.5. Seems actually to have resolved the problem. Spotlight did complete reindex in about 80 minutes; TM took a couple of hours to do first backup of about 9 GB, but subsequent backups went at light speed. Problem solved? Cross your fingers.

  • norbertm Level 1 Level 1 (0 points)

    That looks promising. Could you, for the sake of us other "victims" detail the sequence of steps you used? Did you have to go back to 10.7.0 first, disable Spotlight or imemachine, etc.?

  • Venares Level 1 Level 1 (0 points)

    Apple techs had me run an archive and restore tonight, effectively reinstalling Lion 10.7.5.

     

    Would you tell us what you have done in detailed steps, please?

  • NeilHobbs Level 1 Level 1 (15 points)

    That sounds good.  Have Apple Support acknowledged the issue now?  Did they make any comment on what is going on?

     

    If you can confirm the steps that you went through, I'd be much appreciative.

  • Alf Megson Level 1 Level 1 (95 points)

    That's strange because Time Machine only started to run extremely slowly AFTER I had re-installed 10.7.5.

  • Mark_W_ Level 1 Level 1 (0 points)

    Hi,

     

    So here is what I did (seems to work for now - but still in progress).

     

    1. I restarted my Macbook pressing Control+R to get to the Recovery partition.

    2. Clicked Disk Utility and performed Disk Repair and Permissions Repair

    3. Clicked Reinstall Lion

     

    Here I hit a problem. I got a message that waiting time for the process (downloading additional packages) is 121 hours and 43 minutes. Luckily I had a bootable version of 10.7.5 on a USB stick (you can download Lion from the App Store if it is faster).

     

    4. I restarted MB while pressing the Option key to boot up from EFI USB drive

    5. Reinstalled Lion

    6. Once MB restarted after 35 minutes of installing I downloaded updates (Safari, iTunes)

     

    In the meantime Spotlight started indexing the Macintosh HD. Initially it was taking forever to estimate time (about 30 minutes) then Spotlight came up with 5 hours estimated completion time (not bad, considering it was at 7 days earlier). After one hour from initialization it was about 15% complete and ETA was 7 hours. It limped like that for 30 minutes to about 25% complete and then accelerated suddenly. After another 30 minutes it was 80% complete with ETA 35 minutes, got stuck there for 10 minutes and finally raced towards 100% in 5 minutes. So overall it took 2 hours and 15 minutes to completion. (BTW I have over 1 million files). This doesn't mean that yours will go the same way but I wanted to illustrate that Spotlight seems to struggle every now and then throughout the process.

     

    I haven't done TM yet (before it was super slow - 20 kB in one hour, few hours later stuck on 121 MB out of 9GB of the total update. I will keep you posted on the progress, but I am hopeful.

  • Mark_W_ Level 1 Level 1 (0 points)

    Update:

    Time Machine seems to be back to normal as well. It still hangs up every now and then for a few minutes but it is way faster than before.

     

    First a disclamer: I recently moved to a new drive in my MB and performed 'tmutil associatedisk' to continue with my old backups. This may result in a slower initial backup, even in normal circumstances.

     

    After starting TM backup (over USB2), it took initially 30 minutes to prepare the backup. Currently, 40 minutes after an actual transfer started, it shows 1.84 GB out of 10.33GB total. I consider this a major improvement over the previous attempts (20 kB after 1 hour).

     

    To reiterate, reinstalling Lion solved my Spotlight indexing (completed in 2:15) and TM problem without a need to turn off Spotlight to backup. It may not work in all cases, but maybe will help some of you too.

  • Alias Mike Howard Level 1 Level 1 (5 points)

    @Mark_W_ would you please go to the About This Mac and verify that you are now on 10.7.5?

     

    I ran the reinstall proceedure on both my MBA and iMac and they are now on 10.7.4. without loss or damage to my files. I have a shared DSL connection and the reinstall took about 4 hours or so on each machine (the first estimate was way off, as was yours). Of course I made a full backup of each machine prior doing this (with mds off).

     

    Now backups are 'back to normal'.

     

    NOTE: I was surprised to see that reinstalling the operating system reverted to 10.7.4 rather than 10.7.0, but that's what happened in both cases when I ran it. (remember: it downloaded the OS over the network, so it appears that Apple's idea of a re-install is the previous version - can anyone verify this?)

     

    as always, your mileage may vary.

  • Mark_W_ Level 1 Level 1 (0 points)

    About this Mac shows 10.7.5

     

    Like I've said - I had a problem downloading Lion from the Rescue Partition (I have a 2007 MB). I downloaded a new veriosn from the App Store, made a bootable USB drive and reinstalled from it.

     

    BTW, after 1 hour 30 minutes from the start of TM transfer (2 hours from initiating the backup) I am at 4.31 GB

Previous 1 12 13 14 15 16 Next