Previous 1 19 20 21 22 23 Next 628 Replies Latest reply: Sep 6, 2014 11:42 PM by sbock Go to original post
  • Bakerchief Level 1 Level 1 (0 points)

    Txs Bruno. Did as instructed but had to reboot. Started TM again and was alarmed when eta was 74,312 days - 203 YEARS!! However, it seemed to settle down quickly and I am now at the 3 hour mark. Funny though, the back up size has gone down from the original 207GB when I was running spotlight, to 181GB. Does spotlight eat up all of that memory?

  • Bakerchief Level 1 Level 1 (0 points)

    Thanks. I used Bruno's tip this time and it seems to have worked. However, when TM is finished I'll enable spotlight again but next time I use TM I'll try your method.

  • Mr Humphries Level 1 Level 1 (0 points)

    NeilHobbs wrote:


    This evening, I performed the following to try and resolve this (with Spotlight disabled);


    1. used Onyx to reset the Spotlight cache

    For those who don't feel comfortable using the Terminal, Onyx allows turning Spotlight on and off and deleting indexes. The annoying thing is that the first time it runs, it automatically verifies the OSX disk. This can take a long time and slow the machine to a snail's pace. For my sanity, I had to disable this is in the prefs.


    Screen Shot 2012-09-30 at 12.18.38.png

  • Mac From Start Level 1 Level 1 (0 points)

    I wasn't even sure which post to reply to in order to join this thread.  I picked one that referred to a combo reinstall of 10.7.5 because I tried that too and have had no joy from it.  Let me start with one specific question I'd like the community's advice on:     I started a Spotlight reindexing after I did my system reinstall.  It told me 3 days.  But it was evening my time so I let the indexing run all night.  It's been running for over 16 hours now and tells me it has 34 hours to go.  If the progress bar is any indication, it's about a third done.  Since I can't get onto Apple tech support for another twenty hours in my time zone, I can't get advice from them–such as it might be–about whether to keep the re-indexing running for that time or give it up now.  Any thoughts from others would be appreciated.


    My second problem is whether to cast around trying more things that are suggested on this thread or wait till Apple fixes the 'issue'.  There seems to be a lot of repetition on this thread now, and it's getting hard for me to work out what is a new suggestion and what isn't.  And since nothing seems to be working for everyone...


    Backing up with Time Machine is important for me, but I can probably do a Carbon Copy Cloner backup until this Time Machine Problem gets sorted.  But in my work I rely on Spotlight to seach for content in my files. With no Spotlight index I feel blinded.  I've been looking for alternatives that will find content in pdfs and proprietory word processor files, but have come up empty.  Alfred seems to find content in open files, but not in particular directories, unless I'm using it wrong.  Does anyone know of any app that doesn't piggyback on Spotlight that will find content in a range of file types and in designated parts of the directory, like Spotlight should do when it works?


    Apple sure hasn't done itself proud with this issue, and like a lot of others, I'm getting just a bit annoyed.  So I beg the community's indulgence for the length of this rant.

  • Beaubarre Level 1 Level 1 (0 points)

    Went back to 10.7.4 too on two iMac 2006. It was easy with command + R at boot and using time machine, and I didn't lose anything because I have a partition with OSX and another for data (with symbolic links for most software), and you can choose which to restore under time machine.


    Reapply combo update didn't work for me, and my two imacs are not compatible with Mountain Lion.


    Backup of 1.4 mo under TM takes me 30 seconds now whereas under 10.7.5 it took me 30 minutes ! It is a great relief and I wonder why it took me so long to bite the bullet of downgrading.

  • John Galt Level 8 Level 8 (43,045 points)

    Mac From Start wrote:


    ... I can't get advice from them–such as it might be–about whether to keep the re-indexing running for that time or give it up now.  Any thoughts from others would be appreciated.




    I recommend badga's procedure here:


    10.7.5 Quick Fix Back to 10.7.4


    After you downgrade to 10.7.4, use Time Machine to restore whatever work you performed subsequent to that backup. Spotlight will have to reindex your HD but it and Time Machine's performance will be back to normal.


    This problem is a textbook illustration of what Time Machine was designed to address. Use it!


    The only functions you will lose will be whatever additional "improvements" were contained in the OS X 10.7.5 update. This is one "improvement" we can all live without.

  • Beaubarre Level 1 Level 1 (0 points)

    Looking at 10.7.5 details it says:

    - Resolve an issue using Spotlight to search an SMB server


    I guess that is the fix which went wrong.

  • pdugg Level 1 Level 1 (0 points)

    Well, 12 hours later and Spotlight progress indicator has climbed to 2 days. It seems cleaning the caches was promising initially but not so much now.


    But I will say that 2 days of estimated indexing is shorter than the 6 days I had before.

  • JackPot62 Level 1 Level 1 (0 points)

    Here is what I did:


    1. Switched of Spotlight


    2. Run Time Machine (at normal speed)


    3. Deleted ALL mdimporters which have nothing to do with the system.

    (Kept them in trash, you never know)


    In my case it was (user/library/spotlight AND library/spotlight):








    Wolfram Notebook.mdimporter


    4. Switched on Spotlight


    Before: 3 days

    After: 4 hours


    (I did NOT delete the Microsoft Office.mdimporter (library/spotlight)


    The solution? Maybe. We'll see…

  • martin21045 Level 1 Level 1 (0 points)

    I agree, I see no point in risking messing up something by a relative novice like me tampering with the Terminal. I am content to do without Time Machine, keep Spotlight running, and use Carbon Copy Cloner for now; I was using both Time Machine and CCC since I keep backups in multiple forms at a few locations. I am content to wait for Apple to bless us with the gift of a proper fix - in not too much more time I hope.


    I am really annoyed at how Apple upgrades tend to make older files/applications incompatible. For example I lost all trust in Apple word processores after MacWrite, and later Claris Works files became obsoleted. For all we tease Microsoft, at least I can still open up any version of Word or Excel - years and many OS's later. Because of that I am very hesitant to perform major OS upgrades; I only went to OS 10.7 recently and am really sorry that I updated beyond 10.7.4.


    Also I hate how Apple does not warn us in advance of upgrades when in their infinite wisdom they decide it is time for us to do without something. How many of you were more than angered when that Apple system upgrade rendered all our Apple USB modems obsolete. Steve Jobs may not have needed a modem but for many of us in business, that remained a necessity as not everybody E-Mails .pdf's yet (as much as I do prefer .pdf's).


    To add insult to injury that 10.7.5 inflicted: this evening I find that in addition to losing Time Machine with OS 10.7.5, my 32GB USB flash drive does not appear on my MacBook Pro! The drive sure shows up on my Windows PC, and on older Macs. I am reading similar complaints from others who have OS 10.7.5 and maybe some with 10.8.x too.


    I am growing more and more concerned that Apple is becoming the ugly, dominant bully that we used to think was Microsoft!



    Columbia, MD

  • Eugenio MORASSI Level 1 Level 1 (0 points)



    Restarted the MacBook in SAFE MODE and logged as root.


    Launched Onyx



    It's free (be sure to choose the correct one, for Mac OS X 10.7).


    At launch it verified the disk: DON'T skip this step. At the end, choose the


    Maintenance tab


    and run it with the only "spotlight Index" selected


    Then choose


    Automation tab


    with ALL options active and execute it (VERY SLOW, at least 4 hours).


    Then reboot normally ad DELETE the internal disk fron the


    Privacy tab


    in Spotlight preference pane.


    It builds the Spotlight (really!) and after an overnight indexing activity, this morning Spotlight worked as it should do.



  • Venares Level 1 Level 1 (0 points)

    Spotlight worked as it should do.

    What is about time machine - is it on normal speed while spotlight is on?

  • Eugenio MORASSI Level 1 Level 1 (0 points)

    I had no time to try.


    At the moment I've been able to have my Spotlight to revert to a normal behaviour.

    Before that, It will NEVER stop indexing.


    As soon as I try to use Time Machine I will let you know.

  • Dimaxum Level 5 Level 5 (5,985 points)



    To everybody who is struggeling with Spotlight.


    Read my latest post ...




  • Ra_ Level 1 Level 1 (10 points)

    Dimaxum wrote:




    To everybody who is struggeling with Spotlight.


    Read my latest post ...





    Doesn't work for me.

Previous 1 19 20 21 22 23 Next