Previous 1 25 26 27 28 29 Next 628 Replies Latest reply: Sep 6, 2014 11:42 PM by sbock Go to original post
  • paula_rachel Level 1 Level 1

    I followed the recommendation...


    I disconnected the external drive.



    sudo rm -rf /.Spotlight-V100/*

    rm -rf ~/.Trash/*

    sudo launchctl load -w /System/Library/LaunchDaemons/

    sudo mdutil -i on -E //:


    The result is this:

    After > 24 hours spotlight is still indexing on my macbook pro (319 GB of stuff) and I am watching in terrified fascination as the estimated time grows and grows... It is currently at 7 days... what shall I do :-(

  • pirinha Level 1 Level 1

    Same here. I disabled Spotlight to use Time Machine. I reported this bug to Apple. No feedback from the Apple Nerds

  • pdugg Level 1 Level 1

    Spotlight has finished indexing but the index is incomplete. For example, Safari is not found -- but the circular progress indicator never completes either. Safari was found while the index was being created.

  • HerrDrKarl Level 1 Level 1

    ArthurDNT wrote:



    Turn off TM or disconnect TM drive, then do a reboot. After this Spotlight works fast and efficient (maybe even faster than before using 10.7.4)




    Could somebody check whether this works in general and not just for me?


    My TM has been off and ejected for 4 days or so after I last turned Spotlight off to make a backup.  Zero improvement in Spotlight completion time.

  Spotlight just finished!  When I started typing this message, it said 23 hours, as it has for several days.  Mystery.


    The only new thing I've done the last day or so is allow my Mac Pro to go to sleep... I'd kept it 'always on' thinking it would encourage Spotlight to finish.  Maybe Spotlight just needed a nap. ;-)



  • HerrDrKarl Level 1 Level 1

    TM will not make any progress even though Spotlight miraculously finished indexing my Mac Pro.


    TM to my FW800 backup drive has just sitting at zero of 5.44 GB.


    Activity Monitor shows mdworker as the most active process at 45%). backupd appears once in a while at 0%, fseventd, dbfseventd also appear now and then at 0%.  Disk Activity showed some slow access (2 mbps ramping up to 10 mbps for a half second) - but mostly no disk activity at all.


    So, one new data point:  having Spotlight complete is not enough to allow TM to run.  Spotlight must be turned off with one of the several techniques in this and the spotlight threads. :-(


    I disabled Spotlight indexing using Terminal with:

    sudo mdutil -a -i off

    This canceled the non-progressing backup.  Started backup again, and this time backupd is using 140% CPU then mdworker  using 15-50% then back to backupd getting 20 to 90% or so (and 8% for mds) during a fairly long 'Preparing backup..." barber-shop progress bar.  Finally, after 15 minutes, I see 'backing up zero KB of 5.44 GB" again .... but no disk activity and no progress.


    This sudo mdutil worked for me the other day, but nothing backing up with it now.  Will try again with:


    sudo launchctl unload -w /System/Library/LaunchDaemons/


    which also worked the other day...


    backupd (140%) and fseventsd (20%) are the top CPU processes now... which makes more sense...'preparing backup' barber-shop pole in the progress bar... not much disk activity...for about 5 minutes ... now backing up but says that there is now 30.07 GB  to back up vs the 5.44 GB reported earlier.  Progressing at up to 30 MB/sec, typically 10 to 20 MB/sec, so reasonably normal.


    Lessons from Montana:


    1.  Spotlight completing indexing on 10.7.5 does not help Time Machine at all; you still have to disable Spotlight to get TM to do its thing


    2. the sudo mdutil command to stop Spotlight is not good enough to get TM to run.  Have to unload the daemon with the sudo launchctl command


    3.  Something is strangely amiss in the file system database if TM thought I had 5 GB to backup when Spotlight was enabled and is actually backing up 30 GB with Spotlight unloaded.  The 5 GB made sense, knowing what I've done since the last backup;  30 GB doesn't.  No longer have confidence in Time Machine.



  • salvofromlondon Level 1 Level 1

    This iS so frustate, how can i do time machine back back ! Take ages , anyone knows? when apple will release an update to risolve the issue?

  • salvofromlondon Level 1 Level 1

    Same here i cannot do a time machine back up ! takes ages , like 20 days !!! Apple do something !

  • michaelfromseal beach Level 1 Level 1

    Report one day later: Happy to say that reverting to 10.7.4 looks like the way to go. I did it 24 hours ago, and TM and spotlight have both worked flawlessly ever since: incremental backups by TM are taking about 1 minute, 10 seconds.  Spotlight fully indexed.


    This is the recommendation by Apple tech support, pending a more complete patch and/or update. It can be done from a TM backup, choose the latest 10.7.4 backup from your restore list.


    It is true that if you have any programs with file changes since then, you'll have to restore them, though in my case in most respects could be done from TM, which would retain all post-10.7.5 files. You won't have to disable Spotlight to backup, or implement any of the other burdensome workarounds proposed on this thread.


    Now the question is: What happens the next time Apple issues a Lion upgrade? I know I won't be installing until I get a full report from the field, via this group.

  • Bakerchief Level 1 Level 1

    Didn't work quite as smoothly for me. Spotlight still tediously slow and is clearly the root cause of this bug.


    Like everyone else, this all started when I tried to backup with TM after updating to 10.7.5. The eta went from 4 hours to more than 7 days. I thought it was my external drive so, like many others, I reformatted and tried again but that made no difference. I even went out and bought a brand new external drive! Then I started reading this thread and followed the advice of many of you. 


    Here's what I have done so far.


    1. Disabled Spotlight using the Terminal command listed several times in this thread <sudo launchctl unload...>

    2. Rebooted

    3. Conducted the TM backup (which was strangley 26GB less with Spotlight disabled)

    4. Rebooted

    5. Enabled Spotlight using the Terminal command <sudo launchctl load...>

    6. Plugged in my external drive again to allow the incremental backup (less than 100MB) but it froze again.

    7. Turnedd of TM and disconnected external drive

    8. Downloaded and installed Spotless

    9. Used Spotless to disable Spotlight

    10. Plugged in external drive and started TM again. Incremental back up took about 3 minutes.

    11. Turned off TM and disconnected external drive.

    12. Rebooted

    13. Used Spotless to enable Spotlight - indexing began and estimated at 2 hours


    That was over 24 hours ago, estimated time is currently 3 days.


    We need to hound Apple with constant feedback reports to get their engineers off their butts on this. If you following this thread then, as suggested by others, take two minutes of your time and fill out the online feedback form at

  • Gallospole Level 1 Level 1

    I reinstalled 10.7.5 and it marginally improved TM. But it still gets hung up. We've been fckn with this for about 3 days now and after a litany of tests and trials, it's my firm belief it's an OS 10.7.5 bug. Prior to this update, TM performed fine.


    Btw, deactivating Spotlight will do nothing. Believe me, I tried it.


    I'm in touch with their senior techs at Apple Care but they only wish to reinstall the OS instead of escalating it to the developers.


    First maps now this......***!

  • Mac From Start Level 1 Level 1

    Just for information, I took this matter up with an Apple senior tech support person late last week.  Not surprisingly, the matter has already been escalated to the engineering division, or at least so I've been told.  I've also been told to expect a response from them before the end of the week.

  • Glenn Cogar Level 1 Level 1

    Hi all.  I have the same problem too.


    Rather than go without a backup while Apple resolved the issue, I decided to use CarbonCloner from Bombich Software.  It has an incremental backup feature, not too different to Time Machine and also allows you to create a bootable backup.




    Ive only ever used it in the past to create a bootable copy of my system in case I need it but its providing an alternative backup for me while Apple resolve the Time Machine and Spotlight issues.


    Its good to know everything is backed up as I was worried this issue may cause a loss of data in backups as some have reported.

  • BrownBrady Level 1 Level 1

    I have the same problem. I don't know how long this has been going on but I only noticed it 2 days ago. My spotlight indexer tells me it will take 2 weeks to finish. My Time Machine was running the whole day today very slowly so I just disabled it. CPU and disk activity was almost non-existent, so I don't know what is happening there. This is on my Mac Pro 1,1 2006 on Mac OS X 10.7.5. May MBP on Mountain Lion does not have this problem.

  • metalman213 Level 1 Level 1

    Its Spotlight everyone. Just stopped background indexing with Spotless 4.0 and my time machine is now back to normal. I have to back up 880gb and just before stopping the indexing, it was at 250 mb. So get Spotless and stop indexing on the master hd

  • metalman213 Level 1 Level 1

    Its Spotlight everyone. Just stopped background indexing with Spotless 4.0 and my time machine is now back to normal. I have to back up 880gb and just before stopping the indexing, it was at 250 mb. So get Spotless and stop indexing on the master hd

Previous 1 25 26 27 28 29 Next